Sign in with
Sign up | Sign in
Your question
Solved

Vista Boot Manager

Last response: in Windows Vista
Share
March 27, 2007 7:39:16 PM

I use to have XP and Vista in a dual boot configuration. I removed the xp partition, following the instructions listed below, but when vista boots it still gives me the OS selection screen. The weird part is now the OS selections screen has vista listed twice and no instance of xp. Can anyone tell me what I need to do to remove the two instances, or just have it boot straight to vista without giving me the boot manager screen.

Place your XP disc in the tray and reboot. Press any key to boot from CD

Once you have reached the setup page, press R to start the recovery console

You should eventually see a screen listing 1) XP and 2) Vista. It will ask you which operating system you wish to fix/restore. Press 1 for XP and hit enter. It will ask you no admin password, if you have no password, leave it blank and hit enter.

Now at the command prompt type fixboot. It will give you a warning and ask if you are sure. Press Y and hit enter.

Now at the command prompt type fixmbr. Again it will give you a warning and ask if you are sure. Press Y and hit enter.

That is it. Now type exit and your system will reboot with only XP on the boot.

Now when you get back into XP you will see your vista D drive is still there and you can access your files. This is your chance to recover any files you forgot to backup. Simply browse the D drive for the files you want and bring them back to your C partition. When you are confident you no longer want the vista drive, simply right click it and select format.

More about : vista boot manager

Best solution

March 28, 2007 5:24:53 AM

It has been a long while since I did multi-boot (way back in OS/2 days)... It's all in the boot.ini file, look at it. Not knowing how advanced you are... In Vista: (this aproach could be painful since it requires you to be a super-admin or turn off UAC) - Select the start icon -> accessories -> run -> cmd... from cmd enter "bootcfg /?" This will give you a list of the commands... Enter "bootcfg /Query"; this will probably show you that XP is still a boot option. From there you can either do a '/delete' option ("bootcfg /delete ?") or possibly consider just deleting the entire file

OR

Open 'System' and select 'System Properties' on the left side of the screen. Then 'Advanced', the 'Startup and Recovery'. In there you can set the default to Vista and clear the checkmark on 'Time to display list of operating systems' or set the time to 0 (or 1) sec-> onds.

AND/OR go to the MS knowledgebase and look for any solutions...

fwiw, I would probably just find boot.ini and delete it and let the default values take over!

Good luck
Share
March 28, 2007 3:36:27 PM

thanks. boots straight to vista now.
m
0
l
!