Sign in with
Sign up | Sign in
Your question

Joystick/DirectX 9.0c DirectInput Problem in XP SP2

Last response: in Windows XP
Share
April 1, 2007 10:58:47 PM

I have a problem that if I run dxdiag it crashes, the next run it puts up a message that there was a problem last time with directinput and do you want to bypass that section.

If you answer yes, dxdiag runs but the input tab is empty (no devices). If you answer No, then it crashes and you get the send the problem report to Microsoft dialog (which refers to dinput8.dll).

Another piece of the puzzle is that in the Control panel, if you attempt to open the game controllers icon, nothing happens so it looks like it may be a problem with something corrupted related to joysticks (nothing else used for game contrllers).

I had an older sidewinder pro hooked up to the Audigy sound card game port input. I borrowed a USB based wingman digital 3D (USB) and installed it. It configures fine with the latest Logitech software. However, still can't open Game Controllers nor does directinput appear to work.

I've tried re-installing directx (web and redist) but that's a waste of time as it just seems to check that 9.0c is already installed and then closes.

I've also tried reinstalling the DirectX End-User Runtimes library but no improvement.

Any suggestions besides reinstall windows (be nice)?? Thanks.
February 25, 2009 6:36:56 PM

I got that same problem and after many days i finally figured it out. All what i need to do is completely remove Aiptek 140000U Media Tablet drivers and included software.
And voila, dxdiag works like a charm, no more complaining DirectInput and no more black screen when starting a game..
!