Folding@Home Troubleshooting

I think it will be useful to have a thread dedicated to troubleshooting the Folding@Home client.

To get the ball rolling, I've had some trouble today. First, my client expired. This hadn't been an issue until I rebooted my computer. I installed a new client into the same directory in the hopes of not losing 40 hours of work, and good news: it worked. However, I seem unable to start a new WU now that the last one is handed in.

I tried deleting everything and starting from scratch, but I keep getting an error. I'm running the Linux 64-bit SMP client, downloaded 2 April 2007.
The error I'm getting is that the client seems to be in an infinite loop where it detects a problem, kills everything, and then starts by re-downloading the core and then connecting to an assignment server and attempts to get work. It then detects the problem again and restarts the cycle. The only line that seems to indicate a problem is:

client-core communication error (0x7f)[/code:1:f65398017c]

Any idea as to what's going wrong so I can fix it? I tried searching on Google, but the only thing I found was that someone was having a problem and using the -local flag fixed it for him for a while. This makes no sense since the Linux client automatically runs with the -local flag.

Edit: Well, I've had some progress on this issue. I deleted everything and re-installed FAH from scratch. This didn't by itself fix everything, but I was getting a different problem at least. Now my client would hang at the NNODES=4 line. Searching for a solution for this problem was much more productive, and I was directed to investigate my network settings (the beta SMP client is known to be sensitive to network settings).

Well, this prompted my memory that I tried changing a couple settings to get file sharing working on a windows network. I had changed my domain name to "Home", and apparently this broke my FAH client. I got rid of the "Home" name in the Domain Name field under Networking >> General, as well as I had to delete the ".Home" that had been affixed to the 127.0.1.1 line under the Hosts tab. Doing these two things and restarting the X-server, I was able to get my FAH client up and running.

A guide to fixing this problem is available on the [url=http://folding.stanford.edu/FAQ-SMP.html]SMP FAQ page[/url], under the "Troubleshooting the Client" heading.
11 answers Last reply
More about folding home troubleshooting
  1. Glad to see you figured it out Hotfoot. :D Didn't I see another thread around here with somebody that has the same error?

    I also have a problem with my Linux SMP client on my native Ubuntu 6.10 installation. For some reason one night when the screensaver came on the client slowed to half speed. Since then I disabled the screensaver, power options, sleep, hibernate, etc. Still only goes half speed, like it is using only one core. I tried reinstalling the client, and then Ubuntu, but no luck. Everything works fine if I run the client on Ubuntu through VMware server.

    I was just gonna wait until feisty is released and try again unless someone knows something.
  2. This is a very strange problem... it's almost as if the Linux kernel stopped recognising one of your cores. What appears under System >> Administration >> System Monitor?

    I don't think it could be that problem, since I'm pretty sure any 64-bit kernel available is SMP aware.
  3. I tried it again last night, reinstalled the client again. No change, still takes 25 minutes per frame. I checked the system monitor, it's using both cores.
  4. Is all this work with the same WU? It might just be that the particular solution has gotten itself into a complicated mode. 25 minutes/frame is very high.... even my PD@3.36GHz goes through a project 2605 frame in 24 minutes.
  5. Run top and see if anything else is chewing up CPU. Hit the letter p to sort by CPU usage.
  6. Nope, nothing else is using the CPU.

    The projects in question are 2604 and 2605. When the Linux client worked properly I could do a frame in 11:30 min. Now it's about 24 or 25 minutes. The client works ok on the same kernel through VMware server.

    There are two things that happened before it slowed down. When I first installed a Native Linux it worked fine. Was good for a few days. Last thing I remember was doing updates and going to bed. One of the new updates was kernel 6.11.something. And the screensaver/sleep/power saving options kicked in. The next morning I notice it's been running slowly all night since approximatly the time it would have started the screensaver.

    Since then, I've reinstalled Ubuntu and the client a couple of times, no luck. So I think I'm gonna have to wait for Feisty to be released (Apr 17?) and try again. Or try a different distro, but I like Ubuntu.
  7. ok, i just installed Folding@home... got it running but when i check the status on it, this is what o get:

    ~/foldingathome/folding status

    ['folding' ver. 5.4]

    Status of running FAH client(s) on 2 processor(s):
    Status on all possible FAH client(s):
    FAH504-Linux.exe (pid 7346) is running
    !!! Strange - No FAH cores downloaded !!!
    Status on all possible 'FaH' scripts:
    FaH (pid 7344) is running


    Status of FAH client(s): OK


    does this mean things are good & set... Im new to linux so dont really know..


    thx,
    Nick
  8. I've never used the status feature. Do you have folding running in a console? You'll know it's working if it updates every-so-often saying x number of y frames completed (z percent).

    Since you have a dual core machine, why not try the SMP client? This is only recommendable if you're leaving your machine on all the time, otherwise stick to the regular 5.04 client. Also, you currently need a 64-bit version of linux to do the SMP.
  9. Hey Hotfoot,
    You just passed me on the team but it only shows 195 w/u. Is it just that many for Tom's but it carries points from pior teams?

    At any rate, perhaps you know the answer to a problem I'm having... I just built a Vista box with an overclocked Core2 Duo. I'm using the regular graphical client 5.03. At first it seemed to go real slow then all of a sudden it seemed to be 3/4th through the work unit. Now it just sits there saying downloading error.

    I've done a fair amount of stability testing on this overclock, so I'm confident it's stable. I'm running the chip at 2.8 GHz (it's a 6300 chip) but have tested it as high as 3.2 GHz with no issues.

    I added the Folding program to the exceptions list on the firewall, then turned the Vista firewall off completely. Still said downloading error. I did some searching on the web, but didn't find an answer. Any ideas?

    I suppose I should just try reinstalling the client, but I came looking for the guy who passed me with 195 work units :x

    Thanks,
  10. I've only ever folded for THG. The reason I have so few WUs is because about a month into folding, I switched to using the SMP client. I currently have 3 dual-core computers working away, but that's soon to be reduced to 2.

    I strongly recommend using the SMP client if you have a Core 2 Duo - this chip is far and away faster than anything I'm running... at 2.8 GHz you should be twice as fast as me. So long as you leave your computer on all the time - the deadlines are quite tight - you will have much higher points/day - in the 1400/day region if I'm estimating right for your computer.

    As for your problems with Vista, I'm sorry I can't help you myself. I have no experience with Vista (I've never even seen a computer running it first-hand). Consider this post a bump to help get more attention from others who can help you.
  11. Thanks HotFoot, I'll look into the SMP client. I normally don't leave this Vista box running all the time, but I just might do it for a while to gain a few positions back on the team :) At one point I was 16th, but have been passed a bunch of late. I don't run as many boxes as I used to...

    It's kind of funny. The two boxes I run 24/7 on Folding are a couple of old Athlon XP rigs. I have a couple of other dual cores besides this new Core2 Duo; a PentiumD 805 overclocked to 3.4 and an Athlon64 X2 3800 clocked to 2.6 GHz. I might try the SMP client on the Athlon64 box and just leave it on.
Ask a new question

Read More

Distributed Computing Apps