NIC prob under Mandrake 8.0

OK...........(Takes a deep breath and burns another pic of Bill Gates)

I am new to Linux but have used PC's since 8088's came out.
I have installed Mandrake 8.0. on my second HD (Win98 on first). I have a cable connection. Cable NIC is a RTL8029. It is found during install and internet is available with no problems. LAN card is Dlink DFE-538TX. It is also found during install. Mandrake uses 8139t00 as all the posts I have read says it should. Its "unknown" under Harddrake. I cannot get the connection sharing to run. Until I can fix this, I cannot learn/use Linux as the rest of the family cannot get online (Two other pc's running Win98)

Can anyone give me some help with this ? I can't keep taking Tylenol in such large amounts !


The sum of the intelligence on the planet is a constant; the population is growing.
5 answers Last reply
More about prob mandrake
  1. In order to get my internet working with Mandrake, I had to do two things:

    1. Make sure DHCP is selected in the install and...

    2. Turn off PnP OS in the BIOS.

    I don't know why I had to disable the PnP function, but it just won't work with it enabled.

    Lyrics. Wasted time between solos.
  2. You had to turn off PNP in your BIOS to get the internet, or to share it with other PC's ? My internet works fine, its my second NIC that is in the "Other" list under Harddrake.

    The sum of the intelligence on the planet is a constant; the population is growing.
  3. I had to turn it off to do anything with my NIC. It was detected, but during the checklist that comes up during the boot process, it said it couldn't bring up the interface eth.lo

    Lyrics. Wasted time between solos.
  4. orry Nial, but could you clarify one thing for me?

    Is the NIC working - ie ifconfig -a shows 2 eth adapters), and "internet sharing" - ie routing between the NICs isn't?

    Or do you only have one working NIC?

  5. Hey.....

    The card is STILL listed as "Other Devices" but I do get this info"

    eth0: RealTek RTL-8029 found at 0xa400, IRQ 10, 00:00:21:DE:8A:07.
    eth1: D-Link DFE-538TX (RealTek RTL8139) at 0xd28a0000, 00:50:ba:51:91:63, IRQ 4
    eth1: Identified 8139 chip type 'RTL-8139C'
    eth1: Setting 100mbps full-duplex based on auto-negotiated partner ability 45e1.

    I got the internet sharing to work, but I have to use DHCP !
    This sucks as I still need to boot to Windoze for work and I use sygste to share with and hide the other 2 PC's in the house. Now, if I get a call and have to logon to the mainframe, I have to boot my PC to windoze, and the other PC's have to change thier IP settings and boot as well to get on.

    Any idea why "Other divices" when OS can clearly see EXACTLY what it is ?
    How about a static IP for the LAN ?


    The sum of the intelligence on the planet is a constant; the population is growing.
Ask a new question