Sign in with
Sign up | Sign in
Your question

Peculiar problem with HDDs - Problem Solved

Last response: in Storage
Share
May 3, 2007 1:10:02 AM

I have three WD5000AAKS SATA2 drives. All the drives exhibit the same issue. When, I do prolonged file transfers or writing to the disks they timeout or I'll get lots of errors in my event log stating that the drive has bad sectors. I've scanned the drives with various utilities that do not report anything wrong with the drives. I initially thought that this could be a problem with my RAID 0 so I rebuilt the array. The problem persisted. I rebuilt it as a JBOD. The problem persisted. I deleted the JBOD and just used the drives independently and the problem persisted. I moved them to a different SATA controller (from the ULI M1575 to the Silicon Image) and the problem went away. I also mounted them in a different computer and the problem did not occur. Now ordinarily I'd just assume that there is an issue with the ULI M1575 controller but I've been able to set up other RAIDs on this controller with no problems. Currently I have two WD 74GB Raptors (SATA) running on it without any problems. The motherboard I am using is the ASUS A8R32-MVP. The Raptors run off the 1 and 2 SATA ports on the controller although I have not been able to test it with the 3 and 4 ports (those are the ones that the 500GB drives connect to). Any thoughts? I'd really not like this problem to be my motherboard but I guess I don't have a choice in this. Is the ULI M1575 picky about mixing SATA and SATA2 on the same controller? Does Windows have problems with 500GB drives? Any stabs in the dark I could take?

Oh, I did search for this but found no similar problems. I usually get the problem when copying a DVD to the HDD using DVD Decrypter or DVD Shrink. Additionally, I do not have any free PCI slots available for a seperate RAID controller otherwise I would have just done that.
May 3, 2007 2:22:15 AM

Your WD5000AAKS drives are SATA-300, while the Raptors are SATA-150. Perhaps the ULI M1575 controller has an issue with speed negotiation with SATA-300 drives. (There are other chipsets/controllers that have this issue, such as the Intel ICH5, normally paired with the 865P or 875P northbridge).

Try setting the jumper on the WD drives to force SATA-150 operation and see if the problem disappears.
May 3, 2007 2:28:05 AM

Any idea what the jumper position would be? There is no key printed on the drive although some pins are labelled: blank, PM2, OPT1, FW, Blank.
Related resources
May 3, 2007 3:27:10 AM

Quote:
I believe it will be the "OPT1" set of pins.

Western Digital tech note


Problem solved. Thanks. I forgot all about being able to force SATA 150.
!