problem with daisy chained wireless router

Has anyone had any issues in the past with hooking up a wireless router (via its uplink port) to a switch hub router that is hooked into a cable modem? The switch is an 8 port D-link, and the wireless router is a brand new 4 port wireless netgear router. I was able to setup the netgear for one of my laptops, but the other laptop has trouble staying connected to wireless. Moreover, even when it is able to access the internet via the wireless connection, it says that it is not connected to the network (even though it also indicates it is connected by having the "disconnect" button active). After about 5-10 minutes of receiving packets, the connection will truly disconnect, but it can be fixed by repairing the connection (albeit temporarily).

Any ideas? I was told by someone that I needed to make my wireless router have a static IP on the internal network, but wheneven I try that I have to inset DNS addresses, and I don't know what to do about that. Any help is greatly appreciated!
2 answers Last reply
More about problem daisy chained wireless router
  1. Ideal setup would be hooking the Modem into your router's uplink. Hook the other router into an open port on your router. Note, this second router should have DHCP disabled otherwise you will come into conflicts when assigning IP addresses.

    Your second router, with DHCP disabled and not using the Uplink port will only act as a Switch - this is exactly what you want it to do.
  2. Just in case you have trouble with this approach, you could try this...
    1. Connect Modem to Router 1 (doesn't matter which one)
    2. Set Router 1 IP address to
    3. Enable DHCP on Router 1
    4. Set a static address range on Router 1 (example: to is static - rest is available for DHCP)
    5. Connect Router 2 to Router 1 (don't bother with uplink ports on either) using ethernet cable
    6. Disable DHCP on Router 2
    7. Set Router 2 IP Address to (or any other address that is within the static range set in Step 4 above
    8. Set the Router 2 to get DNS from ISP (in your case, it will get it from Router 1)
    9. Ensure you have WPA (else, at least WEP) enabled on your wireless.
Ask a new question

Read More

Wireless Router Wireless Connection Networking