Sign in with
Sign up | Sign in
Your question
Closed

Hard drives wont reactivate

Last response: in Windows Vista
Share
May 28, 2007 6:32:08 AM

I had Vista with 4 HD working fine for a couple of days

then on a restart one of the drives did not load I tried everything to reactivate it but nothing worked

I then decided to switch the cables and now none of the drives except the one with Vista loads

Vista gives me a message saying that drivers are being installed for then each time I switch the connections

of the ones that dont work 2 are SATA and one is IDE

they show in Bios, Device manager and computer management were if I try to reactivate I get a message saying "The attempted operation is invalid. Either the parameters parameters specified are invalid or the operation cannot be completed on the selected object
May 28, 2007 7:31:14 AM

Are you trying to use any of these as a raid setup or are you just using them as c:..f: ?

I have a few additional questions since you may be changing your configuration around. is it correct to assume that c: is an ide (pata) drive? Does your bios support having your primary drive as a pata when sata drives exist? Have you recently checked to see if your ide drives are properly configured (master/slave)? Are you trying to connect any other ide devices (cd, dvd, or...)? Have you tried to just use the ide drives, not even attempting to connect the sata drives?

Since some configuration of yours did succesfully work with Vista for a while, this should probably be moved to the hardware section (I do not think your problem is related to Vista).

Best
--DD
May 28, 2007 10:25:23 AM

I figured it was Vista since they do show up on Vista

they're just being used as single drives

the primary disk is also SATA

I have an optical drive connected to IDE and a hard drives as a slave on the same cable

Vista sees them and installs drivers for them but I cant reactivate them

I've tried to connect just one and it still doesnt work
Related resources
May 28, 2007 5:39:40 PM

Quote:
I have an optical drive connected to IDE and a hard drives as a slave on the same cable

Vista sees them and installs drivers for them but I cant reactivate them

IMO, It sounds like you may have a couple of different issues.

This one is totally optional but I think you should consider it; you may just want to skip to the next paragraph and just see what Vista thinks you have... first, you may want to unplug the optical drive until you get your system configured the way you want it; I will guess that it is being seen as "D:", which may interfere with your plans (see 'disk management' below). you say that you had two ide drives working and I will assume that you also had the optical device connected too. - so now I can assume that mobo has two ide connectors (some only have one). I would start by leaving the optical device on a cable by itself (preferably ide1), it is normally a slower device and ide will only be as fast as the slowest device. If you do decide to leave the HD and DVD R/W (another assumption) on the same cable, you should still set the HD as M and DVD as S. If you do put your drives on separate cables, remember to look and verify the M/S jumpers on the hard drives. Once you have those installed, Vista will see them - this is mostly where you are now but if you rearrange the cables now you will have better performance.

Next, it just may have a terminology issue, I don't know about 'activating' a hard-drive. I think what you are trying to do is just see your drives as D:, E:, and F:. You may need to do a few things - in control panel open administrator tools and then select 'computer management', then select 'disk management'. All of your drives should show up here (including your DVD, probably seen as a CD without any media in place). In earlier Windows systems, you used to be able to plug a drive in and format it - I am not sure that is still the case. Now I think you must create a partition (volume) and then either assign a letter to it or take a default, that Vista assigns.

Your booting sata drive will be the first one you see and it will have the drive letter "C"; then (just guessing) you will see your other drives but they will have all of their space defined as 'unallocated'. If that is the case (this is a destructive process, be careful), then you will need to create a partition on the drive (you have many options and you can read up on them but this would probably be a standard setup). Right click on the drive you want to work on and select 'New Simple Volume'; in the pop-up, take the default (should be all or almost all of the available, unallocated space). Next select the new volume (right click) and chose format, selecting ntfs and everthing else as a default (also you can set the drive letter that you want).
If the space appears to be in a volume, you just may need to assign a drive letter for it to be visible.

Also if you want to, when all of your drives are physically installed, post a copy of the 'disk management' screen on your site.

--DD
May 28, 2007 9:30:09 PM

:lol:  cute... thanks for posting that screen; now I know much more about you and your system. this is either a big screw-up that you just happened to stumble into (in which case you really do need clean-up assistance) OR you are just being the pig that your ID also implies (and you are very familiar with what is happening and only fending idiocy). I.e. your display shows that it is not a 'simple' or 'basic' 4 independant drive setup (c..f) as you were implying, prolly had raid setup at one time...

one more try at being nice, do you have data on these drives, that you need to get access to OR can you just format all but drive C to get your system fixed up and running again?

If you are the former, then here is a HINT: There are many links in the 'disk management' help pages regarding repairing dynamic disk and also, MS has many KB links for working with those stupid dynamic disks (aka jbod, IMO) that some idiots set up back during w2k days -- if you are only 'trying' to upgrade to Vista, reconsider that move until you get your other technologies up to speed.

Best
--DD
:) 
May 28, 2007 10:01:17 PM

I never set it up as raid, I installed Vista with no drives on and then just connected all the drives at once, they all worked fine for a couple of days and then the problems started

I keep all my files on these drives I cannot lose anything on them

I've been reading up on Microsoft's sites as well as disk management's help file for the past 2 days and nothing

this is basically all I've done for the past 2 days, I've spent my Memorial Day messing with my PC

I have other pc's but they dont support SATA

btw its read as Por Ke not porky

thanks for all the help you're the only one who has even attempted to help
May 28, 2007 11:10:42 PM

I'm sorry porque, sometime there really are some true porkers around here (no offense intended :)  ). After your last message I did a bit more research and found that there truly is a significant issue with some, when using Vista Home and they are just re-using existing devices (I suspect it is just a hole with the w2k3 server core that Vista is based on). I am using Ultimate and have had no problems but... I did a completely clean install; formatted all of my drives specifically for the new ntfs release; and then restored all of my data directly from digital tapes (I didn't want to have any problems and for me, it has worked!).

However, you are not alone, others apparently are having the same problem. Here is a link that may start to give you more information (hint, back up from there and let me know if it doesn't work)...

http://windowshelp.microsoft.com/communities/newsgroups...

Also, I'll look around specifically for this and see if I can find some more info. I am sure that MS has addressed the problem and has a solution in the KB, you have just not entered the correct combination of key words.

Really, this serious problem should have been caught on your system, on day one... Are you using automatic updates (or have you even done the Vista automatic updates thing yet)?

Best
--DD
May 28, 2007 11:21:41 PM

I updated Vista Ultimate last Friday(installed it Wednesday) problem started saturday

I've also found others with the problem but haven't found a solution other than putting all my hard drives on a different computer then moving the files to another drive and formatting the drives

problem is these 3 drives are very big and full (200GB, 250GB and 500GB)

I've always wanted to save my files to digital tapes for backup but I never really read on it.

I knew I should have stuck with XP on my new system
May 28, 2007 11:32:43 PM

here is a KB article that deals specifically with this problem (8 or 9 ways to approach it) --- I am sure there are more available, it seems to enter the Vista environment, primarily via MCE and w2k; MS cannot let it just die. they either have or soon will have a hot-fix (hang on to the key-words). ...and you just may need to be patient as I don't see any, obvious solution yet (good luck).

http://support.microsoft.com/kb/927520/en-us

--DD
May 29, 2007 12:20:04 AM

I had the same problem with 2 300GB SATA drives moving from MCE to Ultimate. I went through everything I could find to no avail. I wound up installing another drive, then used File Scavenger to restore one drive onto the new one. Then I reformatted that drive and used FS again to recover the other one onto the old drive. (File Scavenger is not free ($50), but it works. There is another, open source data recovery tool - but I can't remember the name - nor do I know if it works with Vista - hopefully someone else can chime in here to save you a few bucks if you go this route).

When I had this problem, MS didn't have any knowlege Base info, and every website just kept saving to "Right-Click and choose ReActivate Drive" - I had assumed that I had unbelievable bad luck having 2 drives go bad at once (I have to "wiggle" the drives a little to get them to fit in the drive bays in my new case, and I thought maybe I jostled a little too hard (they are Maxtor - the #1 name in POS drives. :p  ) )

You might want to try contacting your Mobo manufacturer to see if they have a BIOS or Chipset Driver fix, or contact MS directly since, according to dblD's link, they are aware of the problem - maybe the Tech Support people have a workaround.

If you do get a resolution, please let us know, so that others can be helped if this comes up again.

Sorry for the no help.
May 29, 2007 1:35:21 AM

man I'm on my way out will try this in the morning

hope it works

thanks
May 30, 2007 11:25:22 AM

Came back yesterday and Vista would not start. I would get the BSOD on restart, I tried Vista's recovery program that comes on the cd and was told it couldn't repair the damage.

btw was the suggestion of dblD's link to restart the pc with the drives off and then reconnect them? I did that before and it loaded the drives for them and still nothing.

check this pic I posted before
http://img180.imageshack.us/img180/8730/untitledgq1.jpg
June 20, 2007 1:32:11 PM

had to do the same as exit2dos except I used EasyRecovery Professional

one of the 3 drives(the IDE) still will not work
!