Sign in with
Sign up | Sign in
Your question

Wont let me install games!

Last response: in Windows Vista
Share
June 1, 2007 8:05:15 AM

So.. I have been trying to install a few games -- F.E.A.R., CS:S, and WoW but once I pop the CD into the drive and click "install" (or whatever button it may be for that certain game) nothing happens! I then try to go to "Computer" and then double click on the drive manually and the same things happens. The little isntall menu pops up but once I click install nothing happens! Has anyone else run into this situation? .... Anyone have any possible solutions? Thanks in advance!

~ckburnham

More about : wont install games

June 4, 2007 4:18:27 AM

Hey ck,

I've had the same problem with F.E.A.R. and I just bought the game so I was pretty pissed.

I solved the problem by downgrading to XP. Also, I noticed a lot of changes to my games, especially Oblivion; game loads faster, no more framing and better graphics performance.

My advice, go back to XP for another 6 months when games start utilizing Vista and DX10 and keep your Vista CD around and handy.
June 5, 2007 8:58:39 AM

I have all those games installed under Vista 64, didn't have a problem. I did notice that it can take awhile to load up as it seems to be 'thinking about it'. It happens too when I click on patches that are rather large (hundreds of megs). Takes awhile but get there in the end.

Once installed that games run/load fine.
Related resources
June 5, 2007 3:04:04 PM

Heh! Sounds like what happened to me.

Try replacing the IDE cable :wink:

For me, my DVD-ROM worked flawlessly under XP. For some weird reason, when I went to Vista, it quit working.

Went out and bought an $80 DVD-RW Drive thinking it'd help... psh

Ended up being the stupid IDE cable!!!

Check your cable, then come back and let us know ;) 

I've installed WoW, F.E.A.R., S.T.A.L.K.E.R., BF2142, 50% of Valve's games, Oblivion, etc. All work just fine, disregarding the FPS due to video drivers :tongue:
June 6, 2007 1:28:45 PM

With nearly all installs of games I have to explore the cd and run the setup.exe as administrator.. works fine then. No longer a problem for newer games.
!