Sign in with
Sign up | Sign in
Your question

CORSAIR CMPSU-620HX + Epox AF590SLI2

Last response: in Components
Share
May 6, 2007 6:23:46 AM

I've been running into a problem with this combination. The only indication of power to the motherboard is the network lights flicker for a moment. I also tried this power supply on another working computer and again little-to-nothing happened. Before I claim that it is completely broken and return it I am concerned that maybe the issue is the power supply compatibility with the motherboard. In which case I should return the power supply and pick a new one.

It is unclear what the ATX12V version is for the motherboard... which seems odd...

Any help/comments would be appreciated. Thanks!

Corsair Power Supply + Epox Motherboard (Epox Link)

Oh one odd thing that dawned on me is that one of the connectors is completely empty and doesn't have a cable on the 24-pin connector... this matched the picture on newegg so I am not overly concerned... but it seemed strange!

More about : corsair cmpsu 620hx epox af590sli2

May 6, 2007 5:26:07 PM

Thanks for the response. I figured it was a bad power supply. I also tried using both the 4 & 8 pin connector in the P4 power connection.

Hopefully I can get a new *working* one!

Edit: Why is the -5v connector missing from new power supplies... is that for the latest ATX12V version.
!