Sign in with
Sign up | Sign in
Your question

boot takes over 10 minutes! and slave drive gone!

Last response: in Windows XP
Share
June 5, 2007 1:47:41 AM

when i saw the "found new hardware" balloon after plugging in my friends usb-stick i was very sceptical about letting it install anything (as i am almost always very cautious installing anything)
to my horror, the computer will now stall at the windows logo everytime i turn it on, and it takes almost ten minutes for windows to boot.

i uninstalled the driver (in: add remove programs) for that damned usb-key, but the problem still persists.

i should also note that when booting in safe mode, it stalls for about a minute only, but at the file: GIVEIO.SYS (in sys32 folder)

so i deleted the GIVEIO.SYS file, but problem still there


is there any way i can "UNDO" the last thing i installed in the computer?
or another way to completely remove all of the usb stick files and drivers?
is there some sort of registry history or something?

im not even POSITIVE its the usb-stick that is the problem, but i also discovered that MY SECONDARY HARD DRIVE (slave) IS NOT DETECTED BY WINDOWS

ive also tried unplugging everything usb and booting but there was no difference.

i have also thought about the fact that IT COULD BE something AFTER the GIVEIO driver
is there any way of finding out the sequence of the drivers installing upon bootup?

i should also mention that this is my audio DAW computer and it is heavily tweaked for performance (turned off many services including auto system restore etc..) however it has been stable for years until now.

i had a problem one time (virus maybe) which made it look like i had no optical drives installed.
but they were there and working (opening closing) it was just hat windows could not see them.

i want to make sure this is not the case with the hard drive as there is alot of data on there i would really not want to loose.

is there any way of knowing the drive is dead for sure?

latest thing i tried was unplugging drives to isolate the problem:

first i unplugged (power and ide) of the secondary/slave (the one that seems dead) drive and windows would not boot at all!
just stayed in DOS, and did NOT detect either drive

then just for kicks, i plugged that one back in, and unplugged the main (system) drive, and just as suspected; windows did not boot but DOS did detect the slave drive

so why does unplugging the slave drive make the main one not be detected even by DOS?

i should also add that when both drives are plugged in, they are both detected by DOS, but only main drive is seen by windows.

this further makes me think it is a virus and/or bad driver causing problems

--

should i run msconfig?
and if yes, then which boxes shoud i have checked/unchecked

thanx!
June 6, 2007 4:24:15 PM

thanx for helping edklite

i did what you said, and nod32 as well as spysweeper did not detect anything.

here is the HijackThis log:

Logfile of HijackThis v1.99.1
Scan saved at 6:59:43 PM, on 1/28/2003
Platform: Windows XP (WinNT 5.01.2600)
MSIE: Internet Explorer v6.00 (6.00.2600.0000)

Running processes:
C:\WINDOWS\System32\smss.exe
C:\WINDOWS\system32\winlogon.exe
C:\WINDOWS\system32\services.exe
C:\WINDOWS\system32\lsass.exe
C:\WINDOWS\system32\svchost.exe
C:\WINDOWS\System32\svchost.exe
C:\Program Files\Eset\nod32krn.exe
C:\WINDOWS\Explorer.EXE
C:\WINDOWS\System32\svchost.exe
C:\Program Files\Webroot\Spy Sweeper\SpySweeper.exe
C:\WINDOWS\System32\RunDll32.exe
C:\Program Files\QuickTime\qttask.exe
C:\Program Files\iTunes\iTunesHelper.exe
C:\Program Files\iPod\bin\iPodService.exe
C:\Documents and Settings\hex\Desktop\HijackThis\HijackThis.exe

R1 - HKCU\Software\Microsoft\Internet Connection Wizard,ShellNext = http://go.microsoft.com/fwlink/?LinkId=519
O2 - BHO: AcroIEHlprObj Class - {06849E9F-C8D7-4D59-B87D-784B7D6BE0B3} - C:\Program Files\Adobe\Acrobat 6.0\Reader\ActiveX\AcroIEHelper.dll
O3 - Toolbar: &Radio - {8E718888-423F-11D2-876E-00A0C9082467} - C:\WINDOWS\System32\msdxm.ocx
O4 - HKLM\..\Run: [Cmaudio] RunDll32 cmicnfg.cpl,CMICtrlWnd
O4 - HKLM\..\Run: [KernelFaultCheck] C:\WINDOWS\system32\dumprep 0 -k
O4 - HKLM\..\Run: [NeroFilterCheck] C:\WINDOWS\system32\NeroCheck.exe
O4 - HKLM\..\Run: [NWEReboot] "F:\NeroVision Express 2\Setup.exe" /MULTIMGR /RESTART_MULTIMGR
O4 - HKLM\..\Run: [REGSHAVE] "C:\Program Files\REGSHAVE\REGSHAVE.EXE" /AUTORUN
O4 - HKLM\..\Run: [QuickTime Task] "C:\Program Files\QuickTime\qttask.exe" -atboottime
O4 - HKLM\..\Run: [iTunesHelper] "C:\Program Files\iTunes\iTunesHelper.exe"
O4 - HKLM\..\Run: [nod32kui] "C:\Program Files\Eset\nod32kui.exe" /WAITSERVICE
O4 - HKLM\..\Run: [SpySweeper] C:\Program Files\Webroot\Spy Sweeper\SpySweeperUI.exe /startintray
O20 - Winlogon Notify: WRNotifier - C:\WINDOWS\SYSTEM32\WRLogonNTF.dll
O23 - Service: InstallDriver Table Manager (IDriverT) - Macrovision Corporation - C:\Program Files\Common Files\InstallShield\Driver\11\Intel 32\IDriverT.exe
O23 - Service: IMAPI CD-Burning COM Service (ImapiService) - Roxio Inc. - C:\WINDOWS\System32\ImapiRox.exe
O23 - Service: iPodService - Apple Computer, Inc. - C:\Program Files\iPod\bin\iPodService.exe
O23 - Service: NOD32 Kernel Service (NOD32krn) - Eset - C:\Program Files\Eset\nod32krn.exe
O23 - Service: Webroot Spy Sweeper Engine (WebrootSpySweeperService) - Webroot Software, Inc. - C:\Program Files\Webroot\Spy Sweeper\SpySweeper.exe
Related resources
June 6, 2007 4:27:48 PM

also, i forgot to mention that a friend suggested that i re-install the motherboard drivers (IDE), would you say thats a good idea?
June 6, 2007 5:00:21 PM

well now we are sure its not a virus ;) 

so then I'm afraid it maybe that your drive is corrupt, have you tried other cables for the slave?

they are both ide right?

mombo drivers might help but your mombo can already see one of the ide drives and work it so its not your mombo drivers at all IMO.
June 7, 2007 4:48:57 AM

yes they are both IDE. (two hard drives on IDE-0 and two optical drives on IDE1)

what i really find strange is that both hard drives are detected by POST (that also means the cables are fine) but not by windows.

this is really similar to an issue i had one time with another computer where i installed a ATI tv tuner card, and all of a sudden both the optical drives were not detected by windows.
it drove me crazy and took me a whole day of reading and tweaking as i could not figure out what it was...then by chance i re installed the mobo drivers and newer version of the ATI drivers, and voila! both opticals returned.

in this case it is one of the hard drives and it also happened after i installed that damn usb-stick driver (maybe this is a coincidence but probably is not)

the other weird thing is that if i unhook slave drive: neither hard drive is detected by POST, and hence there is no boot.

if i unhook main drive, slave drive IS detected by POST (but ofcourse there is no boot since windows xp is on main drive)

this is the reason why im considering re-installing mobo drivers (especially for IDE and USB)
June 7, 2007 5:59:26 AM

you can try an xprepair that should clear drivers and reset them, you can go into your add remove I think and uninstall the drivers for the usb drivers.
June 8, 2007 6:02:42 AM

Quote:
you can try an xprepair that should clear drivers and reset them, you can go into your add remove I think and uninstall the drivers for the usb drivers.


the first thing i did was to uninstall the usb-stick drivers, but unfortunately it didnt work :?
June 8, 2007 4:58:46 PM

try the repair
June 8, 2007 7:23:34 PM

Quote:
try the repair


how do i do that?
is that in windows or is it some software?
June 8, 2007 8:49:58 PM

look in this post I have a visual step by step ;)  xp repair
June 8, 2007 9:44:57 PM

You have to be aware of something on Western Digital IDE hard drives (not sure about other manufacturers). There are two settings for Master: one setting for single drive and one for slave present. If the drive is set to Master; Slave Present, when you disconnect the slave drive, the Master drive will no longer be detected in BIOS or will take a very long time to detect. If the opposite is true, then the slave drive may not be detected or again it will be very slow. Ensure that your drives are jumpered correctly.
June 9, 2007 4:41:21 AM

thats interesting but why would this happen all of a sudden even if it was the case?

(it worked fine in the current settings for at least a year, and only now (after installing the usb driver) all of a sudden the hardrive seems like it died although its still detected by POST
June 9, 2007 4:47:22 PM

I didn't think its his jumpers since he never changed them before the problem began
June 10, 2007 8:40:50 AM

Time to get out that manufacturer's disc and scan for problems.

I wasn't suggesting that it wasn't working fine before... I was merely pointing out that the issue you're having when unplugging one of the drives may be due to jumper settings. (You mentioned that when one drive was unplugged, the other wasn't detected at all). When you unplug one drive, ensure the settings on the other drive are correct. Probably the easiest way to do this is to use the Cable Select setting rather than bother with Master / Slave.

Now, after you've done that and isolated one drive, if the drive is STILL not detected, then you either have a defective drive or a defective cable. Just because the drives show up in BIOS is no guarantee that your cable is fine. At the very least, try another cable and see if the issue goes away... that is the easiest and quickest way to see if you have a cable problem or not.
June 12, 2007 6:30:37 PM

i tried replacing the IDE cable: no go :cry: 

im loosing my head over this.

now my computer is useless:

i completely removed the problematic slave drive, and cannot boot into windows at all.

instead it just remains in DOS and after a few minutes shows nothing but a full page of slashes! (/)

why would removing the slave disable me from booting the main drive????

seems like i need to have the bad/slave drive installed (even though it is not detected by windows) in order to boot the main.

really weird.

IF I CHOOSE "cable select" on the slave drive, do both drives have to be set to this? (or is it ok to have the main drive set to master and the slave to "CS"?)
June 12, 2007 6:35:45 PM

cable select will just make them individual which is what I use, don't like the slave myself.

I'm thinking one of your drives is corrupt and/or maybe you have some files on the slave that needes to run the master. but I'm not sure.
June 13, 2007 12:12:36 AM

Could be that your bootloader is on the other dive... but then you would get "NTLDR is missing" if that were the case...

Connect the bad drive and only the bad drive. Use the manufacturer's boot disk to perform diagnostics on it... I'm really suspecting that your hard drives are seriously messed up. (Or at the very least, the drive that isn't detected in Windows). Usually that means the file system is so hosed that Windows can't read it... or it's formatted with a Linux/Unix file system. I'm sure you probably haven't installed Linux... so I'm guessing the file system on that drive is seriously screwed.
June 13, 2007 11:27:17 AM

is there any way to fix a bad file system?

i tried putting the problematic/slave drive into a firewire enclosure into another computer and although i got a "found maxtor device" popup, i could not access the contents of the drive
June 14, 2007 6:11:52 AM

You could try running chkdsk on that drive... you might get lucky. If that doesn't work, you'll have to find a piece of software to recover anything on that drive if there was anything important on it.
December 1, 2007 2:38:32 PM

Well try kaspersky online scanner too , it's better than other products i guess
!