Sign in with
Sign up | Sign in
Your question

How can I remove the XP dual boot option ?

Last response: in Windows XP
Share
June 11, 2007 6:09:29 PM

Ok, so this week-end I tried adding a HDD on my XP machine.
This HDD had 2 partitions on it (from a previous XP install on another PC) so I used the XP install CD to basically delete them and create a single partition on it (that's the only way I knew how to do it).
However, while doing that, it ended up creating a dual boot config so that now, when I start my PC, I have to chose which OS to start:
1) The regular XP install (which works fine)
2) The one that never got installed on the new HDD since I only partitionned it.

How can I remove that dual boot option so that it only boots on the correct HDD ?
June 11, 2007 6:22:14 PM

screenshot of your boot ini please
June 11, 2007 6:28:43 PM

Quote:
screenshot of your boot ini please


how do I get that ?
Related resources
June 11, 2007 6:40:02 PM

right click my computer>properties>advanced>startup and recovery>settings>edit

once you hit edit notepad will open with the contents of your boot.ini

copy and paste that here
June 11, 2007 6:49:06 PM

Quote:
right click my computer>properties>advanced>startup and recovery>settings>edit

once you hit edit notepad will open with the contents of your boot.ini

copy and paste that here


Ok, thanks a lot. I'll have to do that from home and I'll paste it sometime this evening.
June 11, 2007 6:49:58 PM

see you later then ;) 
June 12, 2007 1:19:18 AM

Quote:
[boot loader]
timeout=1
default=multi(0)disk(0)rdisk(1)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect


1 thing I should mention is that at the dual boot screen I get 2 options:
Microsoft Windows XP Professional
Microsoft Windows XP Professional

The default one is the first and this is the "new" HDD that doesn't have XP on it.
I need to select the 2nd XP Pro install to boot to my "regular" XP.
June 12, 2007 4:18:20 AM

OK now I'm a bit confused, so let me tell you this:

you need to remove one of these entrees

Quote:
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect


or

Quote:
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect


now normally I would tell yo to delete the second line since your default normally is the one that is working, but in this case you are saying its the second option.

so I leave it to you to decide which to remove.

but before you do any editing back up your boot.ini as boot.ini.bak and leave it in your root directory, for example if your root drive is "C" then you want to put the back up file next the original in C:\boot.ini.bak.

if you choose the second line then make sure to make your default look like this:

Quote:
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS


no change is needed if go with the first line ;) 
June 12, 2007 4:59:36 AM

all that I know is that at the dual boot screen, if I don't do anything, it boots on the wrong disk (says something like file missing etc...).
since the default seems to be:
default=multi(0)disk(0)rdisk(1)partition(1)\WINDOWS

I guess this is the one I should delete....

by the way, you tell me to make a backup, but where is the original boot.ini file located ?
June 12, 2007 5:21:59 PM

if you read my last post then you will see I told you to save boot.ini.bak in the same directory as the original.

the original being boot.ini, which resides in the root of your drive.

so if your drive letter is "C" then you would find boot.ini in C:\boot.ini

now once you back it up as boot.ini.bak then go back to startup management window and edit your boot.ini to look like this:

Quote:
[boot loader]
timeout=1
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect
June 12, 2007 5:33:00 PM

Ok, i'll try that - I'll let you know how it goes.
June 12, 2007 6:11:10 PM

besure to save teh backup first, if anything goes wrong we will need to use it ;) 
June 12, 2007 6:13:30 PM

Quote:
besure to save teh backup first, if anything goes wrong we will need to use it ;) 


don't mean to be rude but you do know what you're doing right ? :wink:
June 12, 2007 6:22:36 PM

I know what I'm doing, but they are based on the info you have been giving ;) 
June 13, 2007 1:49:59 AM

well, it looks like that did it :D 
thanks a lot for your help !
June 13, 2007 1:54:30 AM

looks like you gave me the right info ;) 

delete your old boot.ini.bak and make a new bakcup file based on the current boot.ini you have ;)  be sure to delete only the backup file(boot.ini.bak) and not boot.ini itselft

it was a pleasure and good luck ;)  :) 
June 13, 2007 6:46:04 AM

Quote:
looks like you gave me the right info ;) 

delete your old boot.ini.bak and make a new bakcup file based on the current boot.ini you have ;)  be sure to delete only the backup file(boot.ini.bak) and not boot.ini itselft

it was a pleasure and good luck ;)  :) 


will do - but to keep on the original discussion about the location of the boot.ini file, I do not see such a file in c:\ (even with the "show all files" options set)
are you sure it's in c:\ ?
June 13, 2007 7:24:37 AM

did you also uncheck "hide protected operating system files (Recommended)" ?
June 13, 2007 4:23:15 PM

Quote:
did you also uncheck "hide protected operating system files (Recommended)" ?


ok..it's official, i'm an idiot :D 
thanks a lot for all your help - new boot.ini.bak has been created.
June 13, 2007 7:47:12 PM

lol you are no idiot, everybody misses that one the first time around ;) 

OK so now if ever you have a problem with your boot.ini file you have a backup for it which you can easily reach with recovery console ;) 

its been a pleasure and good luck ;) 
!