Sign in with
Sign up | Sign in
Your question

Asus WiFi App Solo issue with Vista Ultimate x64

Last response: in Windows Vista
Share
June 18, 2007 1:34:44 PM

First off, i never had this issue when using Windows XP.

I have a wireless network running at home. This enables my pc to connect to another pc (which is connected to the wireless router) that shares an internet connection.

Now, everytime i plug a flash drive/USB HDD into my pc, and i remove it, i lose my wireless connection, which also disconnects me from the internet. When i open the asus wifi application, it shows that my pc has no IP address anymore. The only way to restore connectivity is to restart my pc.

Could it be an Asus driver issue? BTW, the wireless network adapter is also detected as a USB device and is thus listed in the "safely remove hardware list". (Windows XP also detected it this way)
June 19, 2007 5:55:03 PM

this is not a shock to me. i've got Ultimate 64-bit and it doesnt even reconise my motherboard.....i've got the P5B Deluxe WiFi/AP and it does the same with my wifi adapter. the main problem i've got is that Vista doesnt even see my board.i tried to install all the updates which i got of the asus site, AIgear, AInap, Updates...the works, but still nothing. the driver cd i got with the board loads for 2 secs and then error msgs pop up.....i bought 64-bit so that my pc's ram could be reconised as 4GIG, which it does, but now i don't even have a motherboard installed.....acording to windows!!!!!!!!

does any1 know of a solution 4 this problem????i cant overclock because of this...... your help is much appreciated...
m
0
l
June 20, 2007 2:04:58 AM

Don't bother with the drivers from Asus's website... instead go straight to the chip manufacturers themselves. (IE Intel chipset, download from Intel's site; nVidia chipset, download from nVidia's site). Exactly what do you mean when you say Vista claims you don't have a motherboard? Remember you must download 64-bit drivers for your hardware... 32-bit ones will NOT work. My guess is that the Asus CD came with 32-bit drivers and software only. Things like AIgear and AInap will also have to be 64-bit.

Make sure when you search for Asus software that there are 64-bit versions available... and also ensure to download 64-bit drivers from the chip manufacturers. (They do have them, where Asus may not).
m
0
l
Related resources
Can't find your answer ? Ask !
June 20, 2007 6:44:57 AM

Yeah, you're gona need 64bit drivers. On the asus website, under the download section, choose vista 64 as the OS option. This makes it easier to find ONLY the drivers you are looking for. I dont have any issues with Vista detecting my hardware tho.. Im just frustrated with this irritating WiFi issue...
m
0
l
June 21, 2007 3:26:49 AM

I assume that you are stopping the drive before you remove it...

What it sounds like is that Vista is also stopping the USB Wi-fi device when you go to remove your flash drive. Not sure what you would do to fix it... might have to be a driver update or possibly a MS hotfix...
m
0
l
June 21, 2007 7:04:51 AM

I stop the flash drive before removing, but not the WiFi adapter...The WiFi adapter will still be in that "safely remove hardware" list, but it simply wont work until i reboot my pc.
m
0
l
June 22, 2007 4:15:22 AM

Have you tried stopping it, then unplugging it and plugging it back in? Just curious to know if that works instead of rebooting. I know that you aren't stopping the device, but perhaps a bug in Vista stops all USB devices when you stop the removable drive...
m
0
l
June 22, 2007 6:54:33 AM

You see, the WiFi adapter has its own port on the MoBo.. Its actually inside the case. So i never unplug it. I've also ruled out that its a Vista bug because: If i have my flash drive plugged in and my USB hardrive plugged in at the same time, removing only the flash drive will NEVER cause me to lose connection to my other USB drive and vice versa... So im starting to think its a driver issue.. After all, the Wifi driver provided by Asus is still a beta
m
0
l
!