Sign in with
Sign up | Sign in
Your question

Help! I'm completely lost!

Tags:
  • Linux
Last response: in Linux/Free BSD
Share
August 1, 2007 12:11:25 PM

I'm trying to make Scientific Linux work on a 3.0Ghz 64-bit P4 working on an Intel D915GAG motherboard with 4GB of memory. (Scientific Linux is a Red Hat Enterprise Linux-based distro for scientific environments; my boss insists that I use this instead of my much dearer Ubuntu DVDs...)

Now the kernel that gets installed with the Scientific Linux 5.0 installation DVD is the 2.6.18-8.1.8-el5 version. The installation proceeds without any problems, and the system boots normally. However, once the graphical interface loads, we're presented only to a strange message window in which all characters are messed up: they're all squares! I've never seen this before. This message window might contain an error message, but because we can't read it we don't know. There's also a button there, and it closes the message window; but then, the graphical interface doesn't load up at all afterwards.

The only thing that remains there is the mouse cursor. And it even moves. But nothing else ever happens, and at this stage, not even Ctrl-Alt-F5 does anything.

I don't even know where to start. Is this a video driver problem? What the hell should I do? What should I try? :heink: 

I'm now booting into text mode to see what I can come up with. Any suggestions would be very greatly appreciated!!! :bounce: 

More about : completely lost

August 1, 2007 12:18:53 PM

Hmmm, lspci in text mode shows that the VGA adapter is correctly identified as an Intel Integrated Graphics Adapter (82915G). So I'm thinking that's not it... Damn.

Edit: I've managed to get the X Window system to start by simply using startx when booting in single user text mode. All characters are still messed up, but the graphical interface itself loads succesfully. Two message windows appear (probably error messages again...) but can't be read at all. I've even managed to open a terminal window (whose characters are readable) inside this mess.

Isn't there a boot log file I can check to see which error messages I'm missing?
a b 5 Linux
August 1, 2007 1:13:41 PM

ALT + CTRL + BACKSPACE ( not DELETE ) will kill the X server when it gets messed up or freezes or something

If this computer is on the network you can also ssh in and kill it or change things.

Make sure you edit /etc/grub.conf and remove "rhgb quiet" from every single kernel line.

This will disable the graphical boot screen so that you can actually see what is happening during boot.

Also check the logs in /var/log and run dmesg

Good luck :) 
Related resources
a b 5 Linux
August 1, 2007 1:16:17 PM

PS Throw the motherboard in the trash!

Ok that's probably not an option... see if you can persuade your boss to never buy any more boards like this and give you a few bucks to buy a real VGA that actually works!
August 1, 2007 2:46:31 PM

Thanks linux_0!

As for the motherboard and persuading my boss, I'm working on it!!!

I found that, in the X Window system init log, there was an error about "Could not init font Path element unix:/7100" or something to that effect. I tried manually setting a few font paths, but it didn't work.

I tried installing from a Live CD and it worked perfectly. I tried copying the X11 configuration files, but it still didn't work.

So I got fed up and installed from the Live CD. A few installation options simply weren't there, but I'm now adjusting the OS to behave as it should. It now works correctly. Still haven't figured out what happened though...
a b 5 Linux
August 1, 2007 6:24:18 PM

If that was the only thing that was wrong then the problem was xfs the X font server.

It either wasn't running or it was incorrectly configured.

service xfs start

starts it

if you remove "rhgb quiet" from grub.conf, even if X is messed up you will still get the boot messages.

Good luck :) 
August 2, 2007 4:13:42 PM

Thanks linux_0.

It seems that the live DVD installation got corrupted right now. Booting the machine results in a kernel panic. I think the only solution we've got is to make the X Font server work correctly.

We're still exploring possibilities here. I think we'll have to reformat everything. Once we're back to the "lotsa squares" X windows, I'll post again.

Thanks again.
!