Sign in with
Sign up | Sign in
Your question

Xemacs Tabs not working...

Last response: in Linux/Free BSD
Share
August 7, 2007 2:55:37 PM

I've installed xemacs under Scientific Linux (it's a RHEL-based, 2.6.18-kernel linux distro) and compiled with all packages included.

All buttons work, all functions seem to work, except for one: the buffers tab for when you have multiple files open. How can I get these tabs to show? The Options>Display>Buffers Tab Visible is checked!

What am I missing? Help!! :heink: 

More about : xemacs tabs working

August 7, 2007 6:08:01 PM

Oh no, I just found out that even the menus aren't working properly.

Crap.

Why the hell would these #(&*@$ stupid @*&$#!% stupid people make a Xemacs installation without the damned required packages for all things to work properly??? :fou:  :fou:  :fou: 
August 7, 2007 6:20:28 PM

Wait, I found some information.

Apparently, I should run ./configure with the --with-widgets option. This defaults to "no" for no widgets, which disables the tabs.

But configure replies to my --with-widgets=yes (or ...=athena, or whatever) with "unrecognized option". Seems I'm out of luck, but now I know what's wrong...
Related resources
August 7, 2007 6:45:45 PM

Problem Solved, forget it.

I manually edited the configure script and it all worked fine.

Thanks for reading this anyway!
April 22, 2012 3:25:14 PM

Hi Mephistophele,

I have the same issue, can you please describe what was the exact solution?

i am new with red hat so please be generous with the explanation!

thanks
a b 5 Linux
April 23, 2012 12:59:14 AM

You might want to check the post dates before digging up old threads. This thread dates from 2007, the poster last posted on Toms back in 2010 so hasn't been here in just over 2 years.

I'm sure if other people know they'll advise, but don't expect a reply from Mephistopheles.
April 23, 2012 7:05:13 AM

audiovoodoo said:
You might want to check the post dates before digging up old threads. This thread dates from 2007, the poster last posted on Toms back in 2010 so hasn't been here in just over 2 years.

I'm sure if other people know they'll advise, but don't expect a reply from Mephistopheles.



Hi

I have noticed that,Just tried my luck.

Anyway, problem is solved. Updating to --with-widgets=lucid worked for me .

Thanks
!