Sign in with
Sign up | Sign in
Your question

Fedora 7 install

Tags:
Last response: in Linux/Free BSD
Share
August 10, 2007 12:32:47 AM

Currently I have 2 SATA HDs. The first is set to Third IDE Master with Windows XP loaded on it. The second is set to Third IDE Slave and is completely blank. I'm currently trying to install Fedora 7 using the installation DVD onto the blank Slave drive (2nd HD). When I change boot priority to dvd drive in order to boot from the DVD I am able to enter the Fedora 7 Installation. When I get to selecting partition to load onto step I get the following popup: "The partition table on device sdc was unreadable. To create new partitions it must be initialized causing the loss of all data on this drive." Then when I click either yes or no I get "Input/Output error during write on /dev/sdc." What I would like to know is how I need to change my second HD so I can load Fedora onto it. Any help is appreciated. Thanks.

More about : fedora install

August 10, 2007 1:49:04 AM

Backup your important data on your 1st drive just in case before you do anything to the computer or touch the 2nd drive.

I/O errors are sometimes very serious, they could mean your 2nd drive is dead, dying or unreliable.

Replace the SATA cables, try another SATA port on your motherboard and see if the problem persists.

Disconnect the 1st drive and connect the 2nd drive in it's place and see if it works since you know the SATA port used by your 1st drive is good since that drive works.

Also please give us your full system specs including the power supply.

:) 
August 10, 2007 2:01:32 AM

mobo: Asus P5W DH Deluxe
HD1: WD Raptor 150GB - set as Third IDE Master (Has Windows XP Loaded)
HD2: WD Raptor 150GB - set as Third IDE Slave (reformatted drive and is completely blank)
PSU: PC Power & Cooling 750W Silencer
GPU: XFX 7950GX2 Extreme
RAM: 4GB Corsair ddr2 800

I just recently had my 2 HDs in Raid 0, but took them out and switched one to master so they'd be two seperate HDs. I know my 2nd HD isn't dead, and I'm pretty positive it isn't dying.

What should I try first?
Related resources
August 10, 2007 2:30:39 AM

You could use a DSL or Knoppix Live CD to check to see if the drive is healthy, you may also be able to use other Live CDs or a Fedora rescue disk but some Live CDs and the Fedora rescue disks have limited functionality.

Knoppix is a fully functional / usable system on CD or DVD.

http://www.damnsmalllinux.org/download.html

http://knopper.net/knoppi x-mirrors/index-en.html


Simply download and burn the live CD, boot up, launch a terminal and run

[c++]
hdparm -i /dev/sdc
hdparm -I /dev/sdc
hdparm -t /dev/sdc
hdparm -T /dev/sdc

smartctl --all /dev/sdc
[/c++]

Replace /dev/sdc with /dev/sda if you move the drive to the same port as your 1st drive for testing. Also please post or PM me the output of the above commands.

:) 
August 10, 2007 2:38:53 AM

Did you disable RAID mode in your BIOS?

You could also boot into rescue mode from the Fedora 7 disk and when it drops you to the shell / command line run:

dmesg |grep -i ata
dmesg |grep -i scsi

dmesg |grep -i wdc

dmesg

and see if there are any errors

I do not remember if the Fedora rescue disk has hdparm and smartctl on it.
August 10, 2007 5:02:26 AM

I disabled jmicron raid controller and changed SATA config from RAID to Standard IDE.. After I did that both HD were set to slave so I plugged one into master. does that remove the raid? :??: 

I'll download Knoppix overnight since its a big file. I went into the shell through recovery and typed what you said:

when I typed dmesg |grep -i ata - it said HH Complete
when I typed dmesg |grep -i scsi - it said write cache enabled read cache enabled doesn't support DPO or FUA
when I typed dmesg |grep -i wdc - it said:
<6>ata3.00: ATA-7: WDC WD1500ADFD-00NLR1, 2-.-7P20, max UDMA/133
<6>ata3.01: ATA-7: WDC WD1500ADFD-00NLR1, 2-.-7P20, max UDMA/133
<5>scsi 2:0:0:0: Direct access ATA WDC1500ADFD-0 20.0 PQ:0 ANSI:5
<5>scsi 2:0:1:0: Direct access ATA WDC1500ADFD-0 20.0 PQ:0 ANSI:5

Is that supposed to happen even though I only have 2 HDs?

August 10, 2007 5:22:29 AM



<6>ata3.00: ATA-7: WDC WD1500ADFD-00NLR1, 2-.-7P20, max UDMA/133
<6>ata3.01: ATA-7: WDC WD1500ADFD-00NLR1, 2-.-7P20, max UDMA/133
<5>scsi 2:0:0:0: Direct access ATA WDC1500ADFD-0 20.0 PQ:0 ANSI:5
<5>scsi 2:0:1:0: Direct access ATA WDC1500ADFD-0 20.0 PQ:0 ANSI:5


Well this is encouraging it looks like the kernel is seeing the 2 drives.

I have to caution you though, JMicron controllers have compatibility and driver issues so your mileage will vary.

Have you tried to use the onboard SATA controller?

Also regardless of which controller you use try to set it to SATA mode instead of IDE mode and make sure RAID mode is disabled.
August 10, 2007 1:26:34 PM

well knoppix worked I burned it and booted from it and Im posting this while on knoppix, but where do i type in the commands you said? it seems knoppix isnt in english lol so Im having trouble browsing around it

August 10, 2007 2:31:19 PM

-DE is the German version

-EN is the English version

the link above ends in .iso there are no spaces in the URL obviously
August 10, 2007 2:45:40 PM

edit: ok I got fedora installed on the 2nd HD to do it I disabled jmicron thing in bios, unplugged 1st HD with windows and plugged 2nd HD in to master slot then install went through (I thought I had alrdy tried that, but I guess not.)now the only problem is if I plug it back in the way it normally is since the HD with windows is the one in boot priority it loads straight to windows. How do I get an option to load to windows or fedora? Thanks.
August 11, 2007 12:08:04 AM

You have to set your boot priority to boot from the 2nd HDD containing Linux and the GRUB boot loader.

Then you have to add windows to /etc/grub.conf


something like:

title windoze
rootnoverify (hd0,0)
chainloader +1
August 11, 2007 6:42:22 PM

i got the boot loader to work, thanks ;) 
August 12, 2007 5:26:00 AM

cool :) 

Hope you're enjoying Linux!
August 27, 2007 1:31:29 PM

hallooooo....i m new member in this forum.. can anyone please teach or xplain to me about linux?????? pleaz....
!