Sign in with
Sign up | Sign in
Your question

Poor playback quality of video files under Kubuntu 7.04.

Tags:
  • Video
  • Hewlett Packard
  • Hard Drives
Last response: in Linux/Free BSD
Share
October 20, 2007 12:32:18 AM

Hi, I've been using Feisty Fawn on my HP Omnibook 6000 (256mb, 80GB HDD, P3 600mhz) for several months now and there is just one issue that I cannot seem to resolve: graphics.

Whenever I playback video clips and films they always suffer from jerkiness, heavy pixellation and reduced quality compared to when they're run on the same laptop under Windows, where the same video files play perfectly.

I have tried various workarounds, searched endlessly and posted thorough detailed descriptions of my problem on specialist Linux video forums but no-one seems to have any answers.

Has anyone else encountered a similar problem or can offer any suggestions? Thanks for reading my post.

Jay

More about : poor playback quality video files kubuntu

October 20, 2007 6:40:13 AM

It sounds like you need the ATI legacy accelerated drivers for the onboard VGA, which happens to be a 7-8 year old ATI Mobility II with 8MB VRAM.

You may also need to tweak some settings and turn off some eye candy.

http://www.ima.umn.edu/~arnold/omnibook6000-linux.html


Keep in mind this laptop was designed for windows 95, maybe 98, Kubuntu 7.04 is only 6 months old.

As good as Linux is for older hardware your mileage will vary on a 7-10 year old laptop.

GL :) 
October 20, 2007 7:52:31 PM

If you disable all the services you do not need, you can recover some RAM which is critical to performance.

You may also want to give DSL a try http://www.damnsmalllinux.org/ and compare performance.

The critical thing is to the get the ATI legacy accelerated drivers for the ATI mobility / March 64

:) 
October 20, 2007 7:58:18 PM

Which should be done automatically with 7.10 through the restricted drivers control under the System->Preferences->Restricted Drivers. Given the low resources I'd suggest looking at XUbuntu based on XFCE as is it uses far less resources than KDE.
October 20, 2007 8:28:37 PM

Great suggestion indeed :trophy: :) 

I forgot about XUbuntu.

7.10 seems to work fairly well so far, I tried it on a system with ATI graphics and it seems to be running fine.

This is on a 3 day old laptop though.
October 23, 2007 10:45:41 AM

I have Kubuntu 7.10 installed on my desktop. It's an AMD Athlon 64 X2 4200+ with an ATI X300SE card.

I did the comparison check, too. Windows is on another partition. Videos played in Windows look crisper, sharper. I don't think it's always the computer but rather the drivers and video card configuration. But, I'm only speculating.

November 7, 2007 2:51:36 PM

Yeah, it's the drivers.

For comparison:

Ati Rage II Pro 2mb

A 720x560 divx clip plays jerkily under windows.
The same clip plays awesomely under Geexbox, with crispier and brighter colors too.
December 10, 2007 12:16:20 PM

Hey, thanks for all the replies! :) 

I'd been searching for ages for any possible leads. No-one else really had any experience with this issue, but thankfully you guys have all the answers.

I haven't tried DSL yet but I've downloaded Xubuntu 7.10 and I'm using the Live CD right now. I see what you mean about the performance difference, it seems to work better with the laptop too (wireless connectivity feels more reliable and stable).

Once I've installed it onto the hard disk I'll post back with the results so that others in the same situation can use the information too. Thanks again...

Jay
December 11, 2007 3:37:06 PM

Update time... I've installed Xubuntu 7.10 and the fact my wireless card finally works properly has a put a smile on my face :)  .Ran some tests by playing a couple of films in .Avi format using Mplayer: it plays in a small window but attempts at fullscreen produce reports of video config problems.

Never one to give up quickly, I ran the Xvinfo command in Terminal and received the following:

Quote:
X-Video Extension version 2.2
screen #0
no adaptors present


Next, I checked the X-Server(?) version using X -version in Terminal and it listed these details:

Quote:
X Window System Version 1.3.0
Release Date: 19 April 2007
X Protocol Version 11, Revision 0, Release 1.3
Build Operating System: Linux Ubuntu (xorg-server 2:1.3.0.0.dfsg-12ubuntu8)
Current Operating System: Linux excelsior 2.6.22-14-generic #1 SMP Sun Oct 14 23:05:12 GMT 2007 i686
Build Date: 29 September 2007
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.


So I opened up the Xorg.conf file to see which driver is being used:

Quote:
Section "Device"
Identifier "Generic Video Card"
Driver "vesa"
BusID "PCI:1:0:0"


and...

Quote:
Section "Screen"
Identifier "Default Screen"
Device "Generic Video Card"
Monitor "Generic Monitor"
DefaultDepth 24


As you can see Xorg isn't using the right settings for my chipset (the ATI Mach64), so I'm going to see if I can run a script which will install the correct driver and hopefully this should put me on the right track. If anyone has any suggestions in the meantime, please let me know.

Many thanks and apologies for a long post.

Jay
January 14, 2008 4:59:06 PM

Why a script? Just change the driver to "ati". For Mach64 the opensource drivers are way better than Ati's; the current ati driver won't even support cards that old.
January 15, 2008 11:41:38 AM

System->Administration->Screen&Graphics.

From there choose your graphics card by name and you should be good to go..
!