Sign in with
Sign up | Sign in
Your question

A few problems I'm having with ubuntu

Last response: in Linux/Free BSD
Share
December 27, 2007 8:22:06 PM

I've been looking for awnsers using google, but came up empty.

First and biggest problem so far is I have no sound, I'm using a new logitech clearchat Pro USB head set and get no sound. I followed several trouble shooting steps (selecting device to use, turn up volume, make sure its not muted) but still have the problem.

Another big problem is the fact I can't seem to install flash player and AIM both programs are made for linux too and I downloaded the right kind. It all downloads fine but when I click the .exe to install it pops up a window that says "Do you want to run "Flashplayer-installer", or display its contents?- "flashplayer-installer" is an executable text file." then it has buttons titled "Run in Terminal" "Display" "Cancel" "Run" I tried all and both run in terminal and run do nothing but close the window display shows the code. So how can I fix this?

My ubuntu is completely updated too.

More about : problems ubuntu

December 27, 2007 11:36:26 PM

Lots of steps just to get flash working in linux :( 

I'll do that after I reinstall/format because I'm getting a new motherboard and don't want to do all that twice.
Related resources
December 28, 2007 12:47:55 AM

uhh. just download it to /root and type this:
cd /root
gunzip install_flash_player_9_linux.tar.gz
tar -xf install_flash_player_9_linux.tar
cd install_flash_player_9_linux
cp libflashplayer.so /usr/lib/seamonkey/plugins

and it should work, but substitute seamonkey for you respectable browser,
firefox-20.0.4, or whatever. You could wait till later to do this, but what would be the fun?
December 28, 2007 1:18:50 AM

Yup surrealdeal nailed it :) 

Let me clarify a couple of steps.

first install a 32bit firefox

sudo su -;

cd /root;


wget ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/...;

tar xzvf firefox-2.0.0.11.tar.gz;

mv firefox /usr/local/firefox



and then run the following



wget http://fpdownload.macromedia.com/get/flashplayer/curren...;

tar xzvf install_flash_player_9_linux.tar.gz

cd install_flash_player_9_linux/;

cp libflashplayer.so /usr/local/firefox/plugins;



You can use any reasonable directory for firefox instead of /usr/local/firefox like /opt/firefox or whatever.

Then you can link, alias or reconfigure the icons in your GUI accordingly to launch the new firefox.


GL :) 
December 28, 2007 2:31:48 AM

linux_0 said:
Yup surrealdeal nailed it :) 

Let me clarify a couple of steps.

first install a 32bit firefox

sudo su -;

cd /root;


wget ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/...;



When I get to that last step it says Permission denied. So should I manually download it, if so where should I put it ?

December 28, 2007 3:09:47 AM

1. what you are trying to wget is the firefox source, that's not flash.
2. are currently using a browser? if so, what is it?
3. are you root?
... you mentioned you all ready have the install program. is this it:
http://www.adobe.com/shockwave/download/download.cgi?P1...
if so, it should come with a file: libflashplayer.so , which you must copy to the plugins folder of the browser you are using. goto /usr/local and click the folder that has the same name your browser does. now goto plugins. copy the file libflashplayer.so there.
December 28, 2007 4:40:28 AM

2. yes I'm using firefox that was pre installed into ubuntu
3. yes I'm log in as root

Yes that's the thing I've downloaded. when I go to file system usr/local there isn't a folder called firefox or any thing close.
December 28, 2007 6:16:12 AM




sudo su -;

cd /root;


wget ftp://ftp.mozilla.org/pub/mozilla [...] 11.tar.gz;

tar xzvf firefox-2.0.0.11.tar.gz;


mv firefox /usr/local/;


Sorry there was a typo in my previous post.


Try mv firefox /usr/local/;



sudo su -

cd /root

mv firefox /usr/local/



then you can do flash player


wget http://fpdownload.macromedia.com/g [...] ux.tar.gz;

tar xzvf install_flash_player_9_linux.tar.gz

cd install_flash_player_9_linux/;

cp libflashplayer.so /usr/local/firefox/plugins;




in the end you should be able to run /usr/local/firefox/firefox and make a custom application launcher in Gnome to launch it for you.

GL :) 
December 28, 2007 8:29:11 AM

1. i promise you this WILL work, have faith.
2. my last post, the last line read:
/usr/local and click the folder that has the same name your browser does. now goto plugins. copy the file libflashplayer.so there.
3. should have read:
/usr/lib
4.i apologise.
December 28, 2007 2:28:45 PM

NVM I was messing around and went into system>preferences>sounds and instead of having it auto detect I selected usb audio and it all works now
December 28, 2007 2:46:26 PM

now you can enjoy swf errors and feist videos.
December 28, 2007 5:23:04 PM

Glad you got it working :) 

Not to rain on your parade, but flash player sometimes locks up firefox.

If it locks up you can kill it by clicking repeatedly on the X to close the window.
December 29, 2007 2:41:22 PM

I just installed beryl and when I type beryl-manager and click on settings the cube loads up and I close that manager and all the title bars of my windows are gone. So when I log out or restart it has the title bars again but it doesn't have the cube effect. What's wrong?

December 30, 2007 8:09:48 PM

It sounds like your window manager may be crashing.

Check to make sure you have the latest software and drivers installed ( run the software updater ).

Also look for the error logs.

GL :) 
!