Sign in with
Sign up | Sign in
Your question

Problems Installing Linux

Last response: in Linux/Free BSD
Share
January 12, 2008 9:29:04 PM

I have tried to install SUSE 10.3 on my USB Extenal Hard Disk.

However it simply doesnt want to install. After setup on reboot I get various different problems.

My Asus A7N8X-E Deluxe does support booting from USB Hard Disks and I can hear the hard disk working but Linux doesn't appear to have been set up properly. First time I got a disc boot error so I had to restart, boot from Linux CD ROM and try to repair installation. I tried to continue the installation and it finished set it up but would only show me the prompt - i.e. no GUI appeared. So I reinstalled, wiped out previous parititions and tried again. This time the monitor went blank towards the end of the installation and after that I had problems booting up again. I couldn't even get past the Asus splash screen - even the keyboard stopped responding!!!

What the hell is going on?!? Does my PC have some allergic reaction to Linux?!? I am starting my new semester in two days time and I need Linux up and running on my USB Hard Disk ASAP!!

During this installation, I had pulled out all the other hard drives as I want Linux to have nothing to do with them. I want to set it up so that I can choose to boot from USB drive via BIOS when I want to use Linux, otherwise it boots from SATA controller as normal. Also, the DVD ROM and DVD RW drives are just over a year old, in mint condition and clean - the media is also in good condition as it passes the initial media test that Linux gives you.


Any ideas??
a b 5 Linux
January 13, 2008 5:46:41 AM

The A7N8X-E works perfectly with Fedora installed on an IDE disk. Never tried it with USB on this board.

I can confirm that the A7N8X-E sometimes freezes during boot especially after adding and removing USB devices.

Since the A7N8X-E is known to have USB and ACPI problems try a few different BIOS versions and distributions.

You can also try the noapic and acpi=off boot options.

GL :) 
January 13, 2008 9:18:32 PM

Hmmm - thing is I didn't add or remove any USB devices during the installation of Linux on the USB disc. It just decided to freeze or give me a cocked up installation

So how would I go about changing these boot options.
Related resources
a b 5 Linux
January 14, 2008 2:45:20 AM

the install cd should drop to a boot: prompt as it starts and gives you a few seconds to add boot options

if you haven't tried already, try Ubuntu 7.10 and fedora 8 and see if they work any better

both ubuntu and fedora also have live CDs so if you can't get them to install you should at least be able to use the live CDs

GL :) 
January 14, 2008 9:15:01 PM

I have Knoppix which I can use - its just that SUSE is what I am using at my uni and it also has all the development tools which I'll need in my other programming modules.

Is there any way I can stop the boot prompt by pressing Pause/Break as I would on any other DOS screen to stall the PC for a bit??

Ne ideas what could be causing this problem
a b 5 Linux
January 14, 2008 9:25:49 PM

yes you should be able to pause at the boot: prompt by pressing the PAUSE key

try Ubuntu and Fedora anyway and see if they work, if they work that means something in SuSE is having a problem with your hardware

if they also do not work then it must be your hardware

the development tools will work on any distribution

upgrade or downgrade your BIOS, burn the BIOS image on a CD-R and hit ALT + F2 at boot when prompted

GL :) 
!