Sign in with
Sign up | Sign in
Your question

Gentoo Linux

Tags:
Last response: in Linux/Free BSD
Share
July 11, 2008 8:28:56 PM

So I finally decided to take the plunge and install Gentoo Linux and man has it been a trip! I'm deciding to document this little odyssey of mine here so that you can either share in my experience or laugh at me for being foolish enough to do this ;) 

Anyways, it started about 2 days ago when I first popped in the liveCD and saw that there were 2 installers available. One is a graphical one that i hear is total crap, and the other was an ncurses installer that I thought was the official way to install Gentoo. Oh how wrong I was! That little ncurses installer must have crashed about 6 times on me before I decided to man up and read the Gentoo handbook! So, i reformat/resize some of my partitions, mount them, chroot into the new environment, download and untar the stage3 tarball, configure portage and my USE and CFLAGS environmental variables and then I had to go to bed because it was 3 o'clock in the morning (I started at about 10pm)!

The next day I woke up at 11 and spent the next 2 hours in the 'menuconfig' program selecting what options i wanted to compile into my kernel. I finished that, compiled the kernel, and went out to lunch. When I got back, I got to copy the new kernel (my first ever) over to my /boot, install some important tools (like logging and grub) and set up my boot loader. At this point I naively thought I was going to have a working environment, despite my previous experience with projects telling me that NOTHING this complicated ever works on the first shot. Sure enough, when I rebooted, I could get neither Linux nor windows to boot because while grub found itself, apparently it was not configured properly. So, i went back and figured out that for some reason my grub was seeing my hard drives in the wrong order, so i fixed the /boot/grub/device.map file, changed a couple of things in /boot/grub/grub.conf and PRESTO! I could now get Windows to boot and linux to 'boot'. I say 'boot' because all I could see was a blank black screen after seeing my kernel boot options flash for a second, and then after a bit i saw my caps/num/scroll lock lights all flash at once.

At this point I was glad i could at least boot one OS, but I still had no idea what was going on, so I googled around for a bit and didn't learn much, so i headed on down to talk to the nice people at the IRC #gentoo channel. The advice that I got from them was to turn off the framebuffer options i had fed to my 'kernel' line in grub so that then maybe I could see what was going on. So, I did, and I rebooted and I could then see glorious text messages! After a minute or two I got an error from the system saying that it couldn't mount my root file system and it asked me to insert a floppy disk. Since I had no floppy disk, i just hit enter to continue and I was immediately greeted with a kernel panic and the 3 flashing lights from before!

By this time it was already 3am again so I quickly hopped back on #gentoo and asked what the kernel panic message I got meant, and they told me that perhaps I had not compiled in support for my IDE drive or perhaps I had compiled support for my file systems as a module (which is a big no no that I was unaware of). So with that I went off to bed again.

This morning, after a quick look at lspci to see what IDE drivers i have running, I found 2 entries from intel and 1 for jmicron. So, I did the whole chroot thing again, and went back into the kernel configuration program and made sure I had IDE support compiled in and that all the file systems I use were not compiled as modules. After installing my new kernel and rebooting, I could now boot into linux complete with a login prompt! However, the odyssey is not yet complete as for some reason I got a warning during the boot about some partitions not being mounted (that i still need to look into). Also, the framebuffer stuff doesn't work yet so the text only environment has HUGE letters, and finally, it doesn't connect to the internet yet, which is a BIG dealbreaker. It is funny though because during the boot I saw it acquire an IP address from our router and I can ping the router, but I can't ping sites on the internet. So now I have to figure out how to fix that issue - which will probably require yet another compile - so that I can finish installing a fully working environment.

I am going to continue to update this little story as I go along, and hopefully it won't be too long before I have a finished setup. If you guys have any comments or helpful insights as to what my problems are and what I need to do to fix them, I GLADLY welcome the help.

I hope this thread proves to be both entertaining and enlightening for you guys :D 

-Zorak

More about : gentoo linux

a b 5 Linux
July 11, 2008 8:52:14 PM

Wow. That seems overly complicated :S. Hopefully it's worth it to you! I remember when I first got my new computer and installed Fedora, I was up until about 4 trying to get my wireless internet working. Oh, good memories of 8 hours on a computer attempting to do a seemingly simple task :) 
July 12, 2008 1:29:34 AM

And now for an update!

So I guess I will start from most trivial to least. It turns out the reason why one of my partitions wouldn't mount was because I made a typo in a mount option in the fstab :D  (embarrassed). So, I fixed that and then I went back to #gentoo where I found out that in my /etc/resolv.conf, there should have been a line specifying my router as nameserver, which is why I couldn't resolve domain names into IPs the system could use. However, after manually adding the entry, i found out that upon reboot, dhcpcd would promptly rewrite /etc/resolv.conf and destroy the changes i had made, bringing me back to square one. So i found out that I had in fact put a line in my /etc/conf.d/net file that shouldn't have been there which was triggering a rewrite of /etc/resolv.conf upon reboot. I deleted the offending line and HOORAY! I can now boot into a text environment in Gentoo that will effectively touch the internet!

Now all I have to do is install X.org, GNOME, firefox, open office, wine, mplayer, compiz-fusion, my graphics driver and a slew of other programs that I can't think of off the top of my head and I will have a fully functional system! lol :D 

Clearly this has been a learning experience for me and this is NOT for the faint of heart!

-Zorak
Related resources
a b 5 Linux
July 12, 2008 3:02:07 AM

I've been through that song and dance for years now, I'll try to visit more often (moving out to Austin, TX at the moment) as i coulda pointed you to the right areas straightaway as I've seen both those and many more common issues (as well as some less common issues).
July 12, 2008 3:27:41 AM

Ah that is really cool bmouring! You are moving to my hometown :p  I appreciate the offer for help. Hopefully I won't need it :D 

-Zorak
July 12, 2008 7:28:01 AM

So I went ahead and started installing my nvidia drivers with 'emerge nvidia-drivers' and apparently Xorg is a dependency because emerge had to download 100+ packages just to get my drivers installed. After all that was said and done, I decided to install what was left of Xorg and it downloaded another 19 packages. I wanted to get GNOME installed after that and much to my chagrin, i find GNOME needs almost 200 FREAKING PACKAGES! I had heard it was big but OH MY GOD. I have been compiling since the latter half of 11pm and it is now 2:26am here with the end just barely in sight (it is on package 157 of 193).

I hope after this huge compile fest is done it will work, but as I saw before, something this complicated is hardly going to work on the first shot :D 


-Zorak
a b 5 Linux
July 12, 2008 10:14:16 PM

Quote:
something this complicated is hardly going to work on the first shot


Indeed, which is why I suggest getting plain-ol' X chugging before delving into Gnome. Simply run X or startx and see if you get the crosshatch (+TWM if you use startx). If it succeeds, make sure it's running the nvidia glx (glxinfo, glxgears). If it fails, start looking through the /var/log/Xorg.xxx file and try to find the problem(s). Once that's sorted out, Gnome becomes much more a set-it-and-come-back-a-few-hours-later affair (there may be a niggling annoyance fixed by a configuration or alsa issues, but X won't be a problem). Be the tortoise, not the hare.
July 12, 2008 11:19:29 PM

Actually I managed to get X.org, my nvidia drivers, AND GNOME installed and working ALL IN ONE SHOT! Heck, I even got framebuffer support so my CLI outside of X doesn't look like crap anymore :D  I tried to make a post about it a couple of hours ago but i hadn't signed in to the forum yet and so i type out the whole reply, did the username and password at the same time, hit submit and it was the wrong password! So, i hit back and I lost my post and decided to say "screw it i'll post again later". Anyways I got xchat up and running so that I can get help from #gentoo w/o having to boot the live CD and i now have pidgin so i can talk to my friends while I compile junk. The only stuff that remains for me to do is somehow make my sound work (I am not sure why it isn't working but I hope i don't have to recompile my kernel), install flash, and maybe install compiz-fusion. As for the flash stuff, I have no idea whether the copy of firefox that got compiled in along w/ GNOME is 32bit or 64bit but i suspect it is the latter. I need to know b/c from what I had heard you need a 32bit firefox so that you can run 32bit flash (since there is no 64bit).

I do believe the end is in sight and it is beautiful! All in all I must say that this has been a very educational and cool experience for me, and I would definitely recommend installing gentoo at some point to anyone who is interested in using linux (in case there are newbies reading this). That being said THIS IS NOT FOR THE FAINT OF HEART, but then again that is kind of the point. ;) 

-Zorak

P.S. Bmouring, if you have any idea why sound might not work i'd appreciate feed back. When I click on my little volume control in GNOME it says "No volume control GStreamer plugins and/or devices found" and I am not sure exactly what that means. Also when I booted into my liveCD it said something about having to 'unmute my sound card'.
July 13, 2008 4:27:23 AM

So flash is slightly tricky, but you don't need a 32 bit version of firefox: that's for ubuntu users. There's a plugin wrapper for the 64bit firefox called nspluginwrapper to get 32bit plugins to work in it.
  1. emerge -av nspluginwrapper netscape-flash
should do it. (More information here: http://gentoo-wiki.com/HOWTO_Flash_9_and_Firefox)

As for sound, run
  1. dmesg | grep -A2 -B2 -i ALSA

It should say something about "Detected cards" or similar and if not, you forgot to include ALSA support in your kernel, or did not disable support for OSS. Fix kernel and reboot. If your card is detected and sound is still not working, make sure that it's not just muted (run alsamixer, and unmute/turn up everything). And if it is simply not remembering your sound settings on reboot (it keeps muting you, which is the default setting), try adding the alsasound init script to default:
  1. rc-update add alsasound default
if you haven't already, which is the script that the liveCD is running when it notifies you have having to unmute the soundcard.
a b 5 Linux
July 13, 2008 11:50:26 AM

** Reminds self of why he loves the nice folks at Ubuntu land that do all the hard work for him **

July 13, 2008 9:43:40 PM

Oh come on audiovoodoo, its not THAT bad, it just takes a little bit of brain power. And, of course, after I see what the solutions are for my problems, they seem so simple, so a lot of it comes from being unfamiliar with a different system. In the future though, if I had to do this on another machine, I think it would go a little bit more smoothly.

-Zorak
July 14, 2008 11:12:44 AM

im with AV on this one, i wouldnt want to go through all that to set up a OS, although i might try it just for fun, been reading into it a bit more, very customizable very good looking.
a b 5 Linux
July 14, 2008 5:47:00 PM

@Zorak
Granted, the process you describe still sounds easier than tying to get decent grahics support for my X3500 IGP under Vista64. ;)  In all seriousness though I think Gentoo is a great way to force yourself to learn more about linux. The real question is what advantage you get from doing it. Yes, good knowledge of the system but I read a few things that suggest that unless you know your package management and compiler options that you can end up with a system slower than pre-compiled units.

I've just not got the patience for Gentoo. I might yet have a play in VM's at some point but for now I'll pass.
a b 5 Linux
July 15, 2008 3:46:33 AM

@Zorak congrats, you are now an Übergeek :D 

As audiovoodoo said Gentoo scores major points for its educational value :) 

Some would argue it loses some points for being less practical than your typical distro.

I'm ashamed to admit I've never tried it, although back in the day I used to religiously build my kernels and many apps from source. Back in those days you would start a compile and walk away for 2-3 days. If you were lucky you'd be done on the 4th day if your build hadn't failed the previous day.

lol :) 
July 15, 2008 9:07:31 AM

Haha Linux_0, thank you for the new status! Just as in the days of old when it took either a noble or another knight to recognize a man as a knight and confer the title upon him, so has Linux_0 "knighted" me :p 

I think that for any serious linux user, and/or programmer who is familiar with GCC, figuring out which USEFLAGS to use isn't really going to be all that hard. What you don't know, they have excellent reference material to teach you, which is part of what I like about this distro. Also, the people on #gentoo were very helpful and politely point people to the manuals if it is obvious that a person has not read them first. So, I think a guy like audiovoodoo or defninitely Linux_0 would be able to take to this distribution like a duck to water. That being said, this distribution is clearly not like ubuntu! When my sister's computer's motherboard died i set up a user for her (when i was still on ubuntu on my box) and she was able to basically figure it out by herself, but she would be UTTERLY LOST if something went wrong on this new distro!

I have heard gentoo being extolled as the "programmer's dream OS" and I must say that it does come with some nice programming tools right out of the box. I didn't even have to install bison or flex as they were already included. Then again I'd expect a distribution that depends heavily on compiling source to come with some at least half decent compilation tools out of the box ;D

Also, compiling hasn't really taken an inordinate amount of time... yet. From what I am told, I should expect to try recompiling my entire environment on a bi-weekly basis or so, although i don't HAVE to. It is a little bit silly though that I only just finished setting up my system when kernel 2.6.26 comes out :o  I suppose I could see this compiling time as a chance to catch up on my exercise as some of the bigger packages like GNOME and Xorg (and eventually open office) take an hour or more. So, it looks like this distribution will have the added bonus of giving me a full mental and physical work out!

In any case, i only had 2 things left in my way before my system was EXACTLY how i want it and those were audio control via the gnome audio controller and compiz-fusion. I managed to fix the former today by installing the 'gst-plugins-alsa' package which I thought would have been included already. After installing it, my volume control keys on the keyboard work just fine now, so that is nice. All that remains is for me to figure out why compiz fusion is refusing to start the emerald window decorator, leaving my windows borderless. That and compiz has a nasty tendency to break my terminal key binding and then when i open a new terminal it is completely white and unreadable. But, aside from that little hickup I have a pretty smoothly running system now, and its great :D 

-Zorak

P.S. Is compiling an entire distribution on a virtual machine even considered a sane idea? (I'm looking at you audiovoodoo :D  )
a b 5 Linux
July 15, 2008 10:32:59 AM

Welcome to the Knights of the Nine :lol: 

Alas I cannot promote you any further, for that you need to talk to Linus himself at
Cloud Ruler Temple. Although I hear RMS is selling bootleg membership certificates at the Imperial City's Waterfront District.

:lol: 

Seriously now, Linus and RMS ( and several others but there is no room to list them all here ) deserve a real Knighthood or Presidential medal and our eternal gratitude for that matter even though it would ruin their geek cred :) 

All other contributors deserve our appreciation and our respect as well.

On another note, everyone please pick up your Linux phones, call Bethesda and tell them you can't wait to buy a native Linux version of TES5! :D 
July 16, 2008 3:26:09 AM

Haha, very nice metaphors Linux_0. I just wanted to say that my system is now 100% how I want it! :D 

I got compiz working properly today thanks to the nice people over at #compiz (it turns out i just needed to add a line to my xorg.conf), and I must say it is nice seeing things moving pretty smoothly. The only thing that is a tad disappointing is the fact that if i start a game while compiz is enabled, performance suffers, but I know how to temporarily shut down compiz by hand before i start gaming so that isn't such a big deal.

I can't possibly agree with you more about all the hard work and effort put in by the countless programmers that have enabled me to do what I have done. Creating an operating system from scratch is no small feat, even if you do have a model to draw ideas from. So, even though they will probably never read this, I'd like to thank all the Linux devs, the GNU devs, the Mozilla devs, the GNOME devs, the Gentoo devs and most of all the Linux community. Without their hard work and impressive level of collaboration and their commitment to open standards as well as open source, NONE of this would have been possible.

I must say that I am very excited to have a 100% custom machine at my disposal now that easily exceeds any machine that Dell, HP, apple, or any other prefabricated computer vendor has to offer. From here, I expect to continue learning about Linux and Gentoo, but I suspect that additional knowledge will come at a diminished rate after this relatively explosive period of learning for me. So, with that being said, I conclude this story of my initial encounter with Gentoo Linux. I hope it has been entertaining and enlightening for all who have read this topic.

-Zorak
a b 5 Linux
July 17, 2008 5:33:39 PM

I wonder.. If enough people wrote to the Queen we could actually get Linus a knighthood?? I'll have to have a hunt for the address and try putting it on /. ;) 
a b 5 Linux
July 24, 2008 2:42:04 AM

Welcome to the ranks, Zorak! Before you know it, you'll be successfully upgrading kernels remotely over an ssh connection (the first time may not pan out, but I tell you, there are few better feelings in the world than issuing "shutdown -r now && exit", anxiously "pinging" the remote host, seeing responses coming back (this part is the killer), logging in, and having "uname -a" show a spankin' new kernel).
July 24, 2008 2:17:51 PM

Thanks for the welcome! :)  I actually did my first 'emerge -vaNDu world' the other day and apparently I did something stupid and broke a lot of stuff in the process haha. Thankfully there was a very nice person in #gentoo that told me of the wonders of revdep-rebuild. With that I was able to successfully fix reverse dependencies and get my system working again. To be fair, I don't think I actually saw anything that seemed broken, but I did have a couple of failed emerges and I was a bit worried about that for a little while. When i did my revdep-rebuild though, I had my first brush up with a bug in gcc where it had missing symlinks to some gcj related stuff and so my system recompiled all of gcc. :( 

I went through that twice wondering why it still said gcc was broken, only to find out later that it was a minor glitch that can be fixed manually and will be addressed sometime soon.


So, what I thought would take maybe two hours ended up taking about a day for me, but it was a valuable learning experience :D .

Aside from that now, my computer has been having some heating issues so I am trying to find a better place to put it in my computer room and then I will probably reattach my heatsink and reapply the thermal paste just to be sure.

-Zorak

P.S. On a side note, I assume your job brought you to my home town? How do you like Austin so far?
a b 5 Linux
July 25, 2008 6:29:00 PM

What kind of cooler do you have?

Did you get an antec 300 or 900?
July 26, 2008 5:13:22 AM

I was using the stock Heatsink/fan that came with my q6600 and I got an antec 900 so I have 2 fans on the front, a larger one in the back, and a HUGE ASS HONKIN' fan on top. I reapplied my thermal paste today and now it seems to be doing MUCH better. Under load with a graphically intense game i didn't see temps over 61C and on idle it is around 38 or 40 C which is much better than before :) . That and I also don't get any more messages in dmesg saying that it needs to throttle back my CPU speed due to high temperature. The only odd thing I noticed though is that when I reinstalled my CPU the BIOS said it was clocked at 1.6GHz instead of 2.4GHz, so I had to go in there and fix that. Otherwise it seems my troubles are all over now :D 

-Zorak
a b 5 Linux
July 26, 2008 5:23:50 AM

Ah yes, the joy of having to rebuild older packages due to new libraries/tools. I usually find that I end up using revdep-rebuild to get a list of probably-b0rken packages, then upgrading those anyway (usually since the versions that need rebuilding have dropped out of portage (whoops, maybe I should update my systems more often).

Yep, I am indeed in weird, weird Austin, loving the Congress bridge bats, cursing the 35, 183, and MoPac traffic, waiting anxiously for ACL, still waiting to see the mystical salamanders at Zilker park, getting some good Texas BBQ at Ironwork and the Saltlick, hitting up one of the Drafthouses (saw Dark Knight tonight with a bucket of Fat Tire and a great burger), etc. etc. Needless to say, I'm enjoying
July 26, 2008 5:40:15 AM

I kinda want to head down to the Bob Bullock museum to see the new Batman movie on IMAX, but that is getting very much off topic!

-Zorak
!