Sign in with
Sign up | Sign in
Your question

Unable to select own desktop background in Ubuntu

Last response: in Linux/Free BSD
Share
August 15, 2008 5:10:35 AM

Hi,

I've installed Ubuntu 8.04LTS (64-bit) recently and something I've noticed is that I am unable to change the desktop background to anything else besides the 3 or 4 backgrounds that comes pre-loaded.

When I go into the menus for adding a new background, I can view the pictures but as soon as I choose to add it as a background nothing happens and I am back to main menu for changing the background with the 3 or 4 standard Ubuntu backgrounds.

Any help would be appreciated.

August 16, 2008 11:30:41 PM

What kind of images were you trying to use for the background?

Your own or did they come with Ubuntu?
August 17, 2008 3:52:42 PM

They were my own images. jpeg There are a couple that comes with Ubuntu that also doesn't want to load. Space ones.
Related resources
August 19, 2008 7:02:38 PM

Can you create directories / save files in your home area?
August 20, 2008 4:32:12 AM

Hi thanks for the reply. I am able to save files to my desktop and move them around from the Desktop to Documents etc. I am considering formatting the HD and re-installing everything since my graphics card drivers have also stopped working after I installed virtualbox. No more 3d desktop effects for me either at the moment. Maybe the easiest option would be to re-install. I don't have alot of data/programs on the installation at the moment. Thanks for the help.
August 26, 2008 8:38:11 AM

Hmm.. Doesn't sound like a permissions problem. I've never had an issue with backgrounds and unfortunately don't have Ubunt installed at the minute. I'll try and get it up in a VM today and have a look for you.

Any error message on the graphics card issue?
August 26, 2008 9:24:52 AM

Hi audiovoodoo, thanks for the reply. I can't remember the exact message on the graphics card issue but whenever I went into the XServer settings it said something about the Xserver drivers not being loaded or running. And that I should run nvidia-xconfig to fix it. That didn't help.I did try a couple of things like re-installing all the drivers and un-installing virtualbox and compiz.Also enabled and disabled the restricted drivers without any success.My MB has an integrated GPU (Nvidia 6200) and I wonder if that wasn't clashing with the 8800GT that I have installed. My Linux skills are very limited but I am going to give it another try.I really enjoy the cube effects and the 3-D desktop. I am going to format and try get everything going again. :-)
August 27, 2008 5:04:12 PM

Sorry - things have been a bit hectic so I've not had chance to test. In terms of the graphics issues I'd make sure you disable the 6200 on board card through BIOS as this won't be making your life any easier.
August 27, 2008 6:35:35 PM

No problem :)  I've re-installed Ubuntu 8.04 64-bit tonight and managed to get everything set up the way it was before. All my desktop effects are back including the 3-d cube.(I lost it when I installed virtualbox). Don't think I will be trying to install it again any time soon! Most importantly I am able to select my own backgrounds now. I appreciate your help on this.
September 1, 2008 6:19:17 PM

Glad to hear you've got it back. :) 
!