Sign in with
Sign up | Sign in
Your question

Ubuntu Live won't recgonize my hard drive

Last response: in Linux/Free BSD
Share
October 5, 2008 4:12:59 AM

Okay, so I download Ubuntu live and burn it to a cd. I stick the cd in the drive of the computer that has the data that I am trying to recover (computer lost power when XP was shutting down, so XP got messed up) and it load to ubuntu live just fine. But when I go to "My Computer" only the cd-drive is there. If I try to boot to XP it shows the XP loading screen and the randomly reboots (If I do that and walk away it starts a never ending reboot cycle), so I know for a fact the drive is plugged in correctly and powered. It shows up in the Bios in the first SATA slot. But no matter what I do, it won't show up. I have tried typing "fdisk -l" and "sudo fdisk -l" into terminal, but absolutely nothing happens; it acts like nothing was typed in at all. Any ideas as to why the hard drive which seems to be working won't show up in Ubuntu?
October 5, 2008 9:35:36 AM

What are your full specs?

Which version of Ubuntu are you trying?

Some versions of Ubuntu may not be able to recognize your SATA controller.

If the latest Ubuntu doesn't work try the latest version of fedora ( currently fedora 9 ).

http://fedoraproject.org/en/get-fedora fedora has a live CD just like Ubuntu.

Good luck :) 
October 5, 2008 11:01:37 AM

Hmmm.. This might well be an unrecognised controller. As per the comment from Linux_0 knowing your specs would let us know this for sure. As for Ubuntu versions the latest current release is 8.04. If you are using a version older than this then I would recommend you get either 8.04 or as Linux_0 suggests the latest Fedora.

One quick and dirty hack that I have used before to get round this is to stick the disk into an external USB enclosure, that way you remove the issue of the SATA controller. Not a long term fix but it will let you get your data.

Could you open an terminal and at the command prompt type 'mount' this will tell us what disks Ubuntu has mounted when it started up. Sometimes the automount feature can play up and it might be we'll need to help you mount the disk manually.

Related resources
October 5, 2008 11:56:59 AM

I agree with audiovoodoo :)  If the disk is healthy you should be able to access it with ubuntu 8.04 or fedora 9 using SATA or an SATA to USB adapter, although if your drive is failing it may not be a good idea to fudge with it too much because you could make it worse.

Is S.M.A.R.T enabled in your BIOS? Is it crying for help?

If you manage to get your drive working again now might be a good time to backup your data.

Good luck :) 
October 5, 2008 12:25:11 PM

The other way... Boot of your XP install disk and run the repair installation options. It's been a while since I did it but I'm sure you can initiate a disk check from there.
October 5, 2008 12:35:28 PM

:lol:  audiovoodoo

I would suggest ubuntu 8.04 or fedora 9 first over the xp repair options, if you manage to read your drive run a backup under linux to DVD-R or an external drive. After you save all your important stuff have fun with xp repair or whatever you wanna do :) 
October 5, 2008 3:00:57 PM

Last time I looked ntfs3g support did not include an fsck type option. Laugh by all means but most times that XP fries itself the repair option will get you back to a booting state.

Given that Ubuntu (version not yet known but you would have to have gone hunting to get an old version) seems to have a SATA controller issue the likelyhood is that so with Fedora (yes, it's newer, but this is kernel level support is it not?) then you'll likely find issues there too. The proirity in a situation like this is to get the data off the drive, the system is down and out. Sometimes the easy option is the best one to take.

October 5, 2008 3:05:30 PM

@linux_0 My specs are as follows: Abit I35 Pro, Intel q6600 G0 stepping @ 2.4 Ghz, Maxtor 500gb HD, A basic Sony DVD-RW CD-RW drive, ATi X1800XT, Corsair HX 550, and 2x1Gb OCZ Platinum PC2 6400. I am using the latest version of Ubuntu which would be 8.4.1 I believe. I never noticed it before, but I cannot find any setting for S.M.A.R.T. in my bios. Although my sata controller and drive are set for IDE in my bios if that helps at all. I remeber some people saying they couldn't get it to install unless they switched those settings to RAID. When I type "mount" it seems to only show details about my CD drive, but I can post the full results if you would like. I am download fendora now and will post in a little while the results I get with Fendora live. How might I go about mounting the disk manually?
October 5, 2008 3:08:31 PM

@ audiovoodoo I might try that because I have had luck with that in the past before, but I wanted to do a cleaner and quicker route of copying the data to the drive and then reformatting rather than repairing, copying, and then reformatting. But if nothing else works, then I will go that route. Thanks for all the help so far everyone!
October 5, 2008 4:50:23 PM

If the drive is in IDE mode it should be /dev/hda, in SATA mode it should be /dev/sda

"dmesg" should tell you what devices the kernel found at boot

You can use grep to filter the output of dmesg, for example "dmesg |grep ata" and PM or post the output here

You can try "smartctl -d ata -T permissive -a /dev/sda" and "smartctl -d ata -T permissive -a /dev/hda" to try to get the S.M.A.R.T. status from the drive but this doesn't always work

ntfs3g works pretty well, if the drive isn't damaged it should be able to read your data

ntfs-3g mount examples

"ntfs-3g /dev/sda /media"

"ntfs-3g /dev/hda /media"

"ntfs-3g --help" for help

Good luck :) 
October 5, 2008 8:43:18 PM

ubuntu@ubuntu:~$ dmesg |grep ata
[ 0.000000] BIOS-e820: 000000007fee3000 - 000000007fef0000 (ACPI data)
[ 29.997523] Memory: 2065816k/2096000k available (2177k kernel code, 29120k reserved, 1006k data, 368k init, 1178496k highmem)
[ 29.997533] .data : 0xc0320434 - 0xc041bdc4 (1006 kB)
[ 33.347451] libata version 3.00 loaded.
[ 35.066341] ata1: SATA max UDMA/133 abar m8192@0xfdefe000 port 0xfdefe100 irq 16
[ 35.066344] ata2: SATA max UDMA/133 abar m8192@0xfdefe000 port 0xfdefe180 irq 16
[ 35.385734] ata1: SATA link down (SStatus 0 SControl 300)
[ 35.705490] ata2: SATA link down (SStatus 0 SControl 300)
[ 35.708086] ata_piix 0000:00:1f.2: version 2.12
[ 35.708090] ata_piix 0000:00:1f.2: MAP [ P0 P2 P1 P3 ]
[ 35.709123] scsi2 : ata_piix
[ 35.709183] scsi3 : ata_piix
[ 35.709541] ata3: SATA max UDMA/133 cmd 0xf900 ctl 0xf800 bmdma 0xf500 irq 18
[ 35.709543] ata4: SATA max UDMA/133 cmd 0xf700 ctl 0xf600 bmdma 0xf508 irq 18
[ 65.846531] ata3.00: qc timeout (cmd 0x27)
[ 65.846535] ata3.00: failed to read native max address (err_mask=0x4)
[ 65.846539] ata3: failed to recover some devices, retrying in 5 secs
[ 100.987783] ata3.00: qc timeout (cmd 0x27)
[ 100.987788] ata3.00: failed to read native max address (err_mask=0x4)
[ 100.987791] ata3.00: revalidation failed (errno=-5)
[ 100.987793] ata3: failed to recover some devices, retrying in 5 secs
[ 136.129236] ata3.00: qc timeout (cmd 0x27)
[ 136.129240] ata3.00: failed to read native max address (err_mask=0x4)
[ 136.129243] ata3.00: revalidation failed (errno=-5)
[ 136.129245] ata3.00: disabled
[ 136.632746] ata3: soft resetting link
[ 136.788639] ata3: EH complete
[ 136.955097] ata_piix 0000:00:1f.5: MAP [ P0 -- P1 -- ]
[ 136.955155] scsi4 : ata_piix
[ 136.955201] scsi5 : ata_piix
[ 136.955401] ata5: SATA max UDMA/133 cmd 0xf200 ctl 0xf100 bmdma 0xee00 irq 18
[ 136.955403] ata6: SATA max UDMA/133 cmd 0xf000 ctl 0xef00 bmdma 0xee08 irq 18
[ 137.282895] scsi6 : pata_jmicron
[ 137.282929] scsi7 : pata_jmicron
[ 137.282950] ata7: PATA max UDMA/100 cmd 0xcf00 ctl 0xce00 bmdma 0xcb00 irq 22
[ 137.282952] ata8: PATA max UDMA/100 cmd 0xcd00 ctl 0xcc00 bmdma 0xcb08 irq 22
[ 137.616411] ata7.00: ATAPI: SONY CD-RW CRX320EE, RYK4, max UDMA/33
[ 137.788764] ata7.00: configured for UDMA/33


Can anyone make any sense of that?
October 5, 2008 9:15:11 PM

Fendora shows a SCSI drive that is not mountable, but other than that, no drive still. Anyone have any ideas?

This is what I get when I type "mount" By the way:

[fedora@localhost ~]$ mount
/dev/mapper/live-rw on / type ext3 (rw,noatime)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
tmpfs on /dev/shm type tmpfs (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
/dev/sr0 on /mnt/live type iso9660 (ro)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
gvfs-fuse-daemon on /home/fedora/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=fedora)
October 6, 2008 2:22:10 AM

Seems like port 3 is throwing out interface errors.

Can you please PM me the full dmesg output from Ubuntu and Fedora? It's big, really big but it should tell us more.

If your drive is on port3 then that's probably the problem. Maybe you should replace the SATA cables ( both POWER and DATA ) and try another port on your mobo.

Try to be as gentle as you can be, the SATA connectors are pretty flimsy.

Good luck :) 
!