Sign in with
Sign up | Sign in
Your question

Cant mount hard drives!

Last response: in Linux/Free BSD
Share
December 17, 2008 9:47:28 PM

I recently had a motherboard short out. The computer in question was so old I decided to build a new system rather than replace the board. Once I built my new pc, I put my old hard drives into it (pata). The two hard drives are western digital caviars formatted in ntfs. There is a 80gb and a 500gb. I want to copy my old files from the 80gb onto the 5000gb so I can reinstall windows (old install was not bootable.) I load up a knoppix live cd (actually, I have it on a flashdrive), but the only drive visible is my flash drive (it is listed as sda1). I cannot seem to mount my hard drives. When I type mount into the command prompt, I get a list of drives/ramdisks, but none looks like either of my hard drives, although I'm not sure I'd know what to look for anyway. They all fail to mount or are already mounted. I believe this problem may have something to do with the fact that my new motherboard uses a marvell ide controller, but this is just a guess. I also made a windows xp live cd with Barts PE loader and it couldn't detect my hard drives either. What can I do? Thanks ahead of time!

More about : mount hard drives

December 18, 2008 4:56:52 AM

If the drives don't show with both Knopix and BartPE, I'd suspect you either have an odd chipset that Linux doesn't yet support (and Windows needs a driver) or they *could* have been damaged by the MoBo short.

Try connecting the drives (one at a time) to another Windows PC and see if Device Manager detects them.
December 18, 2008 5:36:37 AM

I think MrLinux is probably right. Many newer motherboards come with really crappy IDE chipsets ( JMicron :cough: :cough: ) which can have very poor compatibility with Linux, *BSD and even windows.

You may need to manually install the driver.

Run "lspci -vvvvv" on Knoppix and post it here or PM it to me.

That will hopefully help us figure out what kind of chipset you have.

Good luck :) 
Related resources
December 18, 2008 11:08:08 PM

MrLinux and linux_0, thank you both for the replies. I beleive these hard drives are functional because they list during post. I ran lspci -vvvvv and this is what it returned. I beleive this is the part that concerns my ide controller.
Quote:
0000:02:00.0 IDE interface: Marvell Technology Group Ltd.: Unknown device 6101 (rev b2) (prog-if 8f [Master SecP SecO PriP PriO])
Subsystem: ASUSTeK Computer Inc.: Unknown device 82e0
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
Latency: 0, Cache Line Size: 0x08 (32 bytes)
Interrupt: pin A routed to IRQ 10
Region 0: I/O ports at dc00
Region 1: I/O ports at d880
Region 2: I/O ports at d800
Region 3: I/O ports at d480
Region 4: I/O ports at d400
Region 5: Memory at feaffc00 (32-bit, non-prefetchable)
Capabilities: [48] Power Management version 2
Flags: PMEClk- DSI- D1+ D2- AuxCurrent=0mA PME(D0+,D1+,D2-,D3hot+,D3cold-)
Status: D0 PME-Enable- DSel=0 DScale=1 PME-
Capabilities: [50] Message Signalled Interrupts: 64bit- Queue=0/0 Enable-
Address: 00000000 Data: 0000
Capabilities: [e0] #10 [0011]


I beleive this is a pci ide card I have installed. It should not affect anything since the only thing on it is my dvd drive (it isn't detected either, but I don't need to access it.).

Quote:
0000:04:00.0 RAID bus controller: VIA Technologies, Inc. VT6421 IDE RAID Controller (rev 50)
Subsystem: VIA Technologies, Inc. VT6421 IDE RAID Controller
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
Latency: 64
Interrupt: pin A routed to IRQ 17
Region 0: I/O ports at ec00
Region 1: I/O ports at e880
Region 2: I/O ports at e800
Region 3: I/O ports at e480
Region 4: I/O ports at e400
Region 5: I/O ports at e000
Expansion ROM at e0000000 [disabled]
Capabilities: [e0] Power Management version 2
Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
Status: D0 PME-Enable- DSel=0 DScale=0 PME-


To prevent having a HUGE thread, I have uploaded the entire txt file of the lpsci command here. Would it help for me to try a different live operating system? (whether linux or any os)
December 19, 2008 12:56:47 AM

Can you also run dmesg and post it too?

I'm having some trouble getting the full lspci from box.net can you use pastebin.ca or pastebin.com instead?

:) 
December 19, 2008 1:33:17 AM

Do you have LVM volumes on your disk? I had a hard time getting access to my LVM partitions when I had to boot from a Linux CD after suspend trashed the file system.
December 19, 2008 1:59:28 AM

LVM works fine even from a rescue or Live CD. I have not had any problems with LVM.

Semper Fi :) 
December 19, 2008 2:15:32 AM

I'm not sure what a LVM is (?Linux Volume?), so I don't believe that I am using one. I've never used pastebin before so I hope i did this correctly. Its getting late here so I will run dmesg tomorow. (just type dmesg into the command prompt?). I may get home late tomorow, but I will run dmesg and post as soon as possible. Thanks for the replies!
December 19, 2008 9:42:00 AM

Thanks got it :) 

How old is your copy of Knoppix? Do you know what version it is?

It looks like you have an ASUS Intel board with some very new hardware and Knoppix is having some trouble picking it all up ( probably because it's older ). Your lspci is full of unknown devices.

Ubuntu 8.10 desktop amd64 ( x86_64 ) or Fedora 10 x86_64 should be able to recognize more of your hardware, both have Live CD versions.

Between the two Fedora usually has better device support than Ubuntu. Most of the time if your hardware isn't recognized by the latest Fedora, try the latest Ubuntu and vice versa.

http://fedoraproject.org/en/get-fedora

http://www.ubuntu.com/getubuntu/download

Good luck :) 
December 19, 2008 11:58:04 AM

I believe my current version of knoppix is 5.0. I have also tried 5.1.1. I think the newest version is 5.1.3 but I cant use that because my only computer with a dvd burner is out of comission. :(  (although, I guess I could put it on my flashdrive. big download anyway.) Will run dmesg when I get home from school, time allowing. Thanks again!
December 19, 2008 12:13:49 PM

You can use k3b ( kick *** CD/DVD burning software ) from within Knoppix booted from your flash drive to burn an Ubuntu 8.10 desktop amd64 ( x86_64 ) or Fedora 10 x86_64 CD :) 

The Live CDs can be downloaded from various mirrors around the world ( see links above ) and are about 650-700MB each, which is large but a lot smaller than a 4.3GB DVD :) 

Fedora has the latest drivers, software and kernels so it usually has very good hardware support. Ubuntu is a close 2nd.

Try both if you can :) 
December 19, 2008 6:14:58 PM

I ran dmesg. Here are the results. I will try Fedora as soon as possible. I'm going to have to head out in a little while so I may not get to it until tomorrow. I appreciate all the help!
December 20, 2008 6:02:25 PM

I made a live usb of Fedora ten and it works great. It even found my ethernet drivers. I may actually make a full install on my hard drive once I get everything working. I've been wanting to get experience with linux for a while but I always have driver issues. Thanks for the tip linux_o!
December 21, 2008 4:55:15 PM

Nice, good to hear it's working :) 

Happy yuming :) 
!