Sign in with
Sign up | Sign in
Your question
Closed

Vista Ultimate Radeon X1950 Pro Problems

Tags:
  • Drivers
  • Windows Vista
Last response: in Windows Vista
Share
October 27, 2007 9:19:48 PM

I was enabling the Administrator account today, uninstalling various odds and ends on my login to reinstall on my Administrator(the actual admin, not just an account with Admin priveleges) and I logged in to the Administrator. My Catalyst Control Center wasn't appearing, so I clicked on it. It opened, then I enabled "Crossfire"(Two Video Cards, Have YET to Work). The screen goes black, usual. But it doesn't get out. So after about a minute I push restart, then it resets the system and I log back in.

When I log back in, it says something like:

"No driver hardware found or incorrect drivers installed"

Something like that. So I uninstall the drivers and reinstall them and they still don't work! What do I do? I want to play the Crysis SP Demo and if my dad sees this he'll be all complaining and whining(he's 58 and I'm 15 and I barely whine compared to him) and I want to get this fixed(I'm no computer newb). My specs are:

AMD Athlon 64 X2 Dual Core Processor 4600+ 2.41 GHz
Memory: 3071 MB

The graphics cards are ATI Radeon X1950 Pros. Both of them. We are supposed to have Crossfire but it has never worked, but now the drivers won't even work. I'm running Vista Ultimate.

Thanks,
Nate

More about : vista ultimate radeon x1950 pro problems

Best solution

a b \ Driver
October 27, 2007 11:13:00 PM

Sounds like a Driver problem - I'd start the search here: http://forums.amd.com/game/
Share
!