Sign in with
Sign up | Sign in
Your question

DSL (Damn Small Linux) Live USB Issues

Tags:
  • DSL
  • Boot
  • USB
Last response: in Linux/Free BSD
Share
July 29, 2009 6:01:58 PM

I need help! As you may know, DSL can boot from a live USB. I've tried all 4 guides at DSL's wiki, http://www.damnsmalllinux.org/wiki/index.php/Install_to... . Method 1 and 3 worked, but the problem is when the booting started, it hung at "Checking for for USB..." as in the blinking cursor stopped blinking. Even when I boot from a live CD that is still the case; just so I could boot, I have to remove my pendrive, thus I can't use the pendrive. What should I do to boot from a live USB?

These are my specs if needed:
Mo-Bo: AsRock N68PV-GS
Pendrive: Transcend V30 2GB
CPU: AMD Athlon 64-bit X2 2.4GHz +4800

More about : dsl damn small linux live usb issues

July 29, 2009 6:31:12 PM

Does it boot from the live CD without the flash drive plugged in?
July 29, 2009 6:42:07 PM

Like I said, yeah. It's more like, it can't boot with the flash drive plugged in.
Related resources
Can't find your answer ? Ask !
July 29, 2009 8:41:23 PM

This is most likely down to the boot order in your BIOS. You need to ensure the CD is higher in the boot order than any USB-HDD or USB-Flash device.
July 29, 2009 8:49:45 PM

No, I'm sure it's not that. It's like this. I tried booting from a live USB first, but then at the phase of the booting that says, "Checking for for USB...," it gets stuck. So after that I tried to use a live CD, but during the boot-up process, the same thing happens. So I tried taking the pendrive out. The boot worked, but I obviously couldn't use my pendrive. How can I resolve this.
July 29, 2009 9:10:56 PM

Hmmm... Are you 100% sure? The only other thing I can think of is that the USB pen does not support booting, some just don't work. Is the pen recognised if you plug it in once booted? I know it won't let you use it for config storage that way but it might give us a clue.
July 30, 2009 5:44:47 AM

Try disabling legacy USB support in the BIOS (if it supports it).
July 30, 2009 7:00:44 AM

No. With DSL, you can't or I don't know how you can read a USB stick if you don't boot with it. I'm still learning the ropes you see... Without anything else for booting, other than my HDD which has Windows which I don't select for booting. It reads the pendrive ok. But once the booting happens. The phase where it says, "Checking for for USB...," it hangs like I said.

Yup, I did turn on legacy support. I'll try disabling it and come back to you guys. :) 
July 30, 2009 7:40:16 AM

It's weird. When I disabled "USB Legacy Support," the BIOS didn't read my pendrive as bootable. I know this pendrive is not legacy, or is it? There were 3 other options, namely: For BIOS Use Only(or something like that), Auto, and Enable. I also tried "For BIOS Use Only." It booted, but the same thing as before happened still in the booting phase of "Checking for for USB..." In the USB configuration options there were also "USB 2.0 Support" and USB Controller(I think).
July 30, 2009 9:01:43 AM

I'm sure I've run DSL and stuck a pen in after it was booted. You might need to go into media/USB to see the contents but I'm sure it worked.
July 30, 2009 9:07:58 AM

I'll try. BRB.
July 30, 2009 9:41:24 AM

It doesn't seem to be detected. Dang! Well, when you put in a pendrive, it said that there should be an option to mount it. Mine doesn't get that option for some reason. I can't access the contents either from mnt/sda. Is there a "cheat code" or driver I need to use. My ethernet card doesn't get detected. I tried installing from a CD, but it won't allow me because, after all I am using a live CD.
July 30, 2009 10:32:43 AM

Hmmm.. what file system are you using on the pen drive? Did you format it under windows and can you see it when you boot windows if that is an option. Also do you have another pendirve that you can test with, and have you tried plugging it into any of the other USB ports?

Your kit is reasonable so this should all work. Any other liveCD's to hand that you can try? The Ubuntu one does have an automounter so anything you plug in after booting should appear as an icon on the desktop.
July 30, 2009 10:38:24 AM

Quote:
Hmmm.. what file system are you using on the pen drive?

FAT32.
Quote:
Did you format it under windows and can you see it when you boot windows if that is an option.

Yes and what do you mean can you see it when you boot Windows? When I'm using Windows? Yeah, it can be seen.
Quote:
Also do you have another pendirve that you can test with, and have you tried plugging it into any of the other USB ports?

No and I haven't tried that yet.
Quote:
Any other liveCD's to hand that you can try?

Do you mean other than DSL?
July 30, 2009 10:57:41 AM

Yes, I do mean other than DSL. The format is fine, FAT32 is the lowest common denominator in terms of formats so that should be OK. The fact that it works under windows shows the drive is working. I have to be honest I'm running out of ideas. The only thing I can think of is that your chipset is no supported under DSL. Good as DSL is it's not the most up to date of distributions.

I suggest you try a differed linux distribution, Ubuntu & Fedora are both well known for supporting more recent HW as they have a very active development community. The Ubuntu liveCD will allow you to use it just as a liveCD or to install it. You might well find it also supports your network card. It could be a boot option (cheat code) but I'm not familiar with all of them. Maybe one of the other folks down here might have some other suggestions.
July 30, 2009 11:01:59 AM

Actually I'll add another suggestion in terms of other distributions to try, Slax is more like DSL than either Fedora or Ubuntu. Other than that you could try the 'waitusb' cheat code but I really doubt that will help you out much. Try that with the pen drive plugged in, it's got to be worth a shot.
July 30, 2009 8:39:17 PM

audiovoodoo, you've been great. Thank you! :)  I'll think about your suggestions.

If any one has any knowledge on this topic, feel free to speak up.
August 2, 2009 2:20:33 AM

As audiovoodoo said, your hardware is modern enough to have some issues with DSL.

Definitely give Ubuntu and Fedora a try, they are updated every 6 months and usually support more recent hardware quite well.

If Ubuntu doesn't work try Fedora and vice versa.

Fedora usually works on hardware that Ubuntu doesn't work on and sometimes the other way around.

http://www.ubuntu.com/getubuntu/download make sure you get the 64bit amd64 version!

http://www.fedoraproject.org/en/get-fedora-all make sure you get the x86_64 / amd64 64bit version!

Good luck :) 
August 2, 2009 3:52:38 AM

I didn't know that DSL has modern hardware issues. (Sigh) Are you really sure it can't be my pendrive?
August 2, 2009 4:03:20 AM

It could still be your pendrive or your usb controller on your motherboard but definitely try Ubuntu and Fedora and see if it happens again.

If the same problem happens on Ubuntu, Fedora and DSL then the problem is probably caused by your your usb controller or pendrive.

Have you tried any other pendrives / usb flash drives?

DSL uses the 2.4 kernel and only releases a new version every few years.

Ubuntu and Fedora use some of the latest 2.6 kernels and release a new version every 6 months so they have much better hardware support and offer the latest versions of most applications.

Again make sure you get the x86_64 / amd64 64bit version, it runs a lot faster and has nice features which the 32bit version doesn't.

Good luck :) 
August 2, 2009 4:05:00 AM

Yeah, thanks man. I'll just try DSL on my old PC, if I manage to fix it! LOL! :p 
August 2, 2009 4:08:54 AM

Fedora should run very well on your AMD Athlon 64-bit X2 2.4GHz +4800 :) 

Ubuntu too.

What kind of graphics card do you have?

:) 
August 2, 2009 6:47:01 AM

It's an onboard NVIDIA GeForce 7050 PV / NVIDIA nForce 630a.

Thanks for your help. I'm really appreciating this. You don't have to do this of course, but it's up to you. :) 
August 2, 2009 8:15:37 AM

That should work fine, try Fedora11 x86_64 and then Ubuntu desktop amd64 :) 

rpmfusion has the nvidia drivers for Fedora and ubuntu should volunteer to install the nvidia driver for you.

Good luck :) 
August 3, 2009 8:07:07 AM

Quote:
rpmfusion ... should volunteer to install the nvidia driver for you.

What do you mean by that?

Where can I find this guy?:) 
August 3, 2009 6:14:31 PM

Hey guys! Great news. I asked at AsRock, my Mo-Bo makers, about this issue, and guess what? Thay had a special BIOS update for this situation. It worked! Yepee! But now the proble is that when it boots from the pendrive, it says, "Can't find knoppix file system ... limited shell..." Something like that. I heard this was a really common problem with Knoppix and its derivations like DSL. I didn't find an soulution. While I'm looking, if anyone may know, please tell me. It would be greatly appreciated. :) 
August 3, 2009 6:16:11 PM

It will work without the nvidia driver.

If you want the proprietary driver you have to install it.

http://rpmfusion.org/

:) 
August 3, 2009 6:46:08 PM

Quote:
It will work without the nvidia driver.

If you want the proprietary driver you have to install it.

Ok then. Thanks.

If anyone knows how to resolve my problem with DSL, please tell me. :) 
August 4, 2009 5:55:14 AM

I solved the problem myself! Yepee! Here's a brief description/guide for anyone that reads this with the same problem(live USB). :) 

First of all my specs were:
Mo-Bo - Asrock N68PV-GS - http://www.asrock.com/mb/overview.asp?Model=N68PV-GS&s=...
CPU - AMD 64-bit Athlon X2 4800+
RAM - 2X1GB Kingston Dual-Channel(256MB used by GPU)
USB flash/pendrive - Transcend V30 2GB(orange collar)
OS - Windows XP Professional SP3
GPU and ethernet are built-in(Look at link above).

Check this guide out, http://www.damnsmalllinux.org/wiki/index.php/Installing...

I use Windows, so I used Method I of this guide: http://www.damnsmalllinux.org/wiki/index.php/Install_to...

Follow the steps carefully. Afterward, if you get a message when booting DSL from a live USB that says, "Checking for for USB..."(Yes, there are 2 fors) than it hangs(the rectangular cursor stops blinking), reset the computer and check if your BIOS has a certain update for this situation. I checked with technical support of my Mo-Bo for it.

If it still hangs maybe you followed the instructions wrong or your Mo-Bo may really be incompatible. Try other Methods first before giving up.

If it didn't hang and went on to the desktop, then Yepee!, but if it didn't but you get a message "Can't find KNOPPIX filesystem ... dropping you to a (very limited shell)," reset and make sure your using Syslinux-3.36(I used 3.82 which I thought would actually work, being more updated and all, but it didn't.) Make sure you followes the exact way you're supposed to use it with command prompt.

If you don't know how, put the download syslinux-3.36.zip, http://www.kernel.org/pub/linux/utils/boot/syslinux/Old... or maybe the other compression methods used that you may prefer, http://www.kernel.org/pub/linux/utils/boot/syslinux/Old . Make a "syslinux" (no quotations) folder, put it in your desktop, and extract the files into that folder. (The folder arrangement and name are not necessary; I'm just telling you to put them like that so you have specific instructions to follow.)

Now go to "Run...," type in "cmd" (no quotations), when you see the black box, you'll see a blinking cursor, if it says "C:\Documents and Settings\(your account)>" (no quotations) then you're good to go. If not, type "cd (whatever's missing, e.g. 'cd documents and settings\joe')" (no quotations), then enter. Once you see that it's like what is above, type "cd desktop\syslinux\win32" (no quotations) then press "Enter." Now it should look like this before the cursor "C:\Documents and Settings\(your account)\Desktop\syslinux\win32>" (no quotations). Now type "syslinux.exe -ma X:( replace X: with your pendrive letter.)" (no quotations) then press enter. (Note: If Windows is installed on a different drive letter a different beginning letter would appear in command prompt as above. e.g. Windows is in drive F: so the command prompt would show "F:\Documents and Settings\..." (no quotations))

Now try booting from your pendrive now. Hope it worked. Good Luck!

P.S. If you don't know how to boot from your pendrive, on BIOS POST(Power On Self Test) press the button, F11 rapidly, to enter your boot options, if the key is different, consult your manual or something, or go to your BIOS settings, press Delete or F2 rapidly. If the key is different then you definitely need to consult something.
!