Sign in with
Sign up | Sign in
Your question

Windows 98SE no sound

Last response: in Windows 95/98/ME
Share
July 8, 2012 2:58:35 PM

Hi all, ive got a problem... I downloaded sound drivers from an official site, and my audio is still not working.. please help

Motherboard: MSI K7TM Pro (MS-6340)
(not sure, everest says it) Sound: VIA AC'97 Audio Controller

error message in Device manager: "This device either not present, not working properly, or does not have all the drivers installed. Try upgrading the device drivers for this device."

The audio is integrated.

More about : windows 98se sound

a b \ Driver
July 8, 2012 10:35:21 PM

Where sis you find an official Windows 98 driver for that VIA chipset?

Anyway, you can also check in the BIOS to see if there is an option to enable legacy sound, which will emulate a Sound Blaster 16. Windows 98 should have a built-in Sound Blaster driver that will work fine with that.
July 8, 2012 11:45:14 PM

On MSI's official Site.

I will look forward for that, I haven't seen "Legacy" in BIOS, But I will try to search for it.

Forgot to say that this PC is a Packard Bell, and It is based on Windows 98/ME
Related resources
July 11, 2012 3:05:34 PM

I've got an old Sound card and its works, but, in some games like DOOM, I can only hear the music, but the Audio FX not.. can someone help me?

Sound card: ForteMedia FM801

PCI Slot: 1
a b \ Driver
July 11, 2012 7:24:05 PM

You need to tell your DOS games which SoundBlaster settings to use. That card might be using the following settings:

IO 220 or 240
IRQ 5, 7, or 9
DMA 0, 1, or 3
!