Sign in with
Sign up | Sign in
Your question
Solved

Help needed with "Slax" Linux commands

Last response: in Linux/Free BSD
Share
October 2, 2009 6:02:22 AM

Posted below is a problem I am having with my Acer Laptop. Since I know almost nothing about Linux I thought I would post over here as the laptop thread may not be able to help me.
If someone could read what I have tried below and let me know if there is some glaring error I am missing, I would really appreciate it.




After doing a little research, it would seem that I have a NTFS problem.
So I went to this link to try and fix it.

http://www.retosphere.de/tipsandtricks/ntfserror.php?me...

I chose the Slax program.
When I ran the cfdisk in the Linux shell it told me my HDD was /dev/hda
However when I run the "ntfsfix /dev/hda" command I get a command not found error.
If I type "nftsfix/dev/hda" without the space between ntfsfix and /dev I get a no such file or directory.

I know nothing about linux or this Slax program.
Any help or tips would be appreciated.
October 2, 2009 7:21:07 AM

Link doesn't work, so I'm guessing what the problem is...

/dev/hda is the physical (IDE) drive, you need to use something like /dev/hda1 (or hda2...) to specify the partition; if the drive is SATA it would be /dev/sda...
October 2, 2009 10:05:12 PM

Sorry. I fixed the link.
Thanks for the reply.
I will try some of your suggestions later tonight.
Related resources
October 3, 2009 9:11:58 PM

OK, so far nothing has worked. Guess I don't know linux well enough or my hard drive is just toast.
But in the interest of one more try I will explain my results.

When I type in the command "cfdisk" in my Slax linux shell I get the following results:

Open disk read only- You have no permission to write.
Disk Drive /dev/hda
Size 209 MB

Name (None)
Flags (None)
Label (None)
Part Type = pri/log
Fs Type = freespace
Size MB = 205.64


Now when I try to use the "ntfsfix" command using either /dev/hda or /dev/hda1 or even /dev/hda2 nothing happens.

Any clues?



And on another note, I just noticed while I was playing with this Slax program that it comes with Firefox web browser, which is all I use this acer laptop for anyway.
Is there an easy way to get it to see the laptops built in wireless? or am I just dreaming?
a b 5 Linux
October 3, 2009 11:16:36 PM

What are your full specs?

If the laptop is good enough you should be able to run Ubuntu 9.04 or Fedora 11 on it, both offer live CDs and can be installed if you have enough disk space.

Good luck :) 
a b 5 Linux
October 3, 2009 11:26:38 PM

Ubutnu 9.04 can be installed on a 4GB SDHC card.

You can also use Linux to image your hard drive, as long as the drive can still read, and then try to get your data back from the image on a more powerful computer.

Good luck :) 
October 4, 2009 12:13:21 AM

My laptop is an Acer Aspire 4720Z

Pentium dual core 1.4GHz, 533 MHz FSB, 1MB L2 cache
252 MB mobile intel graphic accerlerator X3100
1GB DDR2 memory
160 GB HDD
DVD Drive
802.11 b/g WLAN
Vista

There is really no data to recover. I use this as an internet browsing device only.
However the infinate BSOD loop is maddening.

I am guessing the Slax program I downloaded to CD only runs off the CD?
I am willing to try anything to get the wireless working again. Even learning Linux. Ha Ha.
The Slax program seems to have a great windows like interface so anything like that would be helpful to a Linux newbie like me.
October 4, 2009 4:58:02 AM

If it's a Windows BSOD problem and there is no data stored on the Laptop, an instalation repair or re-install would be a lot quicker.
October 4, 2009 6:02:40 AM

MrLinux said:
If it's a Windows BSOD problem and there is no data stored on the Laptop, an instalation repair or re-install would be a lot quicker.


Yea. I would have tried that already if Acer gave a copy of the disk with purchase, but they do not.
Thinking about waiting for Windows 7 later this month, and give that a try. Never really liked Vista anyway.

Best solution

a b 5 Linux
October 4, 2009 12:53:01 PM
Share

Ubuntu 9.04 and Fedora 11 are free and it should take about 20 minutes to install on your hard drive :) 

http://www.fedoraproject.org/en/get-fedora-all

http://www.ubuntu.com/getubuntu/download

There's a good chance they will recognize your card, if not you can use NDISwrapper with the windows driver.

If your cpu is 64bit get the x86_64 / amd64 disk otherwise grab the i386 disk.

Good luck :) 
October 4, 2009 5:48:34 PM

Thanks for the links.

According to this link the processor is 64bit. So I guess I will give that a try.

http://ark.intel.com/Product.aspx?id=32431

Now, to go research Fedora and Ubuntu and see which is better for my situation.
October 5, 2009 2:51:16 AM

Decided to go with ubuntu.
My laptop is choking on the 64 bit version though.

Going to download the 32 bit and see if that helps.
October 5, 2009 4:17:18 AM

Nope.
The 32 bit version made it further but gets an error while trying to load Shared Libraries.
This causes the error message "The greeter application appears to be crashing"
The system then goes in an infinite loop trying to load a greeter application.
Arrrrrgh!

Anyone else have this problem or know what might cause it?
October 5, 2009 4:56:31 AM

OK. For those following along with me talking to myself....

I slowed down my CD burner after I found out the first CD did not boot up properly on any computer.
After slowing it down to 16X, I now have a working copy from CD. Yay.

I will try installing it to the laptop soon.
October 5, 2009 5:54:36 AM

Worked like a charm.
Linux, where have you been all my life?

Booted up great on 1st try.
Automatically recognized my wireless connection, sound card and video.

I am a happy camper with a working laptop again.
Thanks again for the helpful links.

On a side note, they really need to mention somewhere in the install notes that the screen will go black for about 20 min. with no hard drive or disk activity.
I really thought the whole thing had crashed, but after quite a bit of anxious waiting, it came up with the finished loading screen.
October 6, 2009 4:44:09 AM

Still more wow.

I decided to try and configure my canon printer over my wireless network today.
It took me all of 3 min.
Once I figured out that you have to click the little triangle to make drop down options appear, I was able to select the windows samba option and then browse directly to my drivers.
I was amazed as my test page worked on the first try.
I have become a huge Linux convert in just 2 days.

Can't wait to see what else I can do with it.
Currently downloading updates.
October 6, 2009 5:00:21 AM

Now for a real question.

What is the best Flash player to install?
I see that Adobe is coming out with a new 10.1 version soon. In the article I read it mentioned Linux support at some point.
Is there a better option for now?
a b 5 Linux
October 6, 2009 5:08:35 AM

arcade said:
Now for a real question.

What is the best Flash player to install?
I see that Adobe is coming out with a new 10.1 version soon. In the article I read it mentioned Linux support at some point.
Is there a better option for now?


Flash Player is evil :) 

It has been known to causing crashing and general slowing-down of your computer.

Gnash is an open-source alternative, although it is even still quite buggy (from my experience)

:) 
October 6, 2009 5:59:58 AM

Thanks for the cool links.
Looks like I can do a lot with this thing. :) 
a b 5 Linux
October 6, 2009 6:05:37 AM

Don't forget to install vlc and mplayer, they're awesome :) 
October 6, 2009 8:16:00 PM

I will look into those when I get home from work tonight.

I see that there is also a Linux version of Mame for Ubuntu.
Anyone had any luck with it?
Mame was the only games I had running on my old Vista laptop.
!