Sign-in / Sign-up
Your question

XP registry getting corrupted fast !!!

Tags:
  • Registry
  • Windows XP
Last response: in Windows XP
December 16, 2007 1:57:24 PM

Hi,
I have an ASUS CUBX-E mainboard in my PC. For the past three weeks I am facing a strange problem : The registry of windows xp is getting corrupted quite frequently. I have re-formatted and re-installed windows xp pro several times but its registry is getting corrupted frequently, and I get the following error :

1. "Windows could not start because the file c:\windows\system32\config\system is corrupt or missing."
2. "Error : \system root\system32\hal.dll missing"

I have tried repairing the windows installation and the registry using recovery console from the windows xp cd but the errors reappears. Sometimes I get the error within few minutes after windows installation completes. However, I would like to emphasize here that windows xp installs everytime without error. Also Windows XP Pro with SP2 has all the drivers for my PC, so I never have to install any other drivers. So that rules out a driver clash or mismatch.

My complete PC specs are :

1. ASUS CUBX-E motherboard with P-III 750 Mhz and 256 MB PC-133 SDRAM [PCI REV. 2.2]
[Windows xp pro with sp2.]
2. Hitachi 80 GB HDD as master on promise ATA-100 controller.
3. LG 52x CD-RW drive GCE-8527B as secondary slave on 440BX IDE
4. Sapphire ATI Radeon 7000 DDR AGP with 64 MB VRAM (IRQ 11)
5. Compex RE100ATX Lan card (IRQ 12)
6. Pctel 56k softmodem (IRQ 5)
7. Yamaha soundcard (IRQ 10)
8. Onboard Promise ATA-100 CONTROLLER (PDC-20265) (IRQ 10)
9. USB ports and hub (IRQ 5)

I have observed/tried the following :

1. The problem begins after the installation.
2. Error 1 is much more common and as per microsoft is related to corrupt registry.
3. I have also tried using different XP CD but it did not help.
4. I have low-level formatted the hdd but it did not help.
5. I have changed the IDE cables but that also did not help.
6. the hdd has no bad sectors and I have tried using both NTFS and FAT32 install. No help.
7. The error/errors may appear after the first restart or after a few days. But they DO return.
8. I have RUN memory diagnostics Memdiag (by microsoft); DocMemory and Memtest86+ (1.70)
BUT NO ERRORS.
9. TESTCPU program shows no errors in processor, and Sandra2002 benchmarks are OK.
10. HDD diagnostic DFT v4.05 and v4.06 show NO ERROR in my Hitachi HDD (80 GB).
11. chkdsk /r sometimes helps (windows is able to start) but it reports NO BAD SECTORS either.
12. when the PC is running I am able to install my programs (MS-office 2003, Acrobat reader, winrar, etc.) and I get no errors installing or running them.
13. I have scanned the PC for viruses using Norton 2008 and Mcafee 2008 (Eval. versions) with latest definitions but they found no viruses.
14. I do get BSODs i XP like : 8E,50,7F,0A,77,24, etc... but anyone who runs windows knows that they are a part of everyday computing.

But RAM tests show no errors. XP installs everytime I tried. No conflicts or driver issues ever. No bad sectors on HDD (ran all 5 stages of chkdsk with no error) Tried using NTFS and FAT32 for C: but problem remains. Hitachi DFT never reports error and drive passes low-level format and full media scan. CPU and memory benchmarks in Sandra 2002 are OK.

As a last resort I even tried using Windows Me. I was using Me till 3 yrs ago with no problems ever.
However, it also shows registry corruption but registry recovers on using "scanreg" tool.
However, if I do not run scanreg and try to boot into safe mode or normal, Me shows "new hardware found" but the hardware name is missing !!!!
I tried installing the usual drivers I have to install in Me but it rejects them all (No suitable driver found). So which "new hardware" is Me finding and trying to install????

After "scanreg" Me boots up fine and is stable. The next registry corruption may occur on the next reboot or after a few days, but it inevitably happens.
Also the errors are more common in XP than Me (since XP uses more resources I guess).

The Bootlog.txt file of Me shows the following cryptic errors :

[0010FD1F] DEVICEINIT = CONFIGMG
[0010FD1F] ASD: failing Unnamed problem, d=HTREE\RESERVED\0, rc=00000005[0010FD1F]
[0010FD1F] ASD: failing Unnamed problem, d=HTREE\ROOT\0, rc=00000005[0010FD1F]
[0010FD1F] ASD: failing Unnamed problem, d=P00000010, rc=00000005[0010FD1F]
[0010FD1F] DEVICEINITSUCCESS = CONFIGMG
[0010FD1F] DEVICEINIT = IOS

LoadStart = pnpdrvr.drv
LoadFail = pnpdrvr.drv Failure code is 0002

LoadStart = DISPLAY.drv
LoadFail = DISPLAY.drv Failure code is 0002

LoadStart = vga.drv
LoadSuccess = vga.drv
LoadStart = DISPLAY.drv
LoadSuccess = DISPLAY.drv
InitDone = DISPLAY
Init = Display Resources
InitDone = Display Resources

[0010FD54] ASD: failing Unnamed problem, d=HTREE\ROOT\0, rc=00000005[0010FD54] : Last line

--------------------------
Although pnp driver and display driver show failure yet on scanreg Me boots normally and I use a resolution of 1024x768 at 32-bit color !!! Also the drivers load normally after scanreg. No conflicts or yellow marks in device manager !!
However, I do not intend to use Me for long and would like to switch over to XP ASAP.

I have been using this configuration with XP Pro for the last three years without any problems. I am unable to locate any error in the PC RAM, hdd, add-in cards, processor, yet I am repeatedly getting this problem.
The frequent crashes and BSODs indicate a RAM problem but then why do Memdiag ; Memtest86+ and DocMemory show no error ?????

Could it be a PSU issue ??? Ambient temps in winter here is about 12 degC w/o heating. With heating it is 18-20 degC. Years ago had a PSU (on a P-I 200MMX) whose fan wouldn't budge at low temps.

I am totally baffled !!! Can anyone help on this?
Any advise/suggestion would be useful.

More about : registry corrupted fast

December 16, 2007 9:40:25 PM

I must say that is very well written.

If you think it could be a p/s prob its worth the 25 bucks after all the trouble you have gone through.
some things to ponder (no promises & maybe not the correct order)

format with a prog that scrambles the old FAT like the gov. does in case of some extra sturdy worm,

Try after formatting Replace the battery and reset bios

try to unplug hardware that isnt totally required eg. modem due to hardware incompatabilities with xp
Then install one by one


possibly the source of your xp editiions assuming the original install disk is correct try no sp2 first then if its ok this is the correct sp2 update that you can get from msoft. Its the official IT downlaod. Works with any version.
WindowsXP-KB835935-SP2-ENU.exe
goto a friends house with broadband to put on a cd as it is a big download for dial up.
good luck

December 17, 2007 2:15:25 PM

Thanks for the reply. well you seem to have quite foresight my friend, as you were spot on about the cmos battery. Today it ran out, but usually the battery problem can be anticipated (from the pc timer...). But maybe I was so caught up with all the hardware troubleshooting that it never occurred to me.
About the SP2 download : I already have it, the humongous 266MB file from big bro. I had created a slipstreamed XP cd for myself about 2 yrs back. Installing plain XP is of no help as one has to install a host of drivers and thereby creating a troublespot. XP-SP2 has all the drivers my PC needs. Besides had it been a driver issue I would have got some error sometime.
I have now re-installed XP about 6 times in three weeks and never got any file copy or driver errors.
It is most likely the RAM or the PSU.
Related resources
Can't find your answer ? Ask !
December 18, 2007 12:03:56 AM

What about cooling? Is the CPU fan running well? Have you replaced the paste? Worth checking out.
December 18, 2007 12:08:56 AM

Never mind, seems your temps are OK.
December 19, 2007 9:03:55 PM

Having come back to this I have another idea or two.

Try reseating your ram and your cards. Possibly when the system heats up they lose a little bit of contact. This would cause problems at differing unpredictable times.

256k ram ultimatly wont be enough so another 512 stick is about 30 bucks on sale. This will tell you if your current stick is bad and if not its a good investment. Just put the new one in at first and see what happens.

You didnt mention the type of your bios but go in and see if they give you voltage readings and check to see if they are fluctuating much. Else download a freeware prog. that will do it for you.

December 19, 2007 9:28:46 PM

Back in 2000 Intel came out with I820 chipset and shortly later they found out that there was a problem with the MTH causing data errors similar as what you describe. I'm wondering if the memory translator hub is having an issue. also know as the north bridge.
I had a board called the pc3 2000 that had the memory hub problem I was having errors like you.
December 23, 2007 5:14:20 PM

Hmmmm....... MTH issue. I thought that was only limited to i820 with SDRAM. My rig has i440BX (the venerable powerhouse) and when working fine it can still beat the hell out of some faster P-4s (1.7/1.8).
But i think it is the PSU as the problem comes almost always on cold-boot. Also recently the PC did not POST on powering ON. I had to switch OFF and then switch ON before it POSTed. This happened twice.
Hot-reboots rarely cause problems. (but sometimes they do.)
I have recently started booting to DOS (Me boot disk) and allow the PC to warm up and then hot reboot to windows. It works !!!!
No registry errors so far!!!!
However, I do get corrupted files especially when moving files around partitions.
So any guesses ??? Is it the MTH (that means the mobo is toast) or is it simply the PSU breathing its last......
December 23, 2007 6:39:14 PM

after seeing your extra post's and googleing a bit this may help
http://pcsupport.about.com/od/findbyerrormessage/a/miss...

I googled hal.dll missing

Im still leaning toward some sort of power problem. Ive read your post several times and I am asuming that you had xp previousy (sucessfully)
Im happy that the battery helped.
Im not sure about the CUBX mobo but I would recomend

Have you changed any hardware check master |slave settings
I see that it is on a promise controller. Is it possibly a raid controller?
Try the normal controller and or lower setting (pio2) until operational
a program|bios voltage measurments (time lapse average)
new memory
the fact that you have prob moving files to different partitions suggests new HDD
December 23, 2007 6:58:00 PM

Possiable the mft is too small, how long has it been since you have had windows set-up. Maybe get diskkeeper demo and increase your mft to about 360mb then do a fregment of the mft that can really help lots.
If you are going to set up windows again after the setup is complete use diskkeeper and increase the mft to 300 or more mb and do a fregment of the mft you will have much better disk performance
also make the cluster size of 8kb bigger to 64 this will allow your mft to be larger and keeping your mft pages bigger with lessor pages this really helps disk performance access time....only can be done if a new format is needed
December 24, 2007 11:32:55 AM

HDD is not the issue as I can delete, resize; erase drive (low-level); re-partition and re-format with NO ERRORS.
It could be the promise controller. Will check that out on next install. Actually in the past month I have done 5-6 fresh installs of XP but ended up getting the same results : Registry corruption.

All drivers install fine. No hardware changes.

Ram also could be an issue but read below:

RAM tests used : Memtest86+ 1.70; Microsoft Memdiag (2005 version); Docmemory (2006 version); and the memory checking util in PC-Check 2006.

DO NOT USE MEMTEST86 V3.4 AS IT IS BUGGY AND REPORTS ANY RAM AS BAD (EVEN BRAND NEW KINGSTON)

Four tests in all. No errors. PC-Check showed no errors in motherboard tests; CPU tests; graphics test ......

Heck only thing I cannot test is the PSU. But getting a new one is a headache as I need one with +5V line. my mobo won't boot unless the ATX supply has a +5V line.

Trouble is if I replace the ram and the issue remains OR if it not a ram issue then I lose the INR 2000.00 I will have to spend on the RAM.

Guess now you can understand why I am doing all the testing.
December 24, 2007 6:32:55 PM

if the mft is corrupted you would not have an problem with the harddrive, if a mft is corrupted you would not receive an error on a normal scandisk saying please replace the disk and try again, or format cannot continue because one or more drives has an serious error.
Master file table is like a folder, this table is created with disk partition creations, if that user chooses manual setup of partitions he/she can choose the size of the mft/cluster size, this contain pages of blank information and if the mft is too small you will get errors similar as to what your getten.
The mft is usually the cause of errors when a system has been running for a year or more. As your PF grows the MFT has to increase it size and its this increase that cause fragments and in turn file/registry corruption occurs, the %system% information,incidentally is in that directory of the MFT your registry information is stored.
This is one reason I make my mft/cluster size bigger right off the hop with any new setup, all info can be found with any search about errors cause from a mft fragmented table. fragmented mft dont mean your harddrive will report an error upon a scandisk, mft is like a folder with lots of codes in it, if you went to a folder to find something and some body mixed the tables of contents all up, you'd have a hard time finding the table your looking for and eventually give up, the PF will do exactly that if the MFT is fragmented
December 25, 2007 4:25:17 PM

Well all this talk about MFT is fine, but it comes in picture only after I install windows xp. I am testing my rig with win Me right now. XP is heavy on resources while testing.
Now I wouldn't worry about MFT. Anyway I never changed mft size ever in XP and never had any problems either. I never trusted scandisk for checking hdd. If in doubt run drive diagnostics with full surface scan, and if doubt persists do a low-level.
Well, about my registry issue I found out this :

I have noticed that if I boot using a MS-DOS floppy , allow the PC to warm up for a few minutes ; remove the floppy and boot from my HDD then windows reports no registry errors.

It seems the problem is really related to my PSU as on a cold-boot all the capacitors are discharged and the motherboard draws more power than on a hot-reboot, causing under power to the hdd/ram and thereby causing file / registry errors much more often on cold-boots.

This would also explain why windows and files get corrupt fast; and why no hardware diagnostics shows no error in RAM, HDD and the motherboard.

So the PSU is the rotten apple......

December 25, 2007 5:28:34 PM

One way to get around the cold boot is in bios setting power, poweron after shut down.
January 2, 2008 12:58:23 PM

Guys, I think this is much more serious. A new PSU did not help. I even got a new 256 MB ram stick but it turned out that its not even a RAM issue.
However, I noticed that sometimes I get a 0x0000008E error BSOD with "atapi.sys"
However, I am always able to install XP from my CD-RW drive. Never got errors.
Any clues ???????
January 7, 2008 2:22:36 PM

well there have been a few interesting developments........
1. Another new PSU and PC is much more stable.
2. It was not a RAM issue.
3. It was not a CD drive issue.
4. But i still get error on cold boot..............??????????
5. If I boot from XP ms-dos floppy and allow PC to warm-up for ~10min. and then hot reboot to windows NO ERRORS.
6. So it is a motherboard issue and manifests only on a cold-boot.....
7. But all devices are running OK and Stable in XP, so.........????

Any suggestions........???????????
April 25, 2008 1:43:59 AM

Ok, 10 steps back and lets look at some other system files. I dont want to rattle anyone, but this problem is growing and not just xp, and nothing to do with old installs.

I have the same problem, but on a winME system, only installed mid January this year, 08, has nothing to do with time, transformer good, mb good, ram good, hd seems ok, all else swapped out and and compared.

Next, Installed xp on another hd on that very machine, impossible untill I physically removed the me drive.

Also had to do a full fdisk and format all over, because something on the me drive corrupted the empty drive about 15 minutes into the install of xp, during file copy.

Next shut down, added old drive as slave. no problems, all files seem to be there. Looked it over found some suspicious entries in the system files, since the bios doesn't have the option to scan for virus, the autoexec.bat had those entries, but not in the back-ups,

@if exist c:\wininst0.400\SuWarn.bat call
c:\wininst0.400\SuWarn.bat
@if exist c:\wininst0.400\SuWarn.bat del
c:\wininst0.400\SuWarn.bat


I also found some files I don't recognize were there, and haven't looked up yet, one is suspicious.

Empty add.ini, attr.ini, ctl.ini, del.ini, path.ini, ren.ini, rep.ini, all in the root of c:.

In Windows directory is a couple files I dont know about and a folder,

_delis43.ini

16 (no extention)

.jagex_cache_32

inside is 3 folders and a file

loginapplet
rsmap
runescape
random.dat

some dat files, idx0 idx1 idx2 etc etc..

not sure what they are from...

Next I pulled the new xp drive out, put a real old 98 upgraded to me drive in as master and the failed me as slave, and again easy read, all is fine, compared the root of c: and windows found 3 missing files, copied them.

tried to boot from that drive alone, no go still hangs right after destop background, no icons mouse moves, task manager is empty, and yes explorer is on the hard drive and clean but not loading... I hex open the asd.exe and looked it over, all seems fine, there too.

Still it won't allow recover install or regular install of any os on that drive.

It is pined for cable select by the way.

My suspicions lay on them trash bastards who drop programs on you against your will and or knowledge, or by scaring the ones who don't know, such as antispywaremaster etc.

My daughter and grandkids use myspace, which sucks, all the spyware adware and punks attacking and perverts stalking, its a wonder the pc lasted 2 and half months.


Hiren's boot cd is the point im at to snoop through and see what else I might find.

I hope this is enough info to help all of us help each other, this particular problem seems to be happening to more people in the last few months.

I do need something that can open and read the registry files from some other system, mini98 has its own registry and I might be able to trick it but I only need a couple entries from it so I would rather find a small app to to open those dat files in a registry type of window....
April 25, 2008 4:14:34 PM

You might try looking for bulged / leaking capacitors on the motherboard... especially if your hardware is old. (I'm assuming it is if your trying to install the crapware known as ME). It wouldn't hurt to check inside the power supply as well... I know at least 2 power supplies I've looked at had the capacitor issue.

If you're trying to install ME (or 98) on new hardware... don't. Please don't. You'll be lucky to find drivers for anything, as manufacturers don't support 95, 98 or ME anymore with new hardware.