Sign in with
Sign up | Sign in
Your question

Grub 2 overwrote my grub legacy

Last response: in Linux/Free BSD
Share
March 3, 2010 2:03:04 PM

Did a full load of Ubuntu 9.10 to a 16GB flash drive from a live CD, but when I tried to boot onto the flash drive, got a "Grub Loading Error: no such disk grub rescue>

I am running Windows XP dual booting with Hardy Heron. Apparently the Legacy Grub got
overwritten with Grub 2.

How do I fix this one?
March 12, 2010 2:32:14 PM

I had a similar issue. I was rebuilding my computer recently, and decided to try out artistX on an old flaky HDD before going and installing what I wanted on my main HDD. With my main HDD set as my primary HDD in BIOS I booted into the live DVD and went through the install process, using the entire secondary HDD. I then reset BIOS to boot from my secondary HDD and received a not bootable error messages. Only once I set BIOS to boot from what had been set as my primary HDD during the install process did my computer boot. I deduce from this that the ubuntu installer automatically uses the MBR of your BIOS selected primary HDD rather than the MBR of the one that you actually install on, if they are different.

This didn't bother me too much, because I was going to reinstall stuff anyway. I restored an image of windows XP to my new main HDD (note on this; in case anyone was wondering clonezila will restore a disk image to a larger HDD than the image was made from, but any space over the size of the original disk will be left unformatted). Then I installed linux mint to the same HDD. When I booted to GRUB I was given the expected mint and xp options, but artistX also showed up! I haven't tried it to see if it works, but if wgschultz is still following this and is curious, I will try.

Based on my experience then, it seems normal that GRUB overwrote itself. But I'm not quite clear; there are now no options to boot your former systems, right?
m
0
l
!