Sign in with
Sign up | Sign in
Your question
Solved

How to Disable USB Suspend?

Last response: in Linux/Free BSD
Share
April 3, 2010 8:01:13 PM

Did not get much help from the ubuntu forums so I'm hoping someone in Tom's can help me out:

OS: Ubuntu Server Edition (no gui)

My media server is running Ubuntu Server and has a 1TB drive connected by USB. My problem is that Ubuntu will suspend/spin down the drive causing delays when accessing files in the future. Also, the drive is accessed frequently so it's continually spinning down then up all day long. I believe my problem is the USB auto suspend feature (which is a power mgmt feature I believe) which is what I want to disable. Is there any way to do this?

Thanks.

-matt

More about : disable usb suspend

April 4, 2010 3:49:28 AM

USB's far from ideal for hard drives and high speed storage devices. You'll be much better off with sata, esata, or even firewire compared to USB 2.0.

What's the reason you're using usb?

USB's capable of 20-35 MiB/sec ( ver 2.0 ) and it's got latency problems. SATA's capable of 110-155MiB/sec and it could be way more than that.

USB 3.0's been improved but it's still got latency and performance problems, it'll vary based on the chipsets used and how those chipsets are connected to the bus.

Have you looked at System -- Prefs -- Power Management and checked your bios?

Good luck :) 
April 4, 2010 9:32:17 AM

The media server came out of old hardware that friends were getting rid of. I just re-purposed it to hold my media. Not the ideal media server I agree.

I have not checked the BIOS so I will do that next. I do not have the gui installed so how would I change Power Management from the command line?
Related resources
April 5, 2010 9:30:54 AM

Also have a look at reducing the load on the external drive. It might be worth looking at the mount and looking at options like 'noatime' to reduce writes. Most of the options you would use for flash drives would work in this regard.
Anonymous
May 25, 2010 3:19:43 AM

I am also looking DISABLE USB AUTO-SUSPEND. My issue relates to TV tunners shutting down in Ubuntu Lucid runnin Myth Backend. I have tried to create a file: /etc/modprobe.d/options.conf which contains the line: options usbcore autosuspend=0 but when I look at /sys/module/usbcore/parameters , the autosuspend component remains == 2... (after reboot). Any help will be appreciated.

Best solution

May 25, 2010 2:00:54 PM
Share

can't solve your problems, but be aware that some 'green' drives park the read heads if it there was no need for the drive in 8 seconds. This combined with a standard flush time of 10 seconds for most linux distros means that the drives will repeatedly park and wake up. So don't use drives like wd10eads or other green drives with this. I believe this goes for the usb versions as well (not sure) - maybe your usb parking problem isn't actually usb, but the drive attached to the usb.
June 1, 2010 2:08:22 AM

Best answer selected by matt11601.
!