Sign in with
Sign up | Sign in
Your question

Ubuntu install does not see my xp installation

Last response: in Linux/Free BSD
Share
Anonymous
April 7, 2010 2:24:28 PM

When installing Ubuntu next to XP it does not recognise that I have XP already installed at the partitioning section.

Any ideas anyone?
Anonymous
April 7, 2010 2:49:12 PM

Thanks for the reply Skittle.

I read the article you sent me, most of which was waaaaay over my head, but got some of it.

I have installed Ubuntu onto a laptop running XP and it picked up the XP install and gave me the option to install alongisde or over, which it DIDN'T give me when trying to install it on my PC running XP.

If this comes down to manually partitioning my PC then I'll probably just not bother installing Ubuntu as I'd be too afraid I'm going to wipe everything on it. I just can't understand why it's not picking up my XP install like it did with the laptop.

Is there anything relatively simple I can try?

Related resources
April 7, 2010 3:05:13 PM

Are you using multiple hard drives on your desktop? Perhaps it doesn't detect it across multiple drives. In any case, if you provide us with your specs and your current partition structure we can assist you in partitioning manually without harming your data. Existing partitions can be resized to fit in new ones (which is what the "install alongside" option would do anyway).
Anonymous
April 7, 2010 3:32:12 PM

Thanks Randomize.

Which specs do you want. I wouldn't even know if my c: is partitioned into c: and D; or whether I have 2 seperate drives!
April 7, 2010 5:31:12 PM

Hi, please post the output of "sudo fdisk -l" (L is lowercase) on paste.debian.net or similar pastebin.com
(run from the ubuntu live cd)
April 7, 2010 7:28:41 PM

Quote:
Thanks Randomize.

Which specs do you want. I wouldn't even know if my c: is partitioned into c: and D; or whether I have 2 seperate drives!




Linux doesn't have drive letters :) 

Your devices mount on top of directories under "/", which is the root directory. /media/cdrom or /media/disk-1 or /media/usb for example.

If you run the command skittle suggested you'll see a list of your drive or drives and how they're partitioned, this info is needed to configure grub properly.

Semper Fi :) 
April 8, 2010 1:30:47 AM

Hey Linux, and Randomizer,

I also have the same problem, just went to install Ubuntu 10.04 on a custom HTCP case I am working on and wrapping with granite and when I go to install on my 750gb seagate 7200.12 drive with Windows 7 installed on a 340gb partition it does not see Windows 7 and claims it is a clean disc with no OS on it. I have never seen Ubuntu do something like this and I even went back and tried to install 9.10 and 9.04 and it does the same thing.... any Ideas?
April 8, 2010 1:48:59 AM

Whether it "sees" Win 7 or not isn't really a problem, as long as it knows there is data there. If it doesn't recognise the NTFS partitions then you have a problem, and should probably file a bug report.
April 8, 2010 2:02:33 AM

Here is what my HTCP rig says when I run the command line that skittle suggested:

Warning: GPT (GUID Partition Table) detected on '/dev/sda'! The util fdisk doesn't support GPT. Use GNU parted.


Disk /dev/sda: 750.2 GB, 750156374016 bytes
255 heads, 63 sectors/track, 91201 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
Disk identifier: 0x68ed724f

Device Boot Start End Blocks Id System
/dev/sda1 * 1 13 102,400 7 HPFS/NTFS
Partition 1 does not end on cylinder boundary.
/dev/sda2 13 45601 366184448 7 HPFS/NTFS


Note to Thread poster,

To find this info load the live CD and when in the desktop, go to the top of the left side of your screen and look for Applications and click it and then go to Accessories and then find terminal and open it and type what Skittle told you to put in and hit enter
April 8, 2010 2:08:16 AM

Thanks for the fast response Random,

I really appreciate it. I am working on this build because I am taking this rig down to my property and need a computer with Ubuntu on it so I can use my cell phone as a modem to get online with. Windows 7 won't let me use my LG vue to do that, but Ubuntu does. So when I go to install it it shows nothing in the partition section at all just says disc is empty??? I have never seen this before when installing Ubuntu... It shows when I type in the terminal command but only shows a blank hard drive when I go to install even when I try manual partition mode. So how do I make sure I don't wipe my Windows 7 install that I activated just last night? Just my luck hey, I just had to activate it LOL>
April 8, 2010 2:20:58 AM

BTW when I set up windows I set up two partitions,

1 with 367 GB for Windows 7, and 1 at 360 GB empty so I could put Ubuntu on. Of course Windows did it own thing for the boot files and made another very small partition.

I don't know about you guys, but I have Ubuntu 10.04 LTS on my Quadcore rig and I am loving it! They have really got a few thing right with this version. Seems like very little messing with things to get it all to work. Cairo dock is much better to work with and has themes you can install right from a menu. I am really liking it. Anyone else running 10.04 yet??
April 8, 2010 2:33:13 AM

I have 10.04 installed as a VM as well as on partitions near the end of my drive, but it hasn't been used much. I'm waiting for beta 2 which is coming out in the next 24 hours.

I'll let someone with more knowledge take it from here, as I'm not much good with with partitioning where the existing partitions haven't been detected.
April 8, 2010 2:36:52 AM

Ok thanks Random,

I am trying to install now and it is saying the same thing, this computer has no operating system on it! So no sure what went wrong here, never seen ubuntu not pick up on a windows install.


I will be looking for the beta 2 and check it out thanks again.
April 8, 2010 2:37:50 AM

also I tried to install inside of windows 7 but it came up with a error about no root drive?
April 8, 2010 3:02:50 AM

I read about GParted while Googling about this as well (most "solutions" included it), but as I've never used it I wasn't going to try to give advice on it ;) 

EDIT: Mind you, I have not had issues partitioning with Win 7 as the OS that created the NTFS partitions first.
April 8, 2010 3:09:03 AM

Yeah I figured as much, I have also heard about it but It does require you to wipe your drive so, kinda not what I want but maybe the only way at this point. Thanks again random.

Edit: Yeah me either until now, just my luck.
April 8, 2010 4:52:53 PM

you can also use (g)parted to shrink an ntfs partition, and change its boot properties.

btw gparted is just a front end to gnu/parted

also are you able to mount the ntfs parrtion in the livecd?
April 8, 2010 6:29:44 PM

parted has GPT support, fdisk doesn't.

That could be part of the problem.

Does 7 default to GPT?

Semper Fi :) 
April 8, 2010 7:17:42 PM

No, 7 still uses MBR unless its on EFI
April 21, 2010 11:55:24 AM

Skittle,

Yes I am able to mount it and it sees the file from Windows 7 install, but when I go to install it it doesn't work. Installing from within W7 doesn't work either, it installs, goes to reboot, and then when I dual boot Ubuntu from Windows boot manager it starts to complete the install and hangs with a error, no partition root file found, go back to the partitioner to fix...
Anonymous
May 8, 2010 8:55:29 PM

Have the same problem. No way to install ubuntu: either doesn't see any partitions or hangs with an error about no root filesystem or wants to wipe all my data.
I have been using ubuntu for years and I have never ever seen sth like this.
What's happening?

And could you please stop posting this https://help.ubuntu.com/community/WindowsDualBoot, because it is nowhere near helpful for this problem.
May 9, 2010 4:50:39 PM

Hey lockesilver,

I have had the same problems and none of the links or research has helped. The only thing I can think of is that it is a hard drive problem with my Seagate 7200.11 and 7200.12 drives. Not sure but it is the only one of my computers with this drive I have experienced this problem with. All 4 of my other computers and two laptops I have installed on all work, including installing it from Wibi within windows.

Let me know if you figure this out, or if you have Seagate hard drive also. Thanks.

Also the motherboard I am using is a Bio star 939 socket board with a Nvida chipset.
June 9, 2010 9:46:25 PM

I have been having the same problem. I have a seagate 7200.12 drive. Installed ubuntu over win 7 with all ur symptoms. I think that the driver has been erased for the hard drive thus making windows not recognize the hdd. I am assuming that the driver or firmware has to be re-installed or re-configured; however, have no idea how to do it as i have been working with .exes my whole life, something alien to ubuntu.
June 10, 2010 8:01:40 AM

well i dont know if anyone is still active on this topic. I have searched all day and found something interesting. I think you have to "slipstream" a windows 7 install. From what i read "slipstreaming" is when one install drivers along with the windows 7 install. If somebody is interested they should Bing "slipstream windows 7 install." heres a little tutorial http://www.youtube.com/watch?v=lwyMuo4pkvM. I would try all this myself but my bandwidth is not that high, the files required are pretty big, so i cant post any results in a timely manner. good luck and hope some one solves this!

ps. anyone else think ubuntu 10.04 is running buggy? i tinkered with 8.10 before and it was much smoother
June 19, 2010 8:08:29 PM

Hey Pink, I just gave up on installing Ubuntu on my Intel Q9550 build with the Seagate hard drive. I think I like Ubuntu 10.04 so far. Not really seeing anything wrong with it. Thanks for the link.
June 19, 2010 9:58:32 PM

well i found the solution, it took 5 days. Im happily back on to win 7. Do plan to go back to ubuntu but not anytime in the near future.
October 28, 2010 6:53:22 PM

SUCCESS ! I trawled the forums for solutions and eventually got one that worked.
It was suggested that the glitch was particularly apparent from version 9.10 onwards.
So the answer is to download and install version 9.04 then simply upgrade to the latest version you require. Has to be done step by step so is a little time consuming but worked for me.

Good luck
October 29, 2010 12:12:00 AM

well I have since moved on, it only happened to me on a seagate drive so... thanks for the info... glad you figured it out
September 14, 2011 5:40:43 AM

I know this is old topic but this may help when one comes searching for answer.

There is a bit difference between Alternate and other cd's of Ubuntu installers. Alternate cd/dvd have better partitioner.

I had same issue. I discovered that it is RAID HDD issue. I went back to BIOS setting . Changed
IDE mode to RAID and Ubuntu got installed with Windows. All working.

But Windows wasn't loading then. BSOD.
Then I have to switch back to IDE mode. Now all working fine.

Also you can try other things like Pre-partitioning and using chdsk /f on windows.

Mrinal
September 14, 2011 11:23:14 AM

Thanks for the info..... :) 
February 2, 2012 4:35:03 AM

SOLUTION AT BOTTOM! >>>

Hello all, sorry to revive an old topic but I just figured this headache out and want to spread the word - I figure that if I found this thread while trying to fix my problem, others might, as well.

Thanks to http://askubuntu.com/questions/61939/ubuntu-installation-does-not-recognize-drive-partinioning I was able to find http://www.rodsbooks.com/fixparts/.

I installed Windows 7 a while ago, knowing I would be dual-booting with Kubuntu. I set up my partitions in the Windows 7 installer (including swap space and everything!), but when I went to install Kubuntu, it wouldn't recognize my Windows 7 install (and other partitions), it only gave the option to erase the whole disk.

The problem is that Windows 7's installer formats the disk in a way that Linux installers have trouble recognizing, even though the OS itself reads the partition and their data with no trouble.

Fixparts fixed the problem - didn't have to change anything, just install it from the .deb or .rpm or source, run it as root, and make sure to press w and enter to write the [automatic] changes to disk. I didn't have to give it any input at all, it simply worked automatically for me, hopefully will do the same for the rest of you.

SOLUTION
Install and run fixparts, make sure to (w)rite the automatic changes to disk.
February 2, 2012 10:21:28 AM

You may have to select the advanced option to manually partition. You can still make one big partition for linux, but it will give you the chance to mount the Windows partition as /windows or whatever as well if you want to do something with wine at some point.

Did you do the initial partitioning with the Ubuntu install disk?
March 1, 2012 12:51:28 AM

Wow, this is much appreciated. I spent days trying to even find any literature at all on this problem. Still a bit in the dark, but I'm about to give it a go. Thanks.
April 18, 2012 12:04:07 PM

I am also having this problem, running ubunto 11.10 from USB currently, trying to install to disk for multi-boot.
Ubuntu detects the disk and partition ok as I can view it in the filemanager and disk tool as /dev/sda

however it says there is no OS installed, but I have windows 7 installed.
It is a default windows 7 install with 2 partitions, the recovery partition that windows creates and the primary partition.

So I have 2 options when installing Ubuntu now, "use entire disk or other".
when I choose use entire disk it does not show sda in the list so I cannot even repartition.
if I choose other, then it chooses sda as the boot device, but does not list it in the partitions to choose from for installation.

please be aware I have ZERO linux experience, I am a windows guy, so any advice needs to consider that.
!