Sign in with
Sign up | Sign in
Your question

Cannot boot, tried everything, end of my rope!

Tags:
Last response: in Linux/Free BSD
Share
May 6, 2010 3:04:46 PM

Background: I have an HP 2140 netbook, I have Windows XP Pro and Ubuntu 9.04 Jaunty installed on it. Everything work(ed) fine until I went to replace grub with GFXBoot.

The Problem: After I removed grub and tried to install GFXBoot, with no apparent errors or any problems, I rebooted the system.
No grub.
Nothing.
A black screen with a blinking cursor appears for a few seconds and then the netbook tries to boot from the NIC and can't.
Ok, the obvious answer is I have messed up grub.
So I boot into a live usb, reinstall grub and configure it like every site I visited told me to.
Reboot.
No change.
Ok, it could be the MBR, so I grab a copy of Super Grub Disk, boot into it, and try to repair the MBR there, it says it's successful so I reboot.
No change.
I'm fed up by this point so I just use SGD to boot into Ubuntu, which works great, the only problems are
1. I don't want to have to use SGD to boot every time.
2. I would like grub to function.
3. I cannot boot into my windows install even with SGD.

To add more annoyance, my NTFS partition is "dirty" and needs to be chkdsk'd, which I can't do, because I can't get into Windows and my netbook lacks a CD drive to use the Windows disk to repair with.
This means ubuntu won't even mount that partition, which means I have no access to my files.

I am at the end of my rope here, I have tried everything.
I have repaired the MBR multiple times, uninstalled and reinstalled grub and grub2, tried SGD, everything.

I could really use some new help.
Thanks.


Extra Info:
Specs : Atom CPU
2GB ram
160GB hdd

(Output of fdisk -l )

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x33686b96

Device Boot Start End Blocks Id System
/dev/sda1 * 1 15541 124833051 7 HPFS/NTFS
/dev/sda2 15542 19457 31455270 5 Extended
/dev/sda5 15542 15906 2931831 82 Linux swap / Solaris
/dev/sda6 * 15907 19457 28523376 83 Linux

More about : boot end rope

May 6, 2010 5:53:13 PM

Have you already tried /sbin/grub-install /dev/sda?

If you haven't, boot from an ubuntu disk, open a terminal sudo su - and try it.

How did you install GFXBoot?

Good luck :) 
m
0
l
May 7, 2010 1:50:26 PM

Just tried that.

Here's the output.

Quote:
root@bork-laptop:/home/bork# /sbin/grub-install /dev/sda
You shouldn't call /sbin/grub-install. Please call /usr/sbin/grub-install instead!

Searching for GRUB installation directory ... found: /boot/grub
Installing GRUB to /dev/sda as (hd0)...
Installation finished. No error reported.
This is the contents of the device map /boot/grub/device.map.
Check if this is correct or not. If any of the lines is incorrect,
fix it and re-run the script `grub-install'.

(hd0) /dev/sda
(hd1) /dev/sdb


No change, same result.

I installed GFXBoot through apt-get.
m
0
l
Related resources
May 7, 2010 7:16:13 PM

what happens if you run 'sudo update-grub' ?
m
0
l
May 10, 2010 4:31:43 AM

Tried it, no change..

Quote:

bork@bork-laptop:~$ sudo update-grub
[sudo] password for bork:
Searching for GRUB installation directory ... found: /boot/grub
Searching for default file ... found: /boot/grub/default
Testing for an existing GRUB menu.lst file ... found: /boot/grub/menu.lst
Searching for splash image ... none found, skipping ...
Found kernel: /boot/vmlinuz-2.6.28-18-generic
Found kernel: /boot/vmlinuz-2.6.28-11-generic
Found GRUB 2: /boot/grub/core.img
Found kernel: /boot/memtest86+.bin
Updating /boot/grub/menu.lst ... done
m
0
l
May 10, 2010 8:29:55 AM

Have you checked which partition is the active one. If you installed grub in the Ubuntu boot partition, rather than in the MBR, then that must be the active partition.

You might also want to have a look at this thread.
m
0
l
!