Sign in with
Sign up | Sign in
Your question

Secondary IDE problem... can't find answer anywhere

Last response: in Windows XP
Share
February 4, 2008 3:16:23 PM

Hi everyone, let me first say that I have looked in countless forums for this, but I have ben unable to find the answer. I thank you in advance for any help you can offer. I will list my problem first, and then list what I have tried to rectify the problem, all to no avail :-(

Here goes...

I was syncing my iPod, when I hit a glitch, and my system crashed, making it unable to reboot. After being able to rescue a few files, I found that I would have to reformat & reinstall Windows XP. For the most part, things went well, but I have had a few issues with the system now. A minor one that I can deal with is that my system will no longer shut down automatically. The power button doesn't work anymore, so I have to flip the switch on the back of the computer. I have tried both enabling and disabling ACPI in the BIOS, but it doesn't work either way. A pain, but not a big deal.

My main issue that is driving me nuts is that Windows XP will not recognize my secondary IDE devices. They are recognized perfectly in the BIOS, so I know that they are not faulty. They were originally set to master & slave, but now they are set to cable select. They will not recognize in either My Computer or Device Manager. The secondary channel is listed in Device Manager, and is listed as working properly, but no devices are listed under it. I would really like to get everything up and running, because everything was recognized before my system crashed.

Listed below are the things I have tried to fix it, but none of it has worked...

- Uninstalled and reinstalled IDE drivers
- Updated SIS drivers
- Unplugged all USB devices
- Uninstalled and reinstalled from safe mode
- Reset the CMOS and let items redetect
- Unplugged and replugged the CD-Rom and 20 gig HD on the secondary IDE channel
- Disabled and re-enabled DMA modes
- Eaten 2 pieces of pizza

Anyway, none of this has worked, and I don't want to have to reinstall everything in hopes that XP will recognize everyhting from a fresh install. If anyone can help me here, I would be extremely grateful. Thanks again in advance!!

Windows XP
Athlon XP +2400
GeForce 440 MX AGP
SoundBlaster 128 PCI
I/O Magic Video Capture PCI
K7S5A rev. 3.1 mobo
512 MB DDR
February 4, 2008 3:42:46 PM

Questions for you.

Have you made sure the devices work perfectly in Primary IDE mode?
If so, ...

Sounds like a possible surge (ruined your power button) so maybe the IDE controller is fried?

I would use a program like PCCheck (eurosoft) to determine that, but it isnt free.
February 5, 2008 6:09:46 PM

CompTIA, thanks for the tip... could the IDE drives post in the BIOS but not Windows if the IDE drive was fried? I found a program to check the component integrity - I will try that tonight.
Related resources
February 5, 2008 6:36:11 PM

If the components work on IDE1/Primary, that would be the first test.
--> If yes,
Yes, a malfunctioning device can show up in BIOS but nowhere in Windows. I will see if I can get you more details on this.


--> If no,
there is a problem with the components and possible more.
February 6, 2008 3:55:42 PM

Well, CompTIA, thanks for the tips buddy. I actually decided to just back up my stuff since it had only been a few weeks since my clean start. I pulled everything that wasn't necessary, reinstalled, and everything is working fine, even the power button. I guess it linked back to mixed up IRQs or something. Thanks for the help! I appreciated it. :) 
February 6, 2008 4:31:49 PM

Rebuilding fixes power button? Alright :) 

Well glad to hear it.
!