Sign in with
Sign up | Sign in
Your question
Solved

Temperature Monitoring in Ubuntu 10.04

Last response: in Linux/Free BSD
Share
May 21, 2010 10:23:12 AM

I am new to linux, I tried Ubuntu 9.10, but couldn't get xcomp to work with the ATI GFX card and dual displays. I gave up until lucid lynx was released. Installed easy peasy.

I am dual booting Ubuntu 10.04 amd64 and W7 64. I searched for a temp monitor, with no luck. no im-sensors in the repository, sensors-applet did not work either.

I am spending more and more time in Ubuntu and I just feel naked without access to my cpu/gpu temps.

A little help please.

specs

AMD 955 BE @ 4 Ghz
Gigabyte GA-MA785G-UD3H
XFX ATI HD5770
May 21, 2010 2:16:14 PM

You'll have to apt-get install lm_sensors or apt-get install lm-sensors ( LM_SENSORS or LM-SENSORS all lower ) and run the detection script. Some boards have really cheapo or proprietary sensor chips on them that aren't supported.

http://ubuntuforums.org/showthread.php?t=879710

http://www.lm-sensors.org/wiki/iwizard/NoSensorsDetecte...

Don't run random code that you find on the internet without checking that it's safe and secure, there's a lot of idiots on the net. Always use the official repos if you can, if you download something by hand, check the sums and sigs if they're available and scan for viruses.

Debian and ubuntu and other distros sometimes modify the packages so they'll differ from the official source code.

If your board's got a decent sensor chip, it should be detected and it'll probably work, gpu sensors on the other hand can be really tricky.

Some chips are so bad, miscalibrated or proprietary that they'll report temps that are off by dozens of degrees so it's a good idea to check your sensor calibration with a known good external sensor like a DMM with temp functions.

http://www.amazon.com/Mastech-Multimeter-Temperature-Me...

If your temps are confirmed by a DMM you'll know if you can trust what your sensors are showing or not. With a little extra effort you'll be able to figure out how much they're off by so you can do some simple math and figure out what the real temps are.

DMM courtesy of google shopping and amazon.

Good luck :) 
May 21, 2010 4:32:38 PM

Thank you for the reply linux_0. I installed lm-sensors. I ran the sensors- detect and accepted all the default=yes. Here is where I am at.

Driver `it87':
* ISA bus, address 0x228
Chip `ITE IT8718F Super IO Sensors' (confidence: 9)

To load everything that is needed, add this to /etc/modules:
#----cut here----
# Chip drivers
it87
#----cut here----
If you have some drivers built into your kernel, the list above will
contain too many modules. Skip the appropriate ones!

Do you want to add these lines automatically to /etc/modules? (yes/NO)yes
Successful!

Monitoring programs won't work until the needed modules are
loaded. You may want to run '/etc/init.d/module-init-tools start'
to load them.

Unloading i2c-dev... OK

henry@ubuntu:~$ sudo /etc/init.d/module-init-tools start
Rather than invoking init scripts through /etc/init.d, use the service(8)
utility, e.g. service module-init-tools start

Since the script you are attempting to invoke has been converted to an
Upstart job, you may also use the start(8) utility, e.g. start module-init-tools
module-init-tools stop/waiting
henry@ubuntu:~$

I need to find out what "service module-init-tools start" is, so I'm off for some research. If you do see something in the terminal echo, that I have done wrong or screwed up please reply. Thanks again
Related resources

Best solution

May 21, 2010 8:15:08 PM
Share

That's implying you should run sudo service module-init-tools start or sudo start module-init-tools.

Don't try to understand what that is, they just switched to upstart and changed ( clobbered?!?! ) the way init works.

sudo modprobe it87 should load the kernel mod if it's installed, then you'll be able to run sensors.

Good luck :) 
May 22, 2010 3:44:48 AM

linux_0, I was hoping you would reply. I searched and read quite a few search results on module-init-tools, and I still don't understand it, or the command to run it. So thanks so much. I did check synaptics and I have it installed, but was "404" on how to access it.

I have an applet in a panel that is showing HHD, and GPU, but no CPU temp. I will give it a shot and let you know how I do.

I am not really concerned about my CPU temp, I am running a Cooler Master Hyper 212 plus HSF with 2 Antec tricool 120mm fans on medium for push/pull. My idle temp is 35c and load with OCCT linpack 57c, in Windows 7.

Thanks again for the help. I feel like such a noob with linux. I am fighting the urge to use gksudo nautilus and sudo chmod +w. I really need to get comfortable with command line operation.

EDIT:
I ran sudo modprobe it87, and sensors, and just like magic I have voltage, fan speeds and temps. Thanks again for all your help
May 22, 2010 3:55:23 AM

Best answer selected by henrystrawn.
May 4, 2011 4:27:26 AM

I have this same issue. But when I type sudo service module-init-tools start I get module-init-tools stop/waiting and nothing happens. I am trying to read the via686a sensor but I am not even sure the module is installed. In know its an old thread but it follows my issue precisely. Hopefully someone can help I need to see my temps and my fan is spinning out of control.
!