Sign in with
Sign up | Sign in
Your question
Closed

Vista SP1 sucks

Last response: in Windows Vista
Share
March 23, 2008 8:38:26 PM

Just installed Vista SP1 and it reset all the activation codes on my Microsoft products, now I have to wait on the phone to get Vista, Office and Halo 2 reactivated in order to use them... Very frustrating....

More about : vista sp1 sucks

March 25, 2008 11:13:31 PM

It does not happen to everyone?
March 25, 2008 11:50:13 PM

Microsoft added some fixes in SP1 to stop people from using a bios hack to activate vista oem, but it seems to screw up some legit copies to.... So far it seems to only happen to a few, but its still irritating none the less...

After using vista for 6 months I'm going to reload up Xp Pro, Vista is a resource hog and it still has glitches even after SP1... From what I heard Microsoft is trying to rush out the next operating system to replace Vista because Vista been more or less a failure... 2nd to Windows ME as the worse operating system Microsoft has put out...
Related resources
March 26, 2008 1:08:19 AM

What type of glitches are/were you experiencing?

Win7 is not being rushed out. It's returning to Microsoft's SOP. The time between XP and Vista is an anomaly compared to the the other MS releases. In addition, one of the reasons that there is that XP was such a mess before SP2 that MS pulled the development team off of XP's successor to focus fully on SP2.
March 26, 2008 6:23:06 PM

after install SP1 my computer starts to use more ram than before vista SP1 it realy sucks.
March 26, 2008 11:31:46 PM

SP1 makes my startup take double the time.
March 27, 2008 6:12:01 PM

you guys must be unlucky. I installed SP1 and haven't had any problems with it. So far for me it's been a push...nothing better, nothing worse.
March 27, 2008 6:17:35 PM

tokyotech said:
SP1 makes my startup take double the time.




Pentium 4 @ 3.2 GHz, 4 x 256 MB RAM, ATI Radeon X300


:pfff: 
March 27, 2008 8:01:01 PM

Mine start up is about.....Hmmm probably 30 sec + bios + raid controller.
March 29, 2008 2:28:21 AM

ericmtnbkr said:
you guys must be unlucky. I installed SP1 and haven't had any problems with it. So far for me it's been a push...nothing better, nothing worse.


Same here...
March 29, 2008 7:44:10 PM

My experience with SP1 is better. I had Vista 32 installed but have wanted to migrate to Vista 64. After SP1 was released I installed V64 and SP1. I upgraded my PC to 8gb of memory and disabled page file.
The only issue I have had is a somewhat quirky SB X-Fi driver that sometimes locks up. Vista 64 is definately faster with a 8gb setup than Vista 32 with 4gb. i don't get into all the benchmark stuff but it just "feels" faster. Doing away with the diskcaching probaly has a major factor with this. I do know that Crysis is mcuh faster and palyable under V64 than V32. Sorry for you guys having issues.
!