Sign in with
Sign up | Sign in
Your question

kaspersky Anti Virus 2009 - BSOD

Last response: in Apps General Discussion
Share
November 30, 2008 1:41:25 AM

Hello All.

I got a problem after installing the kaspersky anit virus 2009. I use a windows XP system. After installtion, i restarted my computer and it went directly to the BSOD scree showing the following stop message:0x0000000A 0x0000004C 0x00000002 0x00000001 0x806E484A.

I am able to login to windows only through safe mode. The system is not even allowing me to login through safe mode with networking. If i tried to uninstall it through control panel, the following message 'windows installer service' could not be accessed is shown.

Following are methods i tried to solve by reading a differnet thread reg BSOD kaspersky. this is following thread i refered but did not find any solution http://www.tomshardware.com/forum/237966-45-bsod-proble...
I tried to ..
1. Run MSCONFIG - remove all the start up files related to kaspersky. - 'this did not help'
2. As you mentioned, I was also not able to find any uninst.exe file in the kaspersky 2009 folder. - couldnt identify the unins.exe file
3. i tried to remove, repair method but it shows the same error message as from contol panel
4. I went through registry to remove - start|run\regedit. I removed the karpersky folder from HKEY_Local_Machine and HKEY_Current _User. Still nothing worked even after I restarted the system.

Please let me know on the soultion to resolve this BSOD error by uninstalling the kaspersky antivirus 2009. Give a decent detailed description.

THank you.
December 21, 2008 11:23:39 PM

I have a similar problem. My stop error was different, though. It ended with F79FE003. There was also the message DRIVER_IRQL_NOT_LESS_OR_EQUAL, which I am researching. I also determined that when I started in safe mode with networking, the boot was hanging at TDI.sys (or maybe the file just after it). So I've thought about replacing that file.

You could research the last 8 digits of your error message with google.
I searched it and there were some results. None for my error, though.

THere is a kaspersky removal tool at this location: http://support.kaspersky.com/faq/?qid=208279463

I just haven't tried it yet. Please let me know if you try it with success.

Thanks,
Kurt
December 23, 2008 2:51:44 AM

I used the Kaspersky removal tool and it did not help. I was able to get internet access only by using BartPE's boot disk and my network drivers.

Hopefully the Kaspersky GetSystemInfo tool has helped you. It only told me I had some leftovers from Norton on my machine, and that I needed to upgrade my network card. I did those, and it didn't help.

My stop error begins with 0x0000000D1, I didn't even notice that. Researching this stop error might help, if the removal tool fails to help you.

Related resources
Can't find your answer ? Ask !
December 23, 2008 9:23:16 PM

Perhaps the original poster got this fixed, but I'm posting in case others have this problem. My research shows a lot of people having problems with Kaspersky installs, at least 6 or so reporting this same problem.

What has worked for me is advice I found elsewhere on the net: go into your device manager and disable all of your network adapters, and see if you can boot without going into safe mode. This worked for me. Then I started uninstalling network adapters, starting with WAN Miniport (PPTP), with the intention of reinstalling them.

I was able to remove all of them, except WAN Miniport (IP), which said it could not be uninstalled, because it might be needed to boot the machine. When Kaspersky was installed, this adapter had a Kapersky "add-on" beside it, something like "WAN Miniport (IP) - Kaspersky Anti-Virus <something >". Something about the add-on screwed up this adapter or registry entry, I suspect.

After removing the other adapters, my "hardware wizard" automatically found my network card and reinstalled it. After that, I had network access. I haven't reinstalled the other adapters yet, though I wrote down the ".inf" files for each adapter in case I want to reinstall them. I found the .inf files in the registry by searching for the associated driver name that I found in the device manager. The .inf files are needed for installing drivers manually through the add hardware interface (at least as far as I'm aware).

But my "WAN Miniport (IP)" is still disabled, and if I try to enable it, the machine crashes. So I suspect I'll encounter problems down the line if I don't address this...
December 24, 2008 3:46:10 AM

I solved the above problem. I found the following site:

http://www.anetforums.com/posts.aspx?ThreadIndex=3204

Quote:

"The reason that uninstalling the device fails is that the device is marked in the registry as not being user removable. ... The "not user removable" attribute is stored in the Characteristics bitfield of the device's registry key. The "not user removable" bit is 0x20 and clearing that bit allows the device to be removed through Device Manager. In my case, the Characteristics value was 0x00000029 and I changed it to 0x00000009.

"The complete list of values for the Characteristics value can be found at http://www.osr.com/ddk/network/501install_4q5j.htm ."

I found the relevant key under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class , but I found it by searching for the name of the device ( WAN MiniPort (IP)).

I took care to back up registry areas that I was changing, and to look for possible problems that might arise.

I reinstalled the driver immediately. I'm not sure this was necessary as I ended up with an extra entry in the device manager for the device. But that could have been because of attempting to reinstall the drivers earlier using the .INF files. I removed the extra entry.

All in all, I'm having a holly jolly Christmas.
!