Can DBAN delete a write-protected USB drive?

I've had no luck trying to delete files or reformat a spontaneously write protected USB flash drive (no switch). Will DBAN override the protection, and if so, where can I find a Windows version?
7 answers Last reply
More about dban delete write protected drive
  1. Try gparted (partition editor) and check the partition flags; I don't know of any Windows based tools that allow the same level of control.
  2. If you're on windows then disk administrator under the management console should allow you to remove just about most things. You'll need to delete the partition then you can start from scratch.
  3. Yep, knocking out the partition table will do what you want.
  4. A colleague of mine tried to use the Berkeley version of Linux and could not delete the partition. Over the weekend, I used the command:

    DISKPART> detail disk
    UFD USB Flash Drive USB Device
    Disk ID: C3072E18
    Type : USB
    Status : Online, Healthy
    Path : 0
    Target : 0
    LUN ID : 0
    Location Path : UNAVAILABLE
    Current Read-only State : Yes
    Read-only : No
    Boot Disk : No
    Pagefile Disk : No
    Hibernation File Disk : No
    Crashdump Disk : No
    Clustered Disk : No

    Note the discrepancy in the bold, italic lines which say "Current Read-only State : Yes" but "Read-only : No." This prevents me from deleting the files or reformatting the drive. Any other suggestions?
  5. Once you've selected the right disk (make sure you get it right!) execute the following commands:

    clean
    create partition primary
    exit

    Then in Windows Explorer just format the drive. If it doesn't show up, go back into diskpart, select the disk and then run:

    select partition 1
    assign
    exit

    It should definitely show up then. You will probably get the autorun prompt as well.
  6. So far, no luck with any suggestions. I had several IT people with Macs working on it, but they could not access or delete the partition on the flash drive.

    Note my previous error message from DISKPART, which reported a discrepancy between "Current Read-only State : Yes" and "Read-only : No."
    On the web, I found another person had asked this question, but it was diverted to Microsoft support, and the answer was not published.
    http://www.eggheadcafe.com/software/aspnet/35994039/disk-marked-as-current-readonly-but-readonly-flag-is-off-.aspx

    I've tried to write-protect/then unprotect the drive, and put it in the freezer to see if I could get access to reformat, but failed. I also exposed the flash drive to a strong magnet, but the files remained intact. Apparently data is not stored magnetically, so degaussing would not work either.

    To delete my proprietary data, I may have to boil it or microwave it, unless someone has another idea!
  7. Buy a new one? Seriously you've spent hours on this from the story you tell. It could at the end of the day be a HW issue.

    To kill the existing drive an ensure the files can not be read just use a hammer, I'm sure that will also help relieve some of the frustration this thing has created. ;)
Ask a new question

Read More

USB Flash USB Drive