Sign in with
Sign up | Sign in
Your question

The password does not meet the password policy requirements

Last response: in Windows 7
Share
August 5, 2011 7:00:34 AM

Hello,
I'm having problems with setting the password for any user.
The problem is, thah when I want to change (or create) password for some user (domain user or database user), I allways get this error: "The password does not meet the password policy requirements." If I check the "Local security policy" -> "Account Policies" -> "Password policy" on my computer, I have disabled "Password must meet complexity requirements." option.
I spoke with our administrator and he told me that our domain server also has this option disabled. To prove this, he change password on any other computer and it worked ok. And we used the same password.
Could it be some bug in windows 7?
I don't know what else could I do, so I would prefer any help, that I could get.
Just for information, I have Windows 7 Pro 64bit installed.

Thank you in advance.

Dado
August 5, 2011 1:48:15 PM

A few things to look at. First would be your default domain policy to make sure that complexity is not set. If it was once enabled, you cannot simply disable it as this is called tattooing. So what you need to to is set it to not defined. Also take a look at minimum password age, and password history.
Having set this in the local policy should not effect any domain passwords as the domain passwords are controlled by the default domain policy or any policy with the highest priority linked at the domain level.
Belive me this is not a bug in Windows 7.
On this machine from the command prompt run net accounts to see what your policy settings are set at.

Good luck
August 8, 2011 12:42:46 PM

Hello cisqokid, thank u for your reply.
I found out what it was. I haven't mentioned that i have HP laptop and it was one of its service (HP protect tools security manager), which was messing with my password policy requirements. Since I removed it from my computer, I'm not getting this error anymore and I can set any password I want.

Regards.

Dado
!