Sign in with
Sign up | Sign in
Your question
Closed

Need Help Installing Citrix Receiver on Ubuntu 64-Bit

Last response: in Linux/Free BSD
Share
September 11, 2010 12:45:52 AM

I just started my first term at BCIT, and they've told us to install this program to use a bunch of programs they have hosted on the servers. I figured it'd be easy enough, and I was wrong. I tried following a few guides that I found via Google, but I just haven't been able to get this to work. There's only a 32-bit version of said program, and I just can't get it to work at all. I get the program installed, but it just... doesn't work. If any body's had any experience whatsoever I'd greatly appreciate some input. The software is mostly CAD, and I'd rather not have to try to do that on my laptop (running W7 for now...).

Pretty much what I've tried is installing Receiver (successful), installing the Motif lib (successful), and then there's been some stuff about.. binding the motif lib or something, I have no clue but it wasn't working for me.

I realize I have no clue what I'm talking about, so if I left out some information please let me know.

Thanks,


- Jesse
September 11, 2010 4:40:58 PM

Alright, ran through that. Got it installed. Went to the URL on the school's server, ran the program and....

Quote:
You have not chosen to trust "Thawte Premium Server CA", the issuer of the server's security certificate (SSL error 61).


Error. I don't know if I have to do that in a config file, or forward port 61, or what. Any ideas?
Score
0
Related resources
September 12, 2010 10:40:12 AM

Sound like you need to set-up a trusted site or install a digital certificate for authentication. Thwate are these guys:

http://www.thawte.com/index.html

They are a root authority who issue the certificates and probably the ones for your school. From memory error 61 is authentication (no certificate installed on your system).

You will probably need to install a digital certificate and add a couple of domains to your trusted sites list (in FireFox, although expect them to only have guides for IE!) so you might very well need to ask the school IT.

Also worth checking you are letting the SSL port 443 through your firewall as this has a habit of screwing things up. People thing Web = http = port 80 and totally forget about SSL on 443.




Score
0
September 13, 2010 3:32:58 AM

Awesome, thanks for the suggestions. I'll have to talk with somebody later this week :) 
Score
0
September 13, 2010 6:23:15 PM

Let me know if you need a bit more with it.
Score
0
September 13, 2010 8:07:47 PM

Well...I installed a Citrix receiver on a friends laptop and it didn't work until we installed Java...after that it worked flawlessly.
Score
0

Best solution

September 20, 2010 2:32:17 AM

Pyroflea said:
Alright, ran through that. Got it installed. Went to the URL on the school's server, ran the program and....

Quote:
You have not chosen to trust "Thawte Premium Server CA", the issuer of the server's security certificate (SSL error 61).


Error. I don't know if I have to do that in a config file, or forward port 61, or what. Any ideas?


I have to run Citrix Receiver for work and I use my laptop running Gentoo amd64 as the client, so I know the whole rigamarole. What you need to do is the following:

1. Open up Firefox and go to Edit -> Preferences -> Advanced and then click on the "View Certificates" button.
2. Scroll down to "Thawte Consulting cc" and select "Thawte Premium Server CA."
3. Click on "Export" and save the certificate file to disk. It should be called ThawtePremiumServerCA.<something.>
4. If you installed the Citrix client to the default /usr/lib/ICAClient, then execute the following less the quotes: "sudo cp ThawtePremiumServerCA.<something> /usr/lib/ICAClient/keystore/cacerts/ThawtePremiumServerCA.crt"

Now try to relaunch the .ica file with wfica or just click on the server's URL again. It should work properly at this point.
Share
September 20, 2010 4:29:52 AM

Dear MU_Engineer,

I love you.

Sincerely,

Jesse

:D 

Seriously though, thank you so much! I know a couple other guys in my course are running Linux as well, so I'll have to pass this info along! Thank you again!
Score
0
September 20, 2010 4:30:13 AM

Best answer selected by Pyroflea.
Score
0
September 22, 2010 5:24:48 PM

This topic has been closed by Mousemonkey
Score
0
!