Sign in with
Sign up | Sign in
Your question
Closed

Photoshop CS4 brush lag and Wacom support broke!

Last response: in Apps General Discussion
Share
January 4, 2009 10:20:43 AM

Still waiting for Adobe to fix apparent problems in Photoshop CS4 within their brush and OpenGL GPU video engines. To date, I have found no workable resolutions for all of the similar complaints spread across web forums to address brush lag, Wacom tablet pressure sensitive functionality broken, and general video flakiness. Photoshop CS3 installed on the same machines are reported to work fine. I spoke to both Adobe and Wacom technical support, and they both acknowledged the problems, either directly or indirectly. Wacom said they sent a letter to Adobe "two weeks ago" reporting the tablet pen pressure sensitivity problem. Adobe had me try every tweak in their book, to no avail, and then privately acknowledged the huge number of user complaints. My system is no slouch either, and met with no qualms from Adobe, so one can assume this is a big problem.

Jim P.
Sierra Vista, AZ
January 27, 2009 12:49:39 PM

I had the same problem, and it was incredibly frustrating. If you're running XP Tablet, you could try this:

Success! I thought the behavior of the delay seemed suspicious – like it was ‘thinking’ about what to do. I couldn’t figure out why Photoshop OR the Cintiq would need to think about it. HOWEVER, I’m using XP Tablet, and it does have to think about what the pen is doing – it looks for a hold pattern to emulate a right-click. To fix the problem, just turn off Press and Hold feature:

Control Panel > Tablet & Pen Settings > Pen options > Press and Hold

Uncheck ‘Press and Hold for Right-Click’.

I don’t have that feature now, but Photoshop works correctly with smooth pen sensitivity regardless of timing.
February 8, 2009 1:35:06 PM

Awesome suggestion Mooner! :D  I'm using a Graphire3 on Windows XP64 so I don't have a "press and hold" button, but I did d/l the latest drivers from Wacom and was able to get the Tablet & Pen Settings in my control panel. From there, I just disabled the functions for the two buttons on the side of the pen (on of them being for right click) and painting on 3D models in OpenGL has been much faster now--aka usable lol-- despite having an old Geforce 6200 OC.

I also set the render preset in photoshop to "unlit texture" since I don't really want the shadows to slow down my system (or misrepresent texture color), and that also helped a bit.
Anonymous
November 30, 2009 4:22:26 PM

I run win 7 ultimate and had this same problem. I followed the instructions given here (right click-stuff above) and it worked perfectly. Granted there still is a SLIGHT latency, however it does not disrupt the creative or productive process. Kudos! Just wanted to drop a line letting everyone know this works. Peace!
November 10, 2011 7:41:56 AM

I'm also running 7 Ultimate, and tried the same thing - click and hold was destroying my pen response in Illustrator and Photoshop - there was a hideous delay between pen touchdown and line draw. The result was that every stroke had a good centimetre at it's head that was just a straight line.

Disabling the 'hold for right click' deal cleared it up.

Thanks.
November 10, 2011 10:30:24 AM

Hey metalmustache

It is 2 years old thread.
November 10, 2011 10:31:11 AM

This topic has been closed by Nikorr.
!