Sign in with
Sign up | Sign in
Your question

Driver_IRQL_Not_Less_or_equal scsiport.sys

Last response: in Windows XP
Share
April 7, 2008 4:24:19 AM

Hello everyone,
This is my first post here and im hopeful someone might be able to give me some direction as to what to do as I never encountered a problem like this before.

First the tech specs:
Intel extreme quad core 3.0 ghz
4 gigs corsair ram
SLI'd 8800 GTX PNY overclocked
780i nvidia mobo
1000w power supply
A+ el diablo case
creative audigy sound card
1 terrabyte harddrive
1 dvd multirecorder litescribe drive (sata)
1 dvd drive (IDE) - pulled from an older machine.
Windows xp 64bit fully patched

Problem:
When I first built this computer I wanted to have 64bit vista on this machine. I kept blue screening after it would copy and install the files. It would reboot after doing the inital install then launch vista and I would get a blue screen. After 4 failed attempts I gave up and Put xp 64bit on it. (I got free OS's through a college program)
So after putting in XP it went smoothly. Now I tried to install a few games. Medieval total war 2 and its xpack installed fine. However if I put in Call of Duty 4 it instantly crashes when the cd goes into the drive. Last night I had a friend over and I tried putting in some music cd's and a blank disc to burn something on it. All of which crashed with the same blue screen.
I was told to do a memory test to see if it was the ram (I Didn't think it was but it was advice so I tried it anyway) and it came out fine. I was also told to download a tweakui and disable auto play. I did that and I still get the blue screen.
Here is a picture of the bluescreen that I took today.


So far this is what I have done.

I tried to uninstal and reinstall the drives. I figured if it was a driver by redownloading the driver it might fix the issue. However it did not.

tried rebooting in safe mode. it read the music cd that I had put in there but obviously couldn't play it as audio drivers werent loaded into safe mode. So its a driver issue. But I still have no idea what driver it would be or anything like that.

I attempted to use this ' http://support.microsoft.com/kb/839635 ' and it did not fix the issue either. All it did was make the blue screen message dissapear faster.

I also ran a start / run / sfc /scannow and that seemed to check out aswell.

I turned off the pagefile to see if that was an issue. It did nothing to fix the issue.

here are some error messages im seeing in the event viewer:

1. The IMAPI CD-Burning COM Service service entered the stopped state.
For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

2. The driver detected a controller error on \Device\CdRom0.
For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

April 7, 2008 5:21:03 AM

ram voltage set and error still persists upon putting in a music cd.
Got anything else I can try?
I should add I don't think its a hardware issue I believe it to be a driver issue. But I am open to any fixes.
Related resources
a b \ Driver
April 7, 2008 5:30:15 AM

If you have to, do a repair install of the OS. Or a fresh install is better.
April 7, 2008 5:36:52 AM

im not good with overclocking or setting voltages so if you got a voltage change give me an exact setting please otherwise I won't know what to put it at.

As for a repair install what would that do to any of my personal files if anything?
a b \ Driver
April 7, 2008 5:48:27 AM

You would have to know the Northbridge default voltage of your MB and bump up the voltage from there. Undervlted RAM and NB can cause the BS your are getting, it is very common.

A repair install would revert you Windows OS back to the point of the restore CD you are using. You would have to reload the 'updates' from there, but your fleswould be left as they are (for the most part).

If you are so sure it's a driver or OS problem, one other thing you can do is run a Registry repair software like this and hope it 'fixes' you registry should there be a problem with it. Like the link I gave stated, the eror you are getting could be caused by a number of things. I would say you RAM is a good possibility. Ttry running the system with one DIMM in slot 1 and see if the error shows up.

http://www.eusing.com/free_registry_cleaner/registry_cl...
April 7, 2008 5:51:54 AM

Ill try this registry editor first and see what I can come up with on that. Then Ill try the ram. I am pretty convinced its a driver error as the screenshot claims its with that file. I tried a windows hotfix but that didn't do it so I really don't know.
Either way voltage on the ram I get the error.
From my research today I do see its a common error pointing to ram so ill check it out in a few min
a b \ Driver
April 7, 2008 5:54:34 AM

Yeah, I would bet dollars to donuts it's RAM related. I had to set my NB voltage to 1.39v on this system to get the 8GBs of RAM to play nice. No problems since I did that.
April 7, 2008 6:19:27 AM

ok well i just got done getting everything back up from the reg program i ran. That really messed up my machine. I got it back to normal now save for my g15 keyboard not showing me what my processor is at... i think i might tackle the ram tommorow after work
April 7, 2008 1:28:48 PM

Well I ran a memory test on my system while I slept it ran for a couple hours and everything checked out. The only reason im hesitant that its the memory besides the fact that the test came out alright is that the games I did get on my machine work fine. Its just if I put certain cd's into the drive does it give me that blue screen. Im not seeing a connection to the ram in a scenario like that. Again if im wrong please correct me but wouldn't that be a driver issue with the drive? In this case in the blue screen a scsiport.sys?
a b \ Driver
April 7, 2008 2:48:11 PM

I have run that registry cleaner on two to three dozen different machines during the past 2 years or so without a single problem. I use it on 12 machines in our offices. The program did corrupt some files on my VISTA 64 machine. I contacted the company's support and they contacted me immediately stating they had not tested the software on VISTA 64. So, I don't recommend using the program on VISTA 64. If the software 'messed up' your machine, something is wrong with your OS install or your machine configuartion in general. You should reinstall the OS.

Now, you keep stating your Corsair ram is fine. You run memtest and it's fine. But then when you try and run a CD (install/run software) the machine Blue Screens with the IRQ-NOT-EQUAL message. That is what bad or misconfigured RAM does, it causes system failure under the stress of running software (a CD). I have seen this many times. A kid brought me his machine and showed me his game would not loadup with the CD. It was the RAM. I removed the second channel DIMMS he had added and the machine ran perfect. Memtest is not run under the stress of a windows environment. It could be your RAM is good (not defective), but not running correctly under windows. Try some other RAM. At least try and run the system with one DIMM in slot 1 only. I'm not saying the problem is not a driver, but what driver would that be? Reinstall your MB CD driver (system drivers). Reinstall your graphics driver. The problem is likely your RAM or you are in need of a reinstall of your OS. Every time I have seen the error message related to IRQ_NOt_EQUAL it has been the RAM.
April 7, 2008 3:32:58 PM

alright well when I get home then I will take out all the ram and leave 1 stick and boot it and see if the problem occurs. If it does ill take out that one stick and put in a different one and see. I have 4 sticks of 1 gig each in there so I have 4 to play with and try.
If that doesnt work I guess ill just backup my personal files over to another computer on the network and then format it and reinstall.

Any other suggestions before I reformat thou?
a b \ Driver
April 7, 2008 3:57:25 PM

Sounds good. Try that. In BIOS, 2.1v + or even 2.2v RAM voltage may solve the problem. Also set the RAM timings to 5-5-5-15. First try the 1 DIMM in slot one, then another DIMM if the first still gives the BS. I had some OCZ memory that refused to cooperate and I contacted support. I was told to bump up the NB voltage and it worked. I can tell you RAM is often the cause of software failing to run. Hope you get it solved. Post back after you try running the system with single DIMMs in slot one. Bump up the voltage and set the timings in BIOS.
April 7, 2008 4:20:24 PM

ok I tried 2.1 volts last night and it didnt solve it but I guess 2.2 won't hurt anything so ill give that a go and mess with the timings (ill admit i never did timings before with ram so ill hopefully be able to figure that out once I get into my bios when I get home) and see if i can figure out how to do that. But ill give that a go if nothing ill start with 1 stick and go from there. But I will definitly post back here with my results. I was searching around for this kinda error and I saw alot of similar errors but nothing quite like the problem im having so I wanted to make sure this all stayed documented for future searchs.
a b \ Driver
April 7, 2008 4:31:12 PM

You can download and install CPUZ, go to the memory tab and monitor your RAM speed an timings from Windows.

http://www.cpuid.com/cpuz.php

Yeah, with 4 GBs of RAM in the system you should go into BIOS and set up the RAM voltage and timings manually. Try the 1 DIMM in slot one only. 2.1+ to 2.2v may solve the BS. Yiu have 780i AMD chipset. That chipset has had more problems than you can imagine. I'm sure you would benefit by updating to the latest BIOS. I'm sure there are many 'fixes' with latest BIOS for that MB. AMD chipsets can be real picky about RAM and all the things we are discussing are part of that.
April 7, 2008 4:44:33 PM

no thats not an amd chipset. Its a nvidia mobo with a intel quad core processor.
a b \ Driver
April 7, 2008 5:15:22 PM

Yeah, sorry I meant Nvida chipset, my mistake.
April 7, 2008 6:20:39 PM

any idea where to get a bios update on a evga 780i mobo? im not good with updating bios at all. actually never did it before...
a b \ Driver
April 7, 2008 6:31:00 PM

I don't have an EVGA MB, but you would need to go to the EVGA website and find your MB product page. Instructions for BIOS update should be there.
a b \ Driver
April 7, 2008 6:32:13 PM

What manufacturer is your MB? I misread and thought you listed it as EVGA.
April 7, 2008 6:43:41 PM

its a evga mobo 780i
April 7, 2008 7:12:32 PM

well from what I gather I think im all up to date there anyway. Ill just go with my original plan of the voltage uppage 1 more time then work in seeing if 1 of the sticks is bad etc then ill reformat if that doesnt do anything.

April 7, 2008 10:16:19 PM

set the ram to 2.2 volts and nothing.
I ran a stress test on my system for 10minutes which maxed out my ram and it ran perfect. Do you still think it could be the ram after doing that test?
a b \ Driver
April 7, 2008 10:20:05 PM

Yeah, you didn't try 1 DIMM as a single in slot 1? It sounds to me as though you have some system configuration issues. Prhaps RAM related or BIOS related. The 780i is notorious for these sort of problems. I would try 1 DIMM RAM in slot 1 and be sure you have the latest BIOS and chipset drivers from the product website.
April 8, 2008 12:07:50 AM

ok so I just rebooted with every single ram stick in individually. I tested with a music cd. The same error occured every single time.
April 8, 2008 12:13:18 AM

kept the ide drive unplugged to see if that was causing a problem. Still had error occur
a b \ Driver
April 8, 2008 12:21:35 AM

Well, I was looking closer at your system configuration. I would have loaded up VISTA 64, not XP 64. You may have to face up and consider reloading you OS system.

Be sure you have the latest BIOS and system drivers. I would load with the OS with the basic hardware. 1 GB RAM. 1 video card, no sound card, keep it as simple as possible loading up the OS. Then install the sound card and check for issues. Same with the second 8800GTX in SLI, etc. checking for problems with each piece of hardware I install. When you add the RAM, be sure to set the voltage to 2.1v and adjust the timings to 5-5-5-18.

So reload the OS with the hardware I described in this order.

Load Windows OS DVD
load system drivers from MB CD
Get all the windows OS updates online
Load video driver
Install hardware individually and watch for problems.
a b \ Driver
April 8, 2008 12:23:20 AM

Actually what you did unplugging the IDE drive is a good idea. I would unplug everything including the second video card and sound card. Unplug everything except the CPU/fan, 1 video card, 1 DIMM RAM and in you case the HD and see what you get.
a b \ Driver
April 8, 2008 12:27:52 AM

I have been running VISTA 64 on the system in my configuration for months. No problem like you are having. I had to tweak the 8GB of RAM by adjusting the speed (1066 MHz), the timings (5-5-5-15) and the voltage (2.1v+). Then I had to set my NB voltage to 3.9v. Been rock solid stable since.
April 8, 2008 12:42:12 AM

do you think copying the scsiport.sys file from a vista 64cd might work?
a b \ Driver
April 8, 2008 12:50:02 AM

You have XP 64 installed right? I don't know what the file you mentioned is. I thin you have a couple of choices. Unplug or remove everything including the sound card and the second 8800GTX. Try running the system with cpu/fan, 1 GB RAM. 1 video card and the hard drive only. If you still get the error, I think a reinstall of the OS may be the solution. I would install VISTA 64 if you have it.
April 8, 2008 12:56:20 AM

ok so a friend of mine found a driver that I didn't have. I was using Nforce 9.46 drivers and when I went to nvidida it wasnt finding anything new. Yet there was a 9.64 driver out there. I installed it. It works problem solved!
thanks badge for your assistance much appreciated!
a b \ Driver
April 8, 2008 1:48:08 AM

I was going to post the latest nvidia driver for 64 xp. I even looked it up and had it on the screen.
!