Sign in with
Sign up | Sign in
Your question

User folders on hard drive is unreadable when drive is swapped

Last response: in Windows XP
Share
April 14, 2008 1:20:39 PM

My daughter's HP dv2000t notebook computer had a motherboard crash, apparently (won't turn on). I took the hard drive out and put it into a NexStar-3 USB drive enclosure to try to salvage the iTunes and documents. The folders all show up, but when I try to access her user directory, it says that it is "empty". The properties for the hard drive also say that it the drive is almost full, so the data is all there...somewhere.

Is there some kind of security that is tying the user directory to my daughter's computer and dissallowing me to tread her files on another computer? I can see how this would be a good feature if it was stolen, but when I send it back to HP for repairs, they say that they will restore the hard drive to its original condition and wipe out her investment in music, etc.

I think that the music is worth more than the computer.

Any help?
April 14, 2008 2:57:44 PM

Yes there is security on the drive if it is formatted to ntfs. However it would not say that the drive is empty it would instead say that you do not have permission to view them.

Right click the drive in my computer and choose properties. If there is a security tab there then great otherwise skip here for now and read the next paragraph. Go to security and click advanced at the bottom. Then goto owner and change owner to you or the administrator of your PC. Tick the box to replace ownership on subcontainers and objects and apply. This will make you the owner with full control of the drive.

If no security tab in my computer click on the tools menu and then folder options. goto view tab and right at the bottom untick use simple file sharing. Then do as I said in above paragraph to replace ownership.

However I do not think this is your problem. If you are running XP with service pack 2 this has known compatibility options for external USB mass storage devices. I think this is more likely the culprit. You will have to uninstall SP2 on your machine then go into device manager and remove your USB. Then reinstall your USB hard drive (Make sure you are not connected to the internet whilst backing everything up as SP2 has security benefits for viruses etc that you will be turning off).

See if you can access the drive without SP2 installed then back it up, disconect it, reconnect to internet and reinstall SP2.

Also the drive may not be formatted to NTFS and might be FAT32 which XP can not read. What operating systems do you and your daughter both run?
April 14, 2008 3:39:30 PM

We're both running XP professional. Most likely the drive is formatted as NTFS, if I remember right. I can read all of the other directories on the drive, it just pretends that the user directory that has a login is empty. Thanks, for the tips. I'll attempt them at lunchtime.
Related resources
April 14, 2008 3:53:17 PM

Then in that case it might be the permissions.
April 14, 2008 4:09:23 PM

I'm in the process of changing ownership of a ton of files. I went to the properties of that drive, clicked the Security tab, then clicked the Owner tab and I'm changing the owner of all "subcontainers and objects" to be me. It appears to be touching every file on the hard drive, so it's taking forever, but prospects of success are good.
April 14, 2008 5:21:51 PM

success
April 14, 2008 8:18:53 PM

Well done glad it worked
April 15, 2008 3:18:03 PM

@mafadecay Excellent assistance dude!
!