Sign in with
Sign up | Sign in
Your question
Closed

VLC Plays Gray Screen!!!

Last response: in Windows XP
Share
April 14, 2008 11:03:58 PM

i just moved all of my media files to my desktop with xp pro. i installed vlc 8.6f and tried to play a video and all i got was sound and a gray screen. what the hey?!?! so i tried playing the same files in itunes and they worked but the frame rate was about .3 so it was worthless.
Whats the deal?

More about : vlc plays gray screen

April 15, 2008 9:25:25 PM

is this in the wrong forum or am i alone?
April 15, 2008 9:38:33 PM

He mentioned XP Pro atleast. Also there was another post in here re: using VLC instead of MP11.

So IMHO then I guess its atleast kinda posted correctly. I think the error is with VLC though not XP.
Related resources
April 15, 2008 9:54:10 PM

ok so if im in the right place how come im not getting any help?
April 16, 2008 11:28:53 AM

The trouble is with forums like this one that its not just about taking. People with a proble log on get their info and never return until they have another problem. Forums only exist with teamwork and knowledge. I am not blaming anybody in particular. I have decided to browse this forum and try to give back a little that I may of stolen from other forums. I am no car mechanic but use car forums to fix my car. I can not help people in that fourm but maybe I can in this one.

Anyway back onto your problem, I would help only I have never used VLC. It does sound to me that you have a memory shortage and not enough resources to play the video. These recomendations may not fix your problem but will help with other things in the long run and if you get lucky maybe they will allow your video. I know you have quicktime installed so imagine its running all the time.

I recomend right clicking everything down by your clock and stopping all things that are not imperative. These tiny icons are useful bet take a huge load on resources. Your broadband and maybe antivirus should be all about what runs down there. Maybe other stuff but depends what this is.

Click start and run type msconfig and click OK. Click on the startup tab and have a look what you can untick here to save a bit of RAM. Quicktime can go for starters! It will still be available for you on demand just wont be running all the time.

Also how much available hard disk space have you got. How much RAM you got and what graphics card do you have. Is it AGP graphics, PCI or onboard?
April 16, 2008 12:01:04 PM

If you are getting a gray screen, you may need to download some codecs as first approach.
April 16, 2008 12:13:47 PM

VLC uses its own codecs, so far as I know. Even though VLC uses its own codecs, it will try to use directx or OpenGL (your choice) to output the video, so if you're getting a gray screen, it could be a graphics driver issue. Have you tried using a media player other than VLC or iTunes? (The framerate issue on iTunes leads me to believe your graphics drivers are not properly configured or installed.)

What computer are you using? Please list the specs and other relevant information. Is your computer home-built, or built by an OEM? (Dell, HP, Gateway, etc.)

Oh yeah, I just remembered. If VLC doesn't have a codec for a file, it just won't try to play it at all. So if you play a movie, and it doesn't have the right codec for the video, it'll just play the audio only. In other words, the window won't even have a gray screen - it'll just show the controls as if you were playing an audio file. Anyway, if you were using Linux or Mac OS X or BSD (or some other OS), I would recommend mplayer with a front-end or VLC. However, since you're using Windows, I don't think VLC is the best solution, although it's good to have it installed anyway. You might just want to get some kind of DirectShow codec pack (k-lite, CCCP, etc.) along with the latest drivers for your graphics card.
April 16, 2008 3:51:09 PM

I found this quote on another Video forum. Like I said I never tried VCL so I have not tested but may well work. This was on Vista but should remain the same through OS's

"Go to prefrences, video, output modules, advanced and select open GL video output, that should work."
April 17, 2008 12:58:38 AM

i would like to try that but i just rebuilt the thing and im using osx right now. i will try that when i get the windows portion going though.
thanks1
April 18, 2008 2:38:12 AM

well everything is working after a motherboard swap thanks for your help though!
April 30, 2010 9:16:28 PM

I had the same problem on XP Home SP3 using VLC 1.0.5 and this solution worked for me. Thanks! :) 
Anonymous
October 30, 2010 12:02:29 PM

TOOLS> PREFERENCES > VIDEO

the problem is with the source of output. i changed mine to WindowsGDI and it worked fine. just go one by one thru those options til it works. I've had this happen to me when i changed videocard in my PC

-Moe. :)  Also, mine was because of a direct X issue...
November 13, 2010 3:31:22 AM

This topic has been closed by Mousemonkey
!