Sign in with
Sign up | Sign in
Your question

Wireless-n USB ok in WinXP but not Ubuntu 10.04

Last response: in Linux/Free BSD
Share
October 13, 2010 1:45:25 AM

I have a fully updated version of Ubuntu 10.04 dual booting with Windows XP Pro. The USB wireless-n adapter uses the reallink rtl-2870/3070 chipset. The rtl-2870 drivers are integrated into the Ubuntu Linux kernel I'm told. Here's the problem. In WinXP, the wireless works like a charm. When I try to connect thru Ubuntu, I can't. Using WICD, I used the exact same settings as in WinXP. Same preshared code, same WPA 1/2 password. Same network name. Ubuntu can see the network just fine but won't let me connect or access the internet. My Win7 Home Premium and my wife's Win7 Starter use the same settings as the WinXP box and work just fine. I'm connecting through a D-Link DIR-628 router set at 802.11g standards. What could I be missing?
October 13, 2010 1:41:16 PM

If you've not already try turning off any wired connection you have open. It does nott seem to like having two connections pointing at the same DHCP server.
m
0
l
October 13, 2010 3:58:26 PM

I always unplug the eth0 connection before trying the wlan0 connection as Ubuntu defaults to the wired connection.
m
0
l
October 14, 2010 9:01:04 AM

Not just unplugged, disabled in the network controls.
m
0
l
October 14, 2010 2:14:41 PM

Before attempting to connect, open up a Terminal window. Then try to open the connection. Post the output of "sudo tail -n 100 /var/log/syslog" here. Somewhere in the latter part of that log it should indicate what is going wrong. That is assuming that wicd writes to syslog and not somewhere else. I only know that's where networkmanager writes to.
m
0
l
October 21, 2010 4:33:33 AM

I got the problem solved. It appears there's a bug in the Ubuntu 10.04 / Linux 2.6.35 (?) kernel that disable the rt2870 password handling capability. This has been posted on the Launchpad website. The fix is to install the backport module recommended there. Now it works fine.
m
0
l
!