Sign in with
Sign up | Sign in
Your question

lost cdroms in bios

Last response: in Windows XP
Share
April 17, 2008 7:42:34 PM

Hi, my problem is that first of all the updates for xp home would not load, the Cd/DVD rom stopped being recognised in the BIOS, when trying to restore to an earlier date the PBell lost the restore points due to 'lack of memory' although there was plenty on the computer.

Lost the Internet explore & audio/video, when trying to restore to the earlier date? (says no cards present) I removed the upper & lower filters as instructed by Microsoft’s site. Also in Device Manager there is only the Hard Drive, no other drives? although the cdroms are working even changed the cable leads? 1 message is that it can't create Ramdrive-less than 2mb of memory!

Windows XP is still on the computer, even loaded another XP O/S on the 'D' drive.

Have added a floppy Drive on ‘A’ working well, created 6 floppies to no avail as the message is after loading - No cd rom drive?

I can still get in to the computer through USB ports (no problems) even sent for a lead to allow any CD rom drive to connect through the USB ports! No jumpers have been altered on the CD drives and they are functioning well in another computer.

Where do I look now? I have been told that the Bios should be ok? does it need flashing? The computer is 3 years old, had 1GB of ram and is functioning ok apart from the obvious? Should I be looking at the BIOS or registry, anyone care to comment HELP! many thanks Phil.

More about : lost cdroms bios

April 18, 2008 12:07:13 AM

Generally I would make sure all conections are tight and secure but maybe you need to have a hoover out. Dust may bell be a problem.

I would try different BIOS settings such as load optimised and load default settings. Make sure your IDE devices are all set on Auto in BIOS. Try and see if they pick up not. If not change them to manual and then back to auto. Every now and then my boot misses my DVD and second HD on the same IDE. Touch wood it doesn't fail and all I do is reboot a few times until it works. Your battery may have gone does your sytem retain the time? A power surge may have blown the IDE controllers on mobo do you have any othe rdevices working off same IDE channel?

If all this doesn't help try playing with the jumpers see if it picks up on cable select etc. Disconnect all hard drives and boot with the CD alone see if it finds it then.
April 18, 2008 11:08:09 AM

Thankyou for that, first time/s that i have used the forums here and on 2 other sites (yours being the second answer - someone thought that it could be a virus)

First, No dust - keeps it all clean, Connections are all 'good' Changed the bios setting to load all & back a few times to 'defaults' Battery is working (tested/tried that by removing & putting it back in.

No devices are showing up in the BIOS - CDrom through the USB does show up on the flash screen (F8) and on 'C' drive in 'Computer" but no others are being recognised.

Don't know anything about the IDE settings/Mobo? apart from set on Auto's!! so maybe need to find out & look closer.

I can get in through the 'A' drive (floppy) and through the USB's as long as the CD roms are disconnected (a conflict? CD rom connected to USB with CDrom connected as normal into the Motherboard stops the USB Cdrom from being recognised and running?) No conflict exists with a USB Flash device though.

Moved the 'jumpers around & the CD/DVD roms even changed the Master/Slave lead as i saw a 'nick' in the very last wire? (not No. 1 but other end. You haven't mentioned the Bios so i'm presuming that you believe that its 'all good'? (i hope so)

Still can't connect to the internet, (says No hardware) although the broadband is all good. Will have to download the appropiate sound drivers aswell. Atleast i'm learning more about the computers operation.

Thankyou for taking the time to help me and others. Thanks Phil.
April 18, 2008 11:28:32 AM

Plot thickens! Battey failure or a spike/surge could funk your BIOS but otherwise if it was working fine it shouldn't just stop so I don't think flashing will help. (Particulary in public places as you will get arrested lol).

Failing hard drives etc could knock your boot sequence out a little. In the past when they dont show in BIOS and boot sequence I normally check BIOS and swap form Auto IDE and back. I mostly get this problem for instance if I install a new HD or swap one over but can randomly occur. Even though the jumpers are fine the BIOS sometimes needs a kick.

Some BIOS setups, in auto detect, have a detect now thing where when you set it to auto you hit detect and it will auto detect it there and then in the BIOS setup screen. I would move HD and CD jumpers around a bit. If it auto detects once then chances are it will every time.

Even try, like I said, remove all HD's and try detecting just 1 CD in BIOS at first then add another and then drop a HD in the equation. I would have one HD and one CD on each IDE cable if they are long enough not 2 HD's on one and 2 CD's on other. Personnaly I find it works better. You may need a longer IDE cable. Tends to help a bit in windows aswell when copying CD's on the fly or swap files on different drives but that is another story.

It could have been a virus but this is sounding very hardware based to me. Some XP updates are a real pain.

So am I correct in thinking that basically everything hardware has stopped?
!