Sign in with
Sign up | Sign in
Your question

HDD Not found in BIOS

Last response: in Storage
Share
May 15, 2007 9:38:45 PM

Here's the situation;

I was trying to format a drive on a PC. There were two partitions and windows was installed. I figured I would use partition magic to format both drives. So I queued up both drives for formatting and rebooted the computer. Partition Magic started to do its thing, however shortly after it started it said something like
xxx File Not found
100% complete
This happened for both partitions. It didn't seem like there was much I could do at this point, so I rebooted the computer. After the POST I get the message NTLDR is missing. I thought that it wasn't a big deal as my previous attempt to format messed up. I figured that I could boot up a Windows CD and just use that to format and re-install windows.

So I boot up the windows CD and select the install option, only when it comes to the screen to ask which partition/drive to install on, it says that no drives are detected. After this I rebooted and went into the BIOS but it doesn't seem to be able to detect the hdd. I tried resetting the settings to factory defaults and rebooting but it still didn't show up. The Zip drive and 2 cd drives show up however. This is an older PC so everything is IDE (no SATA).

The PC worked fine prior formatting with Partition Magic. No hardware configurations were changed. I don't know if this is significant, but a non-bootable CD was in the drive when I rebooted to have partition magic format, but I've removed it after that. Any ideas what the problem could be?

More about : hdd found bios

May 15, 2007 10:26:01 PM

See if BIOS has option to detect hard drives. See if option on IDE section to set master to AUTO or AUTO DETECT.

Mike.
May 15, 2007 11:07:06 PM

Run the diagnostic/repair software from the hdd mfg(s). When I've run into these kind of things this usually corrects the problem
Related resources
May 23, 2007 11:28:23 PM

Sounds like you messed up the partitions or the MBR. Get a cd called hiren's boot cd and use it to repair your partitions as well as the mbr.

Good luck
May 25, 2007 2:59:33 PM

I think that drive have failure in some module of firmware. Do you want to know why ? Well, it's easy, a big part of the firmware is stored on the platters inside a area called "negative sectors" or SA.
Because it's outside the user area and below sector 0 you can't access to it using regular disk edit tool. You will need to send some vendor specific ATA commands to the drive so you can fix the damaged firmware. Hiren boot CD-ROM have no effect in case HDD with SA erro.
!