Sign in with
Sign up | Sign in
Your question

Ubuntu 10.10 Windows 7 dual boot problem

Last response: in Linux/Free BSD
Share
October 20, 2010 10:42:02 AM

I had Windows 7 home basic 64 bit installed on my PC, which is partitioned as: 177GB + 100GB =320GB.
I decided to install Ubuntu 10.10, and while doing so the installation process recognized my Windows OS and accordingly suggested to automate the process(i.e I didn't opt for the Advanced partition process). Thus, I ended up with a 14GB ext4 partition. I booted into Ubuntu via grub, which worked fine.

All went well until after the first time I booted Windows 7 from grub. Windows checked C: for inconsistencies while booting. Then, Windows didn't display the ext4 partition as separate(which I'm told is perfectly fine, as Windows doesn't recognize the ext4 file system). However, after shutting down the computer, when I started it again the grub loader didn't load and I received an error message stating that the reloc offset exceeded the limits of the segment. Then a message appears stating that the operating system wasn't found.

So, what could be wrong and how can I repair the system?

EDIT - And one more thing I didn't mention was that when I now insert an Ubuntu 10.10 live cd and click on Try Ubuntu and check the files on disk, I can see only the 2 partitions, as per Windows. The third partition(the 14GB one) which appeared as a 'file system' drive on the installed Ubuntu doesn't appear anymore.

EDIT2 - Well, I was browsing the threads, and I found a post by buwish
Quote:
Not an app related deal, but something strange occurred earlier. I installed 10.10 via a "side by side" install and not on a separate partition. So, when I booted into Windows from it, I got a "chkdsk" for some odd reason. So I ignored it and went into Windows. Restarted to see if I'd get the chkdsk again and boom, no boot. I got stuck at a prompt with "grub" in it. I assumed that the boot manager was messed up somehow, so I used my Windows disk to clear it, which worked (i.e. the command prompt line fixmbr). To play it safe, so I could back some things up, I wiped the Ubuntu install out for the time being.

Anyone know what happened? If I reinstall, should I do so on a separate partition?

My problem was pretty much identical, but I didn't get any prompt with grub in it, just the reloc offset message and some Intel PXE ROM message, followed by an OS not found message.
I'm not sure how to fix this, and if the boot manager is pointing to a wrong location now, I don't have a Windows CD, so any ideas?
October 20, 2010 10:27:09 PM

I can answer the last bit (EDIT 2). The Intel PXE / OS Not found.

Your PC is set with a boot order, it tried a PXE Boot (over the network) then tried the first disc listed and could not find a bootable partition. I wonder if it might be worth checking you BIOS and establishing what boot order you have set.

If you have a LiveCD you could try booting this then having a look at what partitions there are using Gparted (it's on the menu as Partition Manager) and see if you can see the 3 partitions you should have.

Also could you let us know the basic spec of the PC in question, as you don't have an install disk I imagine this is a laptop with a recovery partition?
October 30, 2010 7:28:28 AM

Thanks for your response, audiovoodoo. I found out what the problem most likely is.
This link essentially details what I should do to set things fine.
http://ubuntuforums.org/showthread.php?t=1519200
However, regarding step 4 i.e. reinstalling grub2, I checked the following site:
http://ubuntuforums.org/showthread.php?t=1195275
In step 13, it mentions the possibility of a separate boot partition. How do I figure if my boot partition is separately located or whether it's in the Ubuntu partition?
One thing I'd like to mention is that while installing Ubuntu, I specifically chose to install the '/' directory in the separate ext4 partition I made. And /boot is under '/'. Does this mean that the boot partition is in the Ubuntu partition?
Also, sudo fdisk -l gives me:

Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x80000000

Device Boot Start End Blocks Id System
/dev/sda1 1 16 128488+ de Dell Utility
/dev/sda2 * 17 1306 10360832 7 HPFS/NTFS
/dev/sda3 1306 23982 182144363 7 HPFS/NTFS
/dev/sda4 26166 38914 102400001 f W95 Ext'd (LBA)
/dev/sda5 26166 36135 80078125 7 HPFS/NTFS
/dev/sda6 38792 38914 975872 82 Linux swap / Solaris
/dev/sda7 36864 38791 15478784 83 Linux

Partition table entries are not in disk order

sda2 is where my Windows 7 installation is.

Also, df -Th gives me:
Filesystem Type Size Used Avail Use% Mounted on
/dev/sda7 ext4 15G 4.3G 9.5G 32% /
none devtmpfs 1.5G 276K 1.5G 1% /dev
none tmpfs 1.5G 404K 1.5G 1% /dev/shm
none tmpfs 1.5G 88K 1.5G 1% /var/run
none tmpfs 1.5G 0 1.5G 0% /var/lock

So, is sda7 my Ubuntu partition?


EDIT- I just followed the steps mentioned and everything's fine now. The dual boot system is working great!
Just one question, though. I used to work on a previous version of vi (text editor) to write c/c++ code where the different parts of the code would appear in different colors. The new version seems to work slightly differently, when I press i (to enter insert mode) 'INSERT' doesn't appear on the bottom and delete also doesn't seem to work, so could you please tell me about the differences?
!