Sign in with
Sign up | Sign in
Your question
Closed

Removing Linux as a boot option

Last response: in Linux/Free BSD
Share
November 12, 2010 10:00:58 AM

I had Ubuntu installed as a boot option on my second hard drive. I deleted the partition it was on but it still comes up as a boot option and I would like to remove it. I tried booting from the Windows boot DVD and typing various commands into the command prompt like "bootsect /n60 SYS /mbr" that I read on some other threads but they did not work. I think my situation may be different because Windows and Linux were installed on different drives.

I'm using Windows 7x64 installed on my C: drive and Ubuntu was installed on the D: drive. Can anyone tell me how I can go back to automatically booting Windows?
November 12, 2010 11:31:06 AM

You'll want to run these commands in the command prompt provided on the install disc:

bootrec.exe /fixmbr
bootrec.exe /rebuildbcd

That should do the job.
Score
0
November 13, 2010 6:39:49 AM

I used those commands and got a successful operation message but Ubuntu is still appearing as a boot option.
Score
0
Related resources
November 14, 2010 5:37:50 AM

Have you tried switching around your boot order? It's quite likely that you're restoring the MBR of the drive which already had the Windows bootloader, but the GRUB bootloader is still on your first boot device, so you gain nothing. If you switch your boot order then it doesn't matter if you leave GRUB on your other drive because you won't ever be trying to boot from it.
Score
0
November 15, 2010 3:05:20 AM

I'm not sure if I follow you. The D drive isn't set as a boot option at all, but even though that's where I installed Ubuntu, it still comes up as a boot option. I currently have the boot order set to CD/DVD drive as first priority then the C drive as second priority, third is disabled. What order do you suggest I switch them to?
Score
0
November 15, 2010 8:13:31 AM

Try setting boot order to C only with nothing for the other two options. I would guess that this will give you the Ubuntu boot option still and confirm that the GRUB boot loader installed on C drive. This would be normal as the system boots from the primary drive then runs GRUB to boot the media on your D drive.

Set the CD as primary, C: as secondary and boot to rescue mode from Win7 CD:

bootrec.exe /fixmbr
bootrec.exe /rebuildbcd
fdisk /mbr

You can make sure you are working on the C: drive by physically disconnecting the D drive from the system for a moment.

If that does not work then you will have to take a look at the drive with something like gparted (on the Ubuntu liveCD) to see if we can work out what is happening.


Score
0
November 16, 2010 9:26:10 PM

Okay I disconnected the D drive just to be sure. When I input those commands this is what I got:

bootrec.exe /fixmbr - the system cannot find the path specified
bootrec.exe /rebuildbcd - total identified windows installations: 0
fdisk /mbr - 'fdisk' is not recognized as an internal or external command


Score
0
November 18, 2010 10:48:51 PM

Try connecting your D: drive again and disconnecting your C: drive. It looks to me like you have them the wrong way round, otherwise it should have found a windows install.
Score
0
November 19, 2010 12:20:58 AM

Yeah I thought that was strange, but I'm definitely using the right driv, I booted back to Windows right after that. Maybe I should mention that my C drive is an OCZ Revodrive that boots through PCIe, so it's pretty easy to verify which drive is connected.
Score
0
November 26, 2010 12:55:36 AM

Hmm well I never solved this one. Any other ideas?
Score
0
November 28, 2010 2:55:29 PM

Right-click My Computer, and then click Properties.
-or-
Click Start, click Run, type sysdm.cpl, and then click OK.
On the Advanced tab, click Settings under Startup and Recovery.
Under System Startup, click Edit.
remove the line that says ubuntu
make sure to make to make a backup because if you mess up.........................
Score
0
November 28, 2010 4:11:38 PM

Please read the link I posted.
Removing the bootloader is not as simple as would you think.
It CANT be done thru windows!
Ubuntu creates a grub loader that needs to be removed with the Ubuntu Live CD
I went thru this exact same problem and that link is the only thing that worked!
Score
0
November 29, 2010 2:20:18 AM

Thanks for the help guys.

Rocky_1- your suggestion is helpful but it seems your specific instructions are for a different version of Windows as I don't have an option to edit or remove Ubuntu, I was however able to change the boot options to show the choice of operating systems for 0 seconds which basically eliminates my complaint but does not fix the root of the problem. Out of curiosity, I still want to get to the bottom of this and learn know how to truly lose it as a boot option instead of just hiding it. Is there a different way to edit out Ubuntu for Windows 7?

king smp-I followed the first set of instructions on the link you provided but afterwards it gets into things I have already done. I've already deleted the Ubuntu partitions and restored them with Partition Wizard, so I can't follow it any further. I decided to run "sudo gparted" anyway and I received a "can't have a partition outside the disk!" message. I'm not really sure what that means but keep in mind that Ubuntu was originally installed on a different drive than Windows.

So I have found a sort of workaround for now but the problem still exists. Is there anything else I can try now?
Score
0

Best solution

December 2, 2010 5:53:21 PM

try looking at this: http://ubuntuforums.org/archive/index.php/t-352723.html
and this: http://gparted-forum.surf4.info/viewtopic.php?id=9238
there is alot of reading there and links so take your time.
Let me know if this helps.
I will check back.
Share
January 28, 2012 3:24:18 PM

Best answer selected by mousemonkey.
Score
0
January 28, 2012 3:24:20 PM

This topic has been closed by Mousemonkey
Score
0
!