Sign in with
Sign up | Sign in
Your question
Solved

No Sound in ALSA/MythTV, BUT sound in Ubuntu...

Last response: in Linux/Free BSD
Share
November 24, 2010 7:23:09 PM

Okay, so Ill try to make this as short and sweet as possible.

I have Ubuntu 10.10 64 bit and have sound. I can play a video with mplayer and get sound, and "test" in Preferences-->Sound-->Hardware sends the "bump" sound to the speakers just fine.

Unfortunately MythTv doesnt have any sound when trying to play videos (MythVideo). Not trying to do ANYTHING else in MythTV besides the videos right now, but as far as I know there is no sound for mythtv.

I have looked all over for answers to this, I try to figure things out before posting for help and have worked on this for days.

Things I have tried:

Installing proprietary driver for video card (Im using onboard 880G chipset). Didnt work

Created an alsa asound.conf file. I used a template that is here
http://www.mythtv.org/wiki/Configuring_Digital_Sound
and just added card 1 device 3 to digital and default. (in aplay -l, this is the one that says HDMI that I think I should be using, since HDMI is the only thing going to my TV). Didnt work.
--Note! I also don't hear anything when saying "aplay -D digital /home/me/soundfile.au"
Says its playing but I dont hear anything...

I found out that Ubuntu not uses pulseaudio per default, and thought this may interfere with alsa? I uninstalled puslaudio and....still didnt make a difference.

Now Ive reinstalled Ubuntu 10.10 64bit for a fresh start and remade that asound.conf file (definitely think I need that.

Any suggestions? Ive been working on this for days and just cant figure it out! Something is probably wrong with alsa since aplay wont play anything...

PS: Speaker-test with aplay does send the static to the speakers...so sound CAN go through, but mythtv and aplay just wont have it.

Thanks for the help!

Best solution

November 25, 2010 3:49:11 AM

Would you mind telling us what hardware you're running?
Share
November 25, 2010 3:43:24 PM

Hey,

Thanks for the response! I really appreciate it. I was running the 880G chipset, but I think I just found out what happened.

I replaced the places in the asond.conf for card 1 and device 3 in the wrong place (just "digital"), but not in the "digital-hw" like it said. I replaced the "digital" by mistake (didnt see the -hw). Anyway, it seems to be working just fine now!

Btw, for anyone else having this problem, make sure after you modify the asound.conf file, you have to either restart your computer to have it take effect, or restart alsa.

You used to be able to use the command /etc/init.d/alsa restart or stop and start, but it doesnt seem like you can do this anymore.

To do this now, I just used "sudo alsa force-reload". Seemed to do the trick and save a reboot :) 

Thanks for the response Pyroflea btw! I really do appreciate it :) 
m
0
l
Related resources
November 25, 2010 10:27:01 PM

Nicely done. It's always stupid little things like that. I remember for phpVirtualBox (web interface for Virtual Box running on my server), I had the wrong port number (off by 1), and it wouldn't work. I spent hours pouring over the config file, finally noticed.
m
0
l
December 2, 2010 11:28:07 PM

Best answer selected by ansemx324.
m
0
l
December 2, 2010 11:28:56 PM

Haha it is always the stupid things like that... Anyway, thanks for your help! Youre the only one who replied :) . Therefore, best answer to you!
m
0
l
!