Sign in with
Sign up | Sign in
Your question

How can i connect this netbook to the internet to update drivers?

Tags:
  • Drivers
  • Ethernet Card
  • USB
Last response: in Linux/Free BSD
Share
February 13, 2011 6:41:23 AM

there is no Ethernet port

i get a ton of errors, one after the other, when trying to install manually with USB.

it is an HP mini 1000; not mine.

i got a usb to ethernet, but it required drivers that were, what do you know, windows only.

is there a usb to ethernet adapter that has native ubuntu support


:cry:  because i will probably not get a reply tonight

but :D  because the replies from the linux community are always so kind and understanding to OS newbishnish :kaola:  :love:  :love:  :love: 




PS. remember, this is a netbook, which makes everything all the more frustrating :kaola:  when used to a 5760 x 1080p res on screen with a real mouse :fou: 

More about : connect netbook internet update drivers

February 13, 2011 6:42:10 AM

oh yea, the internet drivers are the drivers i need to update

the wifi ones
m
0
l
February 13, 2011 3:27:27 PM

What chipset is the wireless? If you do not know please post output of "lspci" and "lsmod"
m
0
l
Related resources
February 13, 2011 5:47:44 PM

the Broadcom b43

BCM4312

those are the chips that show up from either search... there is no way i could sit here and type the whole post :D 

i know drivers are under an already existent ubuntu respiratory so i just need a linux native usb to ethernet adapter for a quick and seamless transfer of the update

i hate installing ubuntu on devices with no Ethernet ports
m
0
l
February 13, 2011 8:25:40 PM

this method gives me error messages while trying to use the "make" command
m
0
l
February 15, 2011 11:10:56 AM

skittle said:
Oh you do not have gcc and other dev tools

Please read this page. Specifically the part under " no internet access"

https://help.ubuntu.com/community/WifiDocs/Driver/bcm43...

k, thanks :D 

this netbook is extremly annoying to work on because of that touchpad and the small, low pixel density screen. :fou: 
m
0
l
February 15, 2011 5:29:20 PM

Not mine -- did this when researching for another netbook
________________

"Broadcom problems

First thing, I see you're using the b43 driver. While this does now support the card you need to pass a couple options to the driver for it to work

See if this helps
Code:

modprobe -r b43
modprobe b43 pio=1 qos=0

If so add to /etc/modprobe.d/modprobe.conf the following line
Code:

options b43 pio=1 qos=0

I recall reading somewhere the downside to this is that it hurts performance for protocols other than http.
---------------------------------------------------------------------------------------------

Which version of Ubuntu are you using? For any current version, if you have a wired internet connection available, do
Code:

sudo apt-get install bcmwl-kernel-source


If you do not have an internet connection, the necessary drivers are on the installation CD.


EDIT: Installation instructions for online and offline here:

https://help.ubuntu.com/community/WifiDocs/Driver/bcm43...

---------------------------------------------------------------------------------------------

You have two different drivers loading, b43 and ndiswrapper, which will conflict. Also, while I think b43 is beginning to support this card, the wl driver should work better.

If you can get a wired connection do
Code:

sudo apt-get install bcmwl-kernel-source bcmwl-modaliases

Open the file /etc/modprobe.d/blacklist.conf with the text editor of your choice, ie
Code:

gksudo gedit /etc/modprobe.d/blacklist.conf

Add the following two lines
Code:

blacklist b43
blacklist ndiswrapper

Make sure there isn't a line reading
Code:

blacklist wl

Reboot and it should work. If not, check the output of
Code:

lsmod | grep wl

If there is no output, the module isn't loading. Load as so
Code:

sudo modprobe wl

Make it load at boot
Code:

echo "wl" | sudo tee -a /etc/modules

__________________
Broadcom 4312

Depending on the distro (and version) you are using, the Broadcom 4312 wireless chipsets are frequently incompatible with the b43 kernel module and the ssb module on which b43 depends. The Broadcom wireless chipset for the 4312 under these circumstances conflicts with the ssb module.

This may work for you:
First, pass this parameter when booting (or add it to the menu.lst): ssb.blacklist=1 *
Second, you'll need to install and enable the proprietary Broadcom STA driver.
Third, you will need to be certain that both the b43 and ssb drivers are blacklisted. Add:
ssb
b43
to the end of /etc/modprobe.d/blacklist.conf

When you reboot, the installed driver scripts should configure the system to load the wl driver automatically at boot. You can check this with the command:
lsmod | grep wl
which should return a line for wl.
You can also determine which interface your wireless is assigned to with the command:
ifconfig -a
-------------------------------------
* "pass this parameter when booting"
means type

Quote:
ssb.blacklist=1

at the bottom of boot screen when grub screen shows which kernel of operating system to boot.

---------------------------------------------------------------------------------------------

Mint is a great distro to start with
No, don't change distros. Mint should be easy to configure.
When your Grub screen appears, you should be able to press the "e" key to edit.
Then there should be a line of instructions for the computer to read in order to boot the computer.
You should be able to type "ssb.blacklist=1" on that line of instructions, and then I believe you enter "b" to boot (whatever the screen states to boot that edited line.

To download the STA driver. you will need an internet connection, so you will have to connect a cable up. Then open the synaptic package manager and search for the Broadcom STA driver. Synaptic will install and configure the driver modules for you. But now that I think about it, doesn't Mint have an install proprietary drivers applet? If so select the STA driver (while connected to the internet) and install it.

The reason for the error in activating is most likely that the wireless card can not be detected because the ssb or b43 module has already connected to the device, therefore not allowing the device to be opened by another application.

So, you need to blacklist those modules in order to keep the connection to the wireless device open for the STA driver to connect to. You do this by stopping the initialization scripts from loading those drivers in the modprobe.d directory which is accessed during the boot process. To do this:
Open up a terminal window (Gnome Terminal, XTerminal, or whatever is available in your menu). Type "su" you will be asked for the root password. Then type the file manager you use (Nautilus if Gnome, Konqueror or Dolphin if KDE, Thunar if XFCE - not sure which Mint you are using). You will then be superuser browsing your folders (BE VERY CAREFUL NOT TO DELETE STUFF!).
Go to the "File System" directory. Open the "etc" folder. Open the "modprobe.d" folder. There will be a file named "blacklist.conf", right click and open with a text editor. Scroll to the bottom and type in:
ssb
b43
(Some distros require "blacklist ssb" and "blacklist b43" you will see other entries in that file, just make your entries similar. Then save the file and close your file manager and terminal that you have open as superuser, to avoid doing something accidentally.

Then reboot, cross your fingers, and if it works you'll owe me a pint of Guinness stout."
m
0
l
February 17, 2011 8:08:48 PM

i won't have access to the netbook until mon. so i will see if it works now

nothing works the way it is supposed to with me though :D 
m
0
l
!