Sign in with
Sign up | Sign in
Your question

Realtek for ubuntu

Last response: in Linux/Free BSD
Share
February 25, 2011 8:50:46 PM

Hello....need help with getting Ubuntu 10.04 to connect to the internet...Once in a while, it will connect to the LAN...but will never load a web page.

More about : realtek ubuntu

Anonymous
February 25, 2011 9:15:54 PM

This topic has been moved from the section Wireless Networking to section Linux/Free BSD by Grumpy9117
m
0
l
February 25, 2011 10:36:16 PM

What hardware are you using? Specifically the network adapter and router.
m
0
l
Related resources
February 27, 2011 5:22:26 PM

Try to set it up manually rather than using DHCP.
m
0
l
March 6, 2011 11:45:22 AM

PreferLinux said:
Try to set it up manually rather than using DHCP.


Thanks for your response...I have it set to ignore DHCP...it still doesn't work. I tried using NDISGTK...no luck...tried ndiswrapper alone...no luck. I'm looking for a wireless network adapter that is compatible with both Windows and Linux.
m
0
l
March 6, 2011 11:52:26 AM

Ndiswrapper uses the windows driver to communicate with the wireless card - most wireless cards do have some level of support in linux natively. What card are we dealing with?

Are you using wireless security (WPA2?) You'll probably need WPAsupplicant instead of wirelesstools to connect to your network.
m
0
l
March 6, 2011 4:18:15 PM

Thanks for the responses...I am very new to Ubuntu...but I like what I've seen so far, except for this problem getting online. I'm sure glad I didn't do away with Windows yet!

My network adapter is: Realtek RTL8187B Wireless 802.11b/g 54Mbps USB 2.0 Network Adapter



Port_#0007.Hub_#0006


Thanks again for the help...
m
0
l
March 6, 2011 4:20:03 PM

I forgot to add that I am using no security. No DHCP, either.
m
0
l
March 7, 2011 11:33:22 AM

https://help.ubuntu.com/community/WifiDocs/Device/Realt...

Scroll way down to the bottom of the page and read under section option 2.

The driver is built into the system already. Here's what I would do. Boot the system with the usb wireless unplugged, login and open a command prompt (terminal). Plug in the adapter, wait 30 seconds and then type 'sudo dmesg' it may ask for your root password or not. It will scroll alot of information, but we're only interested in the last handful of lines, it SHOULD say that it detected the device plugged in and setup. Next type 'sudo ifconfig' and you should have several entries, you should have one that says wan0, and it should have an IP address.

Additionally, I recommend you activate DHCP before these steps, that way it will connect and get the proper addresses.

Traditionally USB based wireless has been problematic in linux. The support is there, but with such a vast number of adapters using the same chips, each has the potential to require minor driver variations, and thats just too much for a volunteer effort to support.
m
0
l
!